Download it now!
Bug 32185 - UI - Untranslated WRITER dialog for 'Format -> Title Page'
Summary: UI - Untranslated WRITER dialog for 'Format -> Title Page'
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: All Windows (All)
: medium major
Assignee: Fridrich Strba
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 31865
  Show dependency treegraph
 
Reported: 2010-12-07 08:02 UTC by Olivier Hallot
Modified: 2010-12-28 21:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Menu entry untranslated for title page (21.09 KB, image/png)
2010-12-07 08:03 UTC, Olivier Hallot
Details
untranslated dialog in pt-BR (19.55 KB, image/png)
2010-12-07 08:04 UTC, Olivier Hallot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2010-12-07 08:02:20 UTC
Hi

The title page dialog in Writer is untranslated for pt-BR. However, it was translated in pootle.

See attached images to get to it.
Comment 1 Olivier Hallot 2010-12-07 08:03:35 UTC
Created attachment 40870 [details]
Menu entry untranslated for title page

Format - Title Page
Comment 2 Olivier Hallot 2010-12-07 08:04:24 UTC
Created attachment 40871 [details]
untranslated dialog in pt-BR

almost untranslated dialog in pt-BR.
Comment 3 Rainer Bielefeld Retired 2010-12-07 11:32:18 UTC
[Reproducible] with "LibreOffice 3.3.0 RC1 - WIN XP German UI  [OOO330m17 (build 3.3.0.1", so it seems to affect all localizations of the UI.
Comment 4 sophie 2010-12-08 02:41:23 UTC
Strange, it's translated in my French version. 
Strings in German are not translated, so it's ok if they appear in English, but not for pt_BR. 
Olivier Are you sure the .po file has been updated before the RC?
Comment 5 Olivier Hallot 2010-12-08 05:57:18 UTC
Sophie

To the best of my knowledge I try to keep pootle at the most updated status. I just went yesterday to update Kohei last-minute change.

I am sure I translated these strings when we moved from LO 3.3 testing.

Olivier
Comment 6 sophie 2010-12-08 06:32:10 UTC
I'm assigning it to Petr as it seems an integration issue. Just to make sure because we have an issue in FR too, are you on a Mac ? and if yes, could you check that it's ok on other OS. Thanks.
Comment 7 sophie 2010-12-08 06:33:40 UTC
Petr, please could you have a look, the .po and .sdf files are ok, but integration seems missing. Thanks
Comment 8 Petr Mladek 2010-12-08 09:44:06 UTC
I see the problem only on Windows. The strings are translated on Linux.

It seems that the libreoffice/build/po/lo-build-<lang>.po files were not applied during the Windows build at all.

I am going to nominate it as a blocker.

Fridrich, could you please have a look?
Comment 9 Michael Meeks 2010-12-28 07:31:34 UTC
Is this still an issue in RC2 ?
Comment 10 Olivier Hallot 2010-12-28 07:43:03 UTC
Not anymore, however another bug referes to string footprint in the dialog for some languages (Bug 32633)

This bug can be closed. Thx
Comment 11 sophie 2010-12-28 21:40:52 UTC
Closing.
Comment 12 sophie 2010-12-28 21:41:16 UTC
.