Bug Hunting Session
Bug 32241 - Vertical alignment for Math object in Writer
Summary: Vertical alignment for Math object in Writer
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-08 13:51 UTC by RGB
Modified: 2014-05-01 22:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
.odt file to reproduce the problem (12.38 KB, application/vnd.oasis.opendocument.text)
2013-05-27 10:04 UTC, Frederic Parrenin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description RGB 2010-12-08 13:51:33 UTC
OOo DEV300m95 includes a patch that fix a long standing (9 years!) problem in Writer: automated vertical alignment for Math objects.
I think it is very important to add this patch to LibO also.
See the original issue for more information:
http://www.openoffice.org/issues/show_bug.cgi?id=972
Comment 1 TM 2011-02-25 21:57:59 UTC
This is a very serious problem for those who deal with mathematical equations very often, and after all, the solutions is already being implemented in OpenOffice.org. Is there any forecast when will this bug be fixed in LibreOffice?
Comment 2 TM 2011-02-25 22:04:15 UTC
Changed the relevant version to "LibO 3.3.1 release", and Platform to "All", "All".
Comment 3 MN 2011-03-09 06:46:57 UTC
Changed priority to "high", because this is a problem for several years awaiting a solution.

It is very important that Writer can properly align the objects of Math. As already indicated, the patch already exists.

Without this fix, typing documents with a large number of formulas becomes extremely laborious, because we are forced to manually align each formula.
Comment 4 Don't use this account, use tml@iki.fi 2011-03-09 07:08:32 UTC
I am sorry to disappoint you, but the bugzilla importance fields for enhancement requests don't really have much impact on what gets implemented.
Comment 5 MN 2011-03-13 11:12:03 UTC
I understand. Meanwhile, I hope that this feature be implemented in future versions. It is very important for scientists and teachers of mathematics.
Comment 6 RGB 2011-04-29 11:49:19 UTC
I can see this on 3.4 betas: under Tools → Options → LibreOffice Writer → Formatting aids → Layout assistance: "Math baseline alignment" is enabled by default :)
So I mark it as "resolved → fixed" (I hope it is OK I'm doing this...)
Comment 7 MN 2011-05-22 05:22:51 UTC
Thanks!

However, just as happened with OpenOffice, you need to make some adjustments in the alignment.

I tested the alignment in version 3.4 RC1.

In fact, the alignment only occurs effectively when the formula is in edit mode. After exiting the editing mode, it loses part of the vertical alignment, getting the formula a few mm above or below the base line.

Even so, this has been a great progress.
Comment 8 Axel Niedenhoff 2012-10-26 16:36:31 UTC
I can add an example document from LO 3.6.2 if needed.
Comment 9 Frederic Parrenin 2013-05-27 10:04:12 UTC
Created attachment 79839 [details]
.odt file to reproduce the problem
Comment 10 Frederic Parrenin 2013-05-27 10:04:57 UTC
Indeed, there is still a problem with the vertical alignment of formulas.
In the attached example, the vertical alignment of the second formula is wrong.
By the way, why not defining a notion of base line of objects and to add the option to align the base line of the object with the base line of the text?
The current solution seems to be sub-optimal.
Comment 11 Jean-Baptiste Faure 2014-05-01 22:01:49 UTC
Works as expected in LibO 4.1.6 (generic Linux version) and LibO 4.2.5.0.0+.
You need to edit each formula to restore the alignment on the base line of the text.

Closing as WorksForMe. If something related to this does not work in a further version, please file a new bug report.

Best regards. JBF