Bug Hunting Session
Bug 32335 - Under Traditional Chinese environment, the installation process showed bizarre characters.
Summary: Under Traditional Chinese environment, the installation process showed bizarr...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.3.0 RC4
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 38256 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-12 05:42 UTC by Jeff Tong
Modified: 2011-12-13 09:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The problem before installation file extraction (44.45 KB, image/png)
2010-12-12 05:42 UTC, Jeff Tong
Details
3.4 beta 2 installation under Traditional Chinese Windows 7 (97.73 KB, image/jpeg)
2011-04-22 04:58 UTC, Jeff Tong
Details
wrong encoding (29.47 KB, image/jpeg)
2011-04-27 14:12 UTC, Stephen
Details
Simplified Chinese was shown under Win7 Traditional Chinese version (23.61 KB, image/png)
2011-06-22 07:51 UTC, Jeff Tong
Details
NSIS initial screen on zh-TW system (59.63 KB, image/png)
2011-06-28 23:53 UTC, Andras Timar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Tong 2010-12-12 05:42:33 UTC
Created attachment 41034 [details]
The problem before installation file extraction

I am a Traditional Chinese user.

The installation process showed bizarre characters before file extraction. I think it displayed Simplified Chinese instead of Traditional Chinese because we are all used to it.

After file extraction, the process showed English only.

Luckily, nothing went wrong after installation. Traditional Chinese interface shows up normally.

Thanks for your concern.
Comment 1 Jeff Tong 2010-12-12 22:33:09 UTC
Today, I found that the problem may be on Windows 7 (64-bit) only. I did not find the same problem on Windows XP (32-bit).
Comment 2 Cédric Bosdonnat 2010-12-13 05:46:29 UTC
Fridrich, could that be a localization problem or is it windows packager issue?
Comment 3 Jeff Tong 2011-01-15 05:35:40 UTC
The problem was solved under rc2 but it is back under rc3!!
Comment 4 Jeff Tong 2011-01-22 06:38:32 UTC
I have just installed rc4. The problem is the same.
Comment 5 Noel Power 2011-01-24 02:49:12 UTC
maybe tor might have some ideas ( or be interested ) adding him to cc
Comment 6 Jeff Tong 2011-02-11 05:27:00 UTC
I have just tested 3.3.1 rc1. I am very disappointed because the problem was not yet solved.

From this month on, I teach students using Calc with LibreOffice instead of OpenOffice.org but they have to use 3.3.0 rc2 which is the only version showing proper tradition Chinese during installation.
Comment 7 Jeff Tong 2011-04-22 04:58:47 UTC
Created attachment 45947 [details]
3.4 beta 2 installation under Traditional Chinese Windows 7

I have just tested 3.4 beta 2. I have to surrender. Although the text in the screen is English, the buttons remains Simplified Chinese code under Tradition Chinese environment. In short, the installation process wrongly displays Simplified Chinese instead of Traditional Chinese.
Comment 8 Jeff Tong 2011-04-22 05:05:36 UTC
To avoid the installation process of Libre Office, I have to teach my student using the service provided by ninite.com because they do not know how to do if they download file directly from www.libreoffice.org with Windows 7. That is totally unacceptable and ridiculous.
Comment 9 Stephen 2011-04-27 14:10:19 UTC
(In reply to comment #8)
> To avoid the installation process of Libre Office, I have to teach my student
> using the service provided by ninite.com because they do not know how to do if
> they download file directly from www.libreoffice.org with Windows 7. That is
> totally unacceptable and ridiculous.

For your information, I also suffered from the wrong encoding of the install packages (see wrong_encoding.jpg) of 3.3.2. What I suggest as a workaround is:

1. Install the package, choose a special path (shorter path) when asked for a path to extract instead of the default path, for editing a file inside later on.
2. After extraction, the installation package will move on to setup the software. When it starts to install and ask to click the "Next(N)" button (at the screen wrong_encoding.jpg), click "Cancel(C)" to the setup.
3. Go to the special folder where the installation package just extracted. Find "setup.ini" in that folder.
4. Editor the file in an editor, find the "default=..." under "[languages]", change to "default=1028", in your case, if it is "default=1033" or "default=2052"
5. Save the file
6. Double click the "Setup.exe" in the same folder to setup again, now it should show the language in correct encoding.

Hope this help.

ps. LibreOffice should let user to choose their language before installation instead of detecting the system's encoding, which is not accurate.

(for QA team, My system is Windows Xp sp3 Simplified Chinese)
Comment 10 Stephen 2011-04-27 14:12:09 UTC
Created attachment 46132 [details]
wrong encoding
Comment 11 Don't use this account, use tml@iki.fi 2011-04-28 01:22:17 UTC
So in the initial comment from Jefff we have a Traditional Chinese user who sees Simplified Chinese on the initial dialog of the installer. (I.e. the dialog that says "Thank you for downloading LibreOffice x.x. The installation files must be unpacked etc". That dialog is from the NSIS wrapper.) Then the actual MSI installer shows only English for Jeff.

I.e. already the initial comment describes two *separate* problems.

This was in LibreOffice 3.3.0 beta ?. Then in later comments he says the problem (which one? that the first (NSIS) dialog was in Simplified Chinese, or that the subsequent dialogs (MSI) was in English? Or both?) went away in rc2, but came back in rc3 and rc4 (both problems? or which one?)

Then in comment #7 Jeff describes what the initial installer dialog (from NSIS) shows in 3.4 beta2. Now a different symptom (mixed English and Chinese), and likely caused by a totally different bug (the known problems with localisation in 3.4 beta 1 and 2).

As if it wasn't confusing enough already, then in comment #8 another person, Stephen, who uses Simplified Chinese complains about 3.3.2, and shows one of the later installer (MSI) dialogs. He doesn't say what's wrong with it, though. I am afraid I am not able to tell, I don't know Chinese, and I certainly can't differentiate between Simplified and Traditional Chinese. (I would have guessed it is Japanese, even, in Stephen's screenshot, but I am not sure.) But anyway, Stephen, please note what the initial comment in this bug report describes, and what the title says: "Under *Traditional* Chinese environment. Does that really match your situation? You say that your system is Simplified Chinese.

So this bug report is fairly confusing...
Comment 12 Don't use this account, use tml@iki.fi 2011-04-28 02:29:30 UTC
Note that when I say "initial dialog", I actually mean the three or so initial dialog windows, where it tells the installer files have to be unpacked, asks for where to unpack them, and does the unpacking. Those are the dialogs handled by the NSIS installer wrapper. The rest, the "Welcome to the installation" of whatever it says, are handled by Windows Installer (a.k.a. MSI).
Comment 13 Stephen 2011-04-30 06:44:36 UTC
(In reply to comment #12)
> Note that when I say "initial dialog", I actually mean the three or so initial
> dialog windows, where it tells the installer files have to be unpacked, asks
> for where to unpack them, and does the unpacking. Those are the dialogs handled
> by the NSIS installer wrapper. The rest, the "Welcome to the installation" of
> whatever it says, are handled by Windows Installer (a.k.a. MSI).

Asking path... - NSIS installer wrapper (I call it NSIS from now on)
Welcome to the installation... - Windows Installer (I call it MSI from now on)

What Jeff and I mean "before installation file extraction..." is NSIS;
and "after file extraction/move on to setup the software" mean MSI.

In Jeff's "Description":
>The problem before installation file extraction

>I am a Traditional Chinese user.

>The installation process showed bizarre characters before file extraction. I
>think it displayed Simplified Chinese instead of Traditional Chinese because we
>are all used to it.

NSIS showed bizarre characters

>After file extraction, the process showed English only.

MSI showed English only

>Luckily, nothing went wrong after installation. Traditional Chinese interface
>shows up normally.

Application started up in correct encoding.

--------------

Attachment "The problem before installation file extraction" is NSIS showing wrong encoding:
"lang101=2052,trans_zh-CN.mst" for "lang102=1028,trans_zh-TW.mst"

Attachment "3.4 beta 2 installation under Traditional Chinese Windows 7" is also NSIS showing wrong encoding:
"default=1033" for "lang102=1028,trans_zh-TW.mst"

--------------

In my case (3.3.2), NSIS showed in English (wrongly 1033 for 2052), MSI (seemed wrongly 1041 for 2052)

My attachment "wrong encoding" is showing MSI in wrong encoding.

*I tested 3.4 beta 3 today, NSIS now shows correct encoding (2052), but MSI still shows incorrect encoding (still seemingly 1041 for 2052).

*For you reference, I also suffered from the same problem when I installed Java runtimes, so I suppose the encoding detection method less reliable than User manual choices

(for QA team, My system is Windows Xp sp3 Simplified Chinese 32-bit)
Comment 14 Stephen 2011-04-30 06:57:40 UTC
*One more minor point is, actually I would like to install an English version on my Simplified Chinese System as I consider it save of resources (Fonts, GUI, etc)
Comment 15 Jeff Tong 2011-06-22 07:07:02 UTC
I found that 3.3.2 was no difference. While installing, there was no problem under WinXP but wrong encoded characters were showing under Win7.
Comment 16 Jeff Tong 2011-06-22 07:44:39 UTC
(In reply to comment #15)
> I found that 3.3.2 was no difference. While installing, there was no problem
> under WinXP but wrong encoded characters were showing under Win7.

I am sorry that I made a mistake and there was indeed a little difference.

I have just tried installation of 3.3.3 (not 3.3.2) again under Win7. The file extraction process showed wrong encoded characters but the installation process showed normal Simplified Chinese instead of English under Traditional Chinese environment. Luckily, everything was fine after installation.
Comment 17 Jeff Tong 2011-06-22 07:51:11 UTC
Created attachment 48289 [details]
Simplified Chinese was shown under Win7 Traditional Chinese version

Under Traditional Chinese Win7, normal Simplified Chinese was shown in installation dialog.
Comment 18 Andras Timar 2011-06-27 11:02:14 UTC
(In reply to comment #11)
> So this bug report is fairly confusing...

I reproduced the bug. I think NSIS itself has a bug. On Traditional Chinese Windows 7 64 bit it loads the Simplified Chinese strings. But NSIS is not a Unicode application. Simplified Chinese text is encoded in Windows code page 936. When NSIS decodes it to code page 950 (in Traditional Chinese environment), the result is garbage.

Then NSIS continues to think that it is under Simplified Chinese environment, and installs Simplified Chinese version. See bug 38256.

In comment 3: The problem was solved under rc2 but it is back under rc3
Maybe those builds were not produced on the same computer and used different versions of NSIS.
Comment 19 Andras Timar 2011-06-28 23:53:48 UTC
Created attachment 48541 [details]
NSIS initial screen on zh-TW system

I built a multi language installer (en-US, de, hu, zh-CN, zh-TW) on Windows 7 64-bit with NSIS 2.46. 
I started my installer under system locale Chinese (Hong Kong), display language Chinese (Hong Kong). It showed the correct characters. 
I started official LibO 3.4.1 RC3 installer on the same system. It showed corrupted characters. The problem is not in LibreOffice sources but in the build environment that produces official builds.
Comment 20 Andras Timar 2011-06-28 23:56:49 UTC
*** Bug 38256 has been marked as a duplicate of this bug. ***
Comment 21 Andras Timar 2011-12-13 09:47:37 UTC
This was an NSIS and/or build environment bug. We don't use NSIS beginning with LibreOffice 3.5.