Bug Hunting Session
Bug 38256 - Setup misuse Simplified Chinese in Traditional Chinese Windows (Hong Kong)
Summary: Setup misuse Simplified Chinese in Traditional Chinese Windows (Hong Kong)
Status: RESOLVED DUPLICATE of bug 32335
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.4.0 RC1
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-13 08:32 UTC by km307
Modified: 2011-12-22 05:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
setup log file collected in TC Windows 7 (64bits) (29.41 KB, text/plain)
2011-06-26 07:32 UTC, km307
Details

Note You need to log in before you can comment on or make changes to this bug.
Description km307 2011-06-13 08:32:08 UTC
Details as below:
1. Windows 7 SP1 (64bits) with location set to Hong Kong Traditional Chinese (LCID 3076).
2. LibreOffice 3.40, this issue also occur on 3.3.2
3. Setup will use Simplified Chinese during installation and Simplified Chinese LibreOffice is installed.

To overcome the problem, after the setup decompress the files, I have to edit the setup.ini and make the change, "lang102=3076,trans_zh-TW.mst".

In addition, Windows in Macao SAR (LCID  5124) may also have the same issue.

Other than adding the two LCIDs in the setup.ini, it may also be good to allow user to select the language during installation.
Comment 1 Andras Timar 2011-06-21 08:11:52 UTC
started
Comment 2 Andras Timar 2011-06-21 08:55:56 UTC
@km307: Can you please run setup.exe /l log.txt (you can stop the installation when the Wizard starts) and attach log.txt to this bug. Thanks.
Comment 3 km307 2011-06-26 07:32:47 UTC
Created attachment 48441 [details]
setup log file collected in TC Windows 7 (64bits)

I have attached the log file. But there is an interesting finding.
If I ran the LibO_3.4.0_Win_x86_install_multi.exe and allow it to install, it will install the Simplified Chinese version (as said before).
But if If I stop the wizard after it has extract the files and then run the extracted setup.exe (with or without the /l log.txt), this time it will display and use Traditional Chinese.
Comment 4 Andras Timar 2011-06-28 23:56:49 UTC

*** This bug has been marked as a duplicate of bug 32335 ***
Comment 5 Björn Michaelsen 2011-12-22 05:50:27 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.