Bug 32848 - LibreOffice for OS X should be available in the Mac App Store
Summary: LibreOffice for OS X should be available in the Mac App Store
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Mac OS X (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 51024 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-05 07:51 UTC by MacPorts.freedesktop
Modified: 2015-08-23 14:24 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MacPorts.freedesktop 2011-01-05 07:51:48 UTC
It would ease deployment and updates in the Free section.

The Mac App Store will be available January 6, 2011.

http://www.apple.com/mac/app-store/
Comment 1 Björn Michaelsen 2011-12-23 11:34:57 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Roman Eisele 2012-05-11 03:21:46 UTC
This enhancement request/proposal is still valid and, well, reasonable, therefore changed the 'Status' field back to 'NEW'.

@Thorsten Behrens:
I have inserted you as Mac expert into the CC field. Could you please take a look at this proposal? I don't know all the possible advantages and disadvantages the proposal may have. I just want to invite you to leave a short comment telling if this idea has already been discussed within TDF and/or LibO developers, if it has been rejected for some reasons, or if it could be discussed some day in the future. IMHO this would be interesting for many Mac users. Thank you.
Comment 3 Thorsten Behrens (CIB) 2012-06-05 09:43:53 UTC
This is not possible as long as LibreOffice is licensed under LGPLv3 (or all contributors accept submission to the AppStore). Thus this is currently unfixable / invalid on a technical level.
Comment 4 Roman Eisele 2012-06-06 01:10:17 UTC
(In reply to comment #3)
> This is not possible as long as LibreOffice is licensed under LGPLv3 (or all
> contributors accept submission to the AppStore). Thus this is currently
> unfixable / invalid on a technical level.

@Thorsten:
Thank you for clarification! This saves us any further discussion.
Comment 5 Roman Eisele 2012-06-14 08:12:13 UTC
*** Bug 51024 has been marked as a duplicate of this bug. ***
Comment 6 Don't use this account, use tml@iki.fi 2013-08-02 12:12:41 UTC
Note however that NeoOffice, which is licensed using an even more (insert suitable adjective) license (GPL), and includes some code snippets from LibreOffice, *is* going to be available in the Mac App Store soon, according to posts by their developer(s) on their forum.
Comment 7 Don't use this account, use tml@iki.fi 2013-08-12 07:41:26 UTC
FYI, NeoOffice is now in the Mac App Store: https://itunes.apple.com/us/app/neooffice/id639210716 .
Comment 8 Alex Thurgood 2013-09-02 14:22:04 UTC
And look at the sacrifices they had to make in order to get it allowed in the AppStore :

http://www.neooffice.org/neojava/fr/macappstore.php

- no embedded hsqldb database functionality ;
- no Java framework or Java extension functionality ;
- no Python extension or Python framework functionality
- limited dictionary and language support
- virtually no integrated media support

Frankly, is it worth it ?

Alex
Comment 9 lists 2013-09-02 15:24:44 UTC
That depends:
- for the current users: probably no
- if you want to reach the masses: probably yes. My father bought Apple Pages because he couldn't find LibreOffice in de Mac OSX AppStore (THE place to look for Apps).
Comment 10 Tor Lillqvist 2013-09-02 16:05:05 UTC
Note that if one embeds Java in an app there is no problem. Not trivial, but not rocket science either. See http://intransitione.com/blog/take-java-to-app-store/ . Whether that makes sense or not, no idea.
Comment 11 Christopher Chavez 2014-07-19 04:35:04 UTC
It appears that the effort to dual license LibreOffice under Mozilla Public License v2.0 is such that it will allow for Mac App Store distribution (overturning comment 3). See http://www.libreoffice.org/about-us/licenses/ and https://wiki.documentfoundation.org/Development/Re-Basing#Why_go_with_the_MPLv2_.3F
Comment 12 Nicholas 2014-10-01 08:42:22 UTC
Has the dual licensing finished? I don't really know how it happens.
Anyway, I believe having LO in the Apple Mac Store would really help get LO out to users :).
Comment 13 Cor Nouws 2014-12-24 15:04:07 UTC
(In reply to Nicholas from comment #12)
> Has the dual licensing finished? I don't really know how it happens.
> Anyway, I believe having LO in the Apple Mac Store would really help get LO
> out to users :).

Yes, licensing shouldn't be a problem any more.
It's mostly climbing over the Apple-walls .. I'm pretty sure it's on the todo of some developers..
Comment 14 Alex Thurgood 2015-01-03 17:38:35 UTC
Adding self to CC if not already on
Comment 15 Cor Nouws 2015-08-23 14:23:22 UTC
in the mean time it is available there
 https://itunes.apple.com/us/app/libreoffice-vanilla/id921923693?mt=12