Bug 33226 - [FILEOPEN/FILESAVE] EPUB Documents
Summary: [FILEOPEN/FILESAVE] EPUB Documents
Status: RESOLVED FIXED
Alias: None
Product: Document Liberation Project
Classification: Unclassified
Component: General (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Miklos Vajna
URL: https://wiki.documentfoundation.org/EPUB
Whiteboard: target:6.0.0
Keywords:
: 103993 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-17 23:22 UTC by Kenney Phillis Jr
Modified: 2018-02-01 03:39 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kenney Phillis Jr 2011-01-17 23:22:33 UTC
Add support for Opening and saving of Epub documents. The specification appears to be an easy modification to the html output engine. As for details, this will loosely wrap around the html editor and writer documents. The essential part of this file format is that they are all a zip file containing a Manifest, images, sounds and  html text. The specifications are already available online for free, and multiple ebook readers make use of this file format. Also, as a  side note, this supports DRM, however, it's easy to identify which files use this.

anyways, for reference, look at the following standards outlined on the International Digital Publishing forum (IDPF)... Open Publication Structure (OPS), Open Packaging Format (OPF), and Open Container Format (OCF). These essentially outline how an epub file is to be created.


References:

International Digital Publishing Forum: (EPUB Maintainers)
http://www.idpf.org/

EpubCheck: (epub validation tool)
http://code.google.com/p/epubcheck/

Sigil eBook Editor (sample epub editor):
http://code.google.com/p/sigil/

Electronic Publication (EPUB, current format, wikipedia):
http://en.wikipedia.org/wiki/EPUB

Open eBook: (Legacy format, wikipedia)
http://en.wikipedia.org/wiki/Open_eBook
Comment 1 jay.talbot 2011-01-30 15:51:18 UTC
I would also like to vote for this feature to be added. It would be a great help to export straight to ePub instead of using a third party converter.
Comment 2 Don't use this account, use tml@iki.fi 2011-01-31 03:49:21 UTC
Voting doesn't help, offering to actually help in writing code does.
Comment 3 jay.talbot 2011-03-01 14:37:38 UTC
(In reply to comment #2)
> Voting doesn't help, offering to actually help in writing code does.

If I was a coder, I would offer. I'd be glad to help test the changes, but that's about all I can do right now.
Comment 4 Björn Michaelsen 2011-12-23 11:43:11 UTC Comment hidden (obsolete, spam)
Comment 5 Samuel Mehrbrodt (CIB) 2013-10-03 08:48:01 UTC
You can "vote" here: http://freedomsponsors.org
Comment 6 Urmas 2013-10-03 14:07:20 UTC
I don't think it's feasible. The EPUB document can have an arbitrary structure, with improper editing making it unusable. LO can generate XHTML output which is to be processed by specialized editors aware of EPUB structure and device requirements.
Comment 7 Samuel Mehrbrodt (CIB) 2013-10-03 14:22:06 UTC
Well, we could make it an export-only format like PDF.
I think that's doable.
Basically it's XHTML with a subset of CSS and some meta-information packed in a defined folder-structure as a ZIP-File.
Comment 8 Samuel Mehrbrodt (CIB) 2013-10-31 09:21:28 UTC
There are two extensions for exporting EPUB Documents:
  http://extensions.libreoffice.org/extension-center/elaix
  http://extensions.openoffice.org/de/project/writer2epub

Maybe we can consider bundling one of them with LibreOffice.
Comment 9 Robinson Tryon (qubit) 2014-04-08 15:24:27 UTC
I just created a wiki page to cover EPUB topics relevant to
* LibreOffice
* The Document Liberation Project

https://wiki.documentfoundation.org/EPUB
Comment 10 Bastián Díaz 2014-05-03 07:48:13 UTC
Sounds like a good idea. Read a PDF, ODT or DOCX format in a mobile device is very complicated. Instead, the ePub format is ideal for display or just to check the status of a report, because if you want to edit, you can use LO from a desktop computer.
Comment 11 Robinson Tryon (qubit) 2014-08-13 02:38:26 UTC
(In reply to comment #10)
> Sounds like a good idea. Read a PDF, ODT or DOCX format in a mobile device
> is very complicated. Instead, the ePub format is ideal for display or just
> to check the status of a report, because if you want to edit, you can use LO
> from a desktop computer.

To do what you're describing would require very good round-trip support for EPUB in LibreOffice. I think that's something we can aim for as a future goal, but I expect the initial EPUB export in LibreOffice will be much more limited, and imagine that the import/export process is likely to remove or change some of the internal structure of a given EPUB document.
Comment 12 Massimo Tallarigo 2014-11-20 15:16:03 UTC Comment hidden (off-topic)
Comment 13 Robinson Tryon (qubit) 2014-11-20 15:40:45 UTC
(In reply to Massimo Tallarigo from comment #12)
> Hi, every tme I try to install the suggested update for writer2epub I get
> the following message:
> Error while installing extension writer2epub.oxt. The error message is:

Hi Massimo,
For bug reports about an extension, please talk to the developer directly, e.g. http://writer2epub.it/en/
Comment 14 Buovjaga 2016-11-24 11:03:33 UTC
*** Bug 103993 has been marked as a duplicate of this bug. ***
Comment 15 haevalencia 2017-06-13 07:36:16 UTC
I think the focus should be on creating a method for exporting to ePUB from Writer like PDF. This is how other software like Pages or extensions for LibreOffice works.
Comment 16 Miklos Vajna 2017-12-06 15:33:23 UTC
https://vmiklos.hu/blog/basic-epub3-export.html and https://vmiklos.hu/blog/epub3-improvements.html implements this. For particular follow-up bug/feature requests, please open individual bugs.