Download it now!
Bug 33258 - regardless of UI language always en wikihelp is launched
Summary: regardless of UI language always en wikihelp is launched
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
3.3.0 RC3
Hardware: All All
: medium normal
Assignee: Jan Holesovsky
URL:
Whiteboard:
Keywords:
: 33753 (view as bug list)
Depends on:
Blocks: 32894
  Show dependency treegraph
 
Reported: 2011-01-18 13:45 UTC by Andras Timar
Modified: 2011-02-10 05:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Fix for the bug. (1.33 KB, patch)
2011-02-02 00:31 UTC, Jan Holesovsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2011-01-18 13:45:05 UTC
When Wikihelp is invoked from LibreOffice 3.3 RC3 URL always contains Language=en parameter, even when English language is removed by the installer on Windows.
Comment 1 Rainer Bielefeld Retired 2011-01-18 22:28:25 UTC
Do we have any other WIKIHELP language than English?
Comment 2 Andras Timar 2011-01-19 00:45:02 UTC
Currently only English wikihelp is uploaded. However, if I press F1 in Hungarian LibreOffice, I expect URLs like

http://help.libreoffice.org/swriter/52821?Language=hu&System=WIN#bm_id3147244

and not like

http://help.libreoffice.org/swriter/52821?Language=en&System=WIN#bm_id3147244
Comment 3 Cor Nouws 2011-02-01 15:36:51 UTC
..
Comment 4 Jan Holesovsky 2011-02-02 00:31:13 UTC
Created attachment 42848 [details]
Fix for the bug.
Comment 5 Jan Holesovsky 2011-02-02 05:47:58 UTC
Reviewed & pushed to libreoffice-3-3 by Thorsten.
Comment 6 Rainer Bielefeld Retired 2011-02-10 05:09:11 UTC
*** Bug 33753 has been marked as a duplicate of this bug. ***