Download it now!
Bug 33753 - [WIKIHELP] Better localisation for search and search results needed
Summary: [WIKIHELP] Better localisation for search and search results needed
Status: RESOLVED DUPLICATE of bug 33258
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium major
Assignee: Jan Holesovsky
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-31 02:09 UTC by Nino
Modified: 2011-12-22 05:49 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nino 2011-01-31 02:09:46 UTC
1) Wikihelp should be searchable within a given language. 
2) Results should be displayed in the desired language
3) Wiki UI should display localized to the same language

considered major as wikihelp is not usable for non-English-NL-only users.
Comment 1 Rainer Bielefeld Retired 2011-02-09 21:00:07 UTC
@Nino :
I can't understand the request. Currently WIKIHELP contents is available only in English, how can you expect search results in other languages?
Comment 2 Rainer Bielefeld Retired 2011-02-09 21:39:15 UTC
Please ignore the nonsense from my comment!

@Nino:
Please contribute a step by step instruction how to reproduce your problem!
Comment 3 Nino 2011-02-10 03:03:54 UTC
Preparing steps:
A) Start LibO without installed Online Help (so Wikihelp is activated by default)
B) Press F1 from whereever you are.
C) You are presented an English Help Page.

Ok, here you still can switch to your native language by clicking on its abbreviation in the language switch bar on the top. But this could/should be automated.

But then:
1) You want to perform a search:
1a) Enter a search item in the Wiki search field top right. 
1b) Searching for items which are identical in several languages you get results from all languages displayed. 
Here I'd like to have an option to search only within one or several languages.

2) Results from the above page is displayed in English (Page Titles)
Instead of displaying English Page Names, a search sould display localized Page Names (which seemingly do not exist, so instead, DISPLAYTITLE contents should be displayed here).

3) Wiki UI is English
As there are localized MediaWiki UIs for many languages, the user's locale should be desplayed by default. As a workaround, switching should be enabled without having to log in.

You see what I mean?
Comment 4 Rainer Bielefeld Retired 2011-02-10 05:09:11 UTC
@Nino:
Thank you for your explication.

To I see, this one is a DUP of
Bug 33258 - regardless of UI language always en wikihelp is launched

Thank you for your attention!

*** This bug has been marked as a duplicate of bug 33258 ***
Comment 5 Björn Michaelsen 2011-12-22 05:49:51 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.