Bug 33359 - LibreOffice not responding after choosing anything in Preferences.
Summary: LibreOffice not responding after choosing anything in Preferences.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 RC4
Hardware: x86 (IA32) Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-21 20:01 UTC by Phil Reilly
Modified: 2013-11-23 13:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Hang log....zipped. (23.96 KB, application/x-zip-compressed)
2011-01-21 20:08 UTC, Phil Reilly
Details
zip of crash dump (17.45 KB, application/zip)
2012-09-12 20:36 UTC, Phil Reilly
Details
crash dump (56.05 KB, text/plain)
2012-09-14 01:42 UTC, Phil Reilly
Details
crash dump (52.06 KB, text/plain)
2012-09-14 01:50 UTC, Phil Reilly
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Reilly 2011-01-21 20:01:15 UTC
Choose preferences then choose any option other than data entry (ok, new topic, etc) and spinning beach ball appears. Macbook OS X 10.6.6, does not occur on PPC 10.4.11. The problem occurs w/ or w/out the language pack installed. Mac Intel/English option installed. Uninstalled RC3 with Appcleaner? (it deleted .app, .plist and the folder- 3 items) then installed RC4. Hang log enclosed.
Comment 1 Phil Reilly 2011-01-21 20:08:19 UTC
Created attachment 42301 [details]
Hang log....zipped.

trying the attachment again. after zipping.
Comment 2 Noel Power 2011-01-24 02:23:59 UTC
macosx -> thorsten
Comment 3 Alex Thurgood 2011-01-24 03:17:20 UTC
Can not confirm. I have Mac OSX 10.6.6, LibO 3.3 RC4, and can cycle or click through the Preferences menu without any problem.

@Thorsten : didn't you mention in a previous bug report that this could be linked to activation of the Accessibility options in the Mac System Preferences ?


@Phil : do you have the system Accessibility options activated (e.g. like VoiceOver, etc) ?

Alex
Comment 4 Phil Reilly 2011-01-24 03:27:31 UTC
bingo!..disabled Universal Access and problem goes away on Snow Leopard...wonder if it appears on Tiger when I enable U.A.?
Comment 5 Roman Eisele 2012-08-25 09:52:32 UTC
(In reply to comment #4)
> bingo!..disabled Universal Access and problem goes away on Snow
> Leopard...wonder if it appears on Tiger when I enable U.A.?

So this is more or less yet another duplicate of our famous bug "47368", even if the present bug report mentions a hang instead of a crash. To keep track of all accessibility-related crash/hang issues, I mark this bug report as a duplicate of bug 47368.

*** This bug has been marked as a duplicate of bug 47368 ***
Comment 6 Roman Eisele 2012-09-12 09:24:43 UTC
Mac Accessibility Related Bugs Survey Results
---------------------------------------------

This bug is very similar to bug 52147 and bug 54282, which have been both
fixed by Michael Meek’s patch for bug 47368:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=3234b715b5a6d13ee673b41066eb565706be5ec9

Therefore it is very probable that this bug has been fixed by that commit, too, even if there is a little difference (the present bug is about a hang, but bug 52147 and bug 54282 are about crashes; but this difference may be explained easily by the different version of LibO and/or Mac OS X).

This is also indicated by the fact that the hang log attached to the present
bug contains many (recursive) references to hitTestRunner(); there was a
problem with endless (?) recursion of this function which should have been
fixed by the commit cited above.

This means in turn that this bug is correctly marked as a duplicate of bug
47368, which was fixed by the commit cited above.

This fix will appear in LibreOffice 3.6.2 and 3.7.0.
Comment 7 Roman Eisele 2012-09-12 09:26:33 UTC
@ Phil Reilly :

It would be very helpful if you could test if you can still reproduce this
crash with Universal Access enabled (!) and the upcoming LibreOffice 3.6.2; in a few days, a first release candidate will be available at

   http://www.libreoffice.org/download/pre-releases/

Or, if you are more adventurous, you can use the current daily build of
LibreOffice 3.6; it is available at

http://dev-builds.libreoffice.org/daily/MacOSX-Intel@3-OSX_10.6.0-gcc_4.0.1/libreoffice-3-6/current/

(Please note that the daily build should not be used for productive work.)


If you can NOT reproduce the hang with any of these versions, you could leave
a short note about that result in the present bug report. 

But IF you still CAN reproduce the same (!) hang with any of these versions,
please set the Status of this bug report to REOPENED, and try to describe in as
much detail as possible what exactly is necessary to get the hang -- step by
step, even mouse click by mouse click.

Thank you very very much in advance!
Comment 8 Phil Reilly 2012-09-12 20:08:58 UTC
I CAN reproduce in the current RELEASE version, will test nightly & report back!
Comment 9 Phil Reilly 2012-09-12 20:36:19 UTC
Created attachment 67063 [details]
zip of crash dump

3.6.3 crash, cannot reproduce as yet.
Comment 10 Roman Eisele 2012-09-13 15:46:20 UTC
Hello Phil Reilly,

thank you very much for your answer -- and for testing again -- and so fast!

However, I have a few questions (to allow me to analyze the issue):

* Did you have ”Universal Access” enabled when you reproduced the crash this time (like in comment #4)? And which option exactly? Or have you installed some window management utility/app on your Mac, like Cinch, Moom, RightZoom, ShiftIt ...?

* How exactly did you reproduce this crash? Could you please enumerate the steps necessary for that, step by step, mouse click by mouse click? This sounds unnecessary, but with such nasty bugs, even a mouse click can make a difference ...

(In reply to comment #9)
> 3.6.3 crash, cannot reproduce as yet.

* What does “cannot reproduce as yet” mean -- did you see the crash only once, and can not repeat it? Or what else?

Thank you again!
Comment 11 Phil Reilly 2012-09-13 16:24:56 UTC
UA enabled. The steps I used to crash 3.6.1 at will did not produce a crash in 3.6.3 nightly. I crashed 3.6.3 one time by clicking in the title bar somewhere. I was not able to reproduce this crash in about 30 min of trying.
Comment 12 Phil Reilly 2012-09-13 20:12:20 UTC
3.6.1 will not crash with the known keystrokes now that 3.6.3 nightly is installed.
Comment 13 Phil Reilly 2012-09-14 01:39:12 UTC
Ignore comment # 12
Comment 14 Phil Reilly 2012-09-14 01:42:09 UTC
Created attachment 67133 [details]
crash dump

moving around preference options without changing any.....BAM!
Comment 15 Phil Reilly 2012-09-14 01:50:45 UTC
Created attachment 67134 [details]
crash dump

moving from here to there.
Comment 16 Phil Reilly 2012-09-14 02:03:00 UTC
minimize to maximize with green ball on start page causes bad reproduction of the start page on 3.6.1 as well as 3.6.3. May not be the place to report it but oh well.
Comment 17 Roman Eisele 2012-09-14 08:30:16 UTC
When I compare the three new crash dumps Phil Reilly has attached to this report, all three seem very similar, therefore the crashes are probably caused by the same bug. However, they (a) look completely different from the original hang log for which Phil once created this bug report, and (b) the stack traces don’t contain any explicite references to Accessibility stuff.

Therefore, I think Phil experiences a new kind of crash, and this crash is not (or only slightly) related to the original issue for which this bug report was created. This original issue seems to be fixed (cf. Phil’s comment #11).

Therefore, I think we must handle these issues separately, by creating a new bug report for it.


@ Phil Reilly:

Thank you very much for all your tests and comments! However, because I see strong evidence that the crash you see in LibO 3.6.3 daily is a different issue, I ask you: could you please file a new, separate bug report for this new kind of crash? This would be very helpful!

In this new report please describe in as much detail as possible what is necessary to reproduce that new crash. You don’t need to attach the three crash dumps you have attached here there again; just mention them in your new report by typing three times "attachment" followed by the number of the attachments (67063, 67133, and 67134), and bugzilla will automatically turn this text into a link to your attachment, like in

  attachment 67063 [details]
  attachment 67133 [details]
  attachment 67134 [details]

(the word “ [details]” has been automatically added by bugzilla, you don’t need to enter it).

Thank you very very much!!!


Because the original issue for which this bug report was created seems to be really fixed, I mark this bug report again as a duplicate of bug 47368, just like explained in comment #6.

*** This bug has been marked as a duplicate of bug 47368 ***
Comment 18 Roman Eisele 2012-09-14 08:32:17 UTC
(In reply to comment #16)
> minimize to maximize with green ball on start page causes bad reproduction of
> the start page on 3.6.1 as well as 3.6.3. May not be the place to report it but
> oh well.

@ Phil Reilly:
A very interesting observation. I can not reproduce this for now, but we will see. Could you please create yet another new bug report for this issue? Sorry for all this work this means for you, but we can handle such problems much more easily if each on gets its own bug report (and therefore the chance to fix them is much better then!).

Thank you very much!
Comment 19 Phil Reilly 2012-09-14 14:37:05 UTC
done!