Download it now!
Bug 52147 - LibreOffice hangs as soon as any page in Preferences is selected.
Summary: LibreOffice hangs as soon as any page in Preferences is selected.
Status: RESOLVED DUPLICATE of bug 47368
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 46981 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-16 10:16 UTC by Kal Sze
Modified: 2013-11-15 23:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
hang log from Mac OS X (324.57 KB, text/plain)
2012-07-16 10:16 UTC, Kal Sze
Details
Crash log (1) created with Norbert's debug version of 3.6.0.2+ and RightZoom running (146.03 KB, text/plain)
2012-07-24 09:28 UTC, Roman Eisele
Details
Crash log (2) created with Norbert's debug version of 3.6.0.2+ and RightZoom running (127.15 KB, text/plain)
2012-07-24 09:29 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kal Sze 2012-07-16 10:16:28 UTC
Created attachment 64269 [details]
hang log from Mac OS X

Steps to reproduce:
1. Install LibreOffice with the official dmg (I have also installed the British English language pack)
2. Start LibreOffice
3. Open "Preferences" by pressing "⌘+,"
4. Click any page

Expected result:
Clicked page displayed

Actual result:
LibreOffice hangs

Log attached.

I have already tried to do a clean install (deleting both the application and the existing preferences folder in "~/Library/Application Support/LibreOffice"), to no avail.

System:
Mac OS X Lion 10.7.4 (x86_64 mode)
4 GB RAM
Comment 1 Michael Meeks 2012-07-16 10:40:00 UTC
Can you try disabling accessibility support ? I suspect this is a duplicate of: bug#47368

Thanks ! & sorry for the problem.
Comment 2 Kal Sze 2012-07-16 10:48:00 UTC
I just looked through "Universal Access". Everything was "off" except for a checkmark on "Enable access for assistive devices". I unchecked it and LibreOffice works again.

However, I don't remember having ever changed anything in "Universal Access". Is "Enable access for assistive deviced" checked by default?
Comment 3 Roman Eisele 2012-07-17 06:24:31 UTC
(In reply to comment #2)
> I just looked through "Universal Access". Everything was "off" except for a
> checkmark on "Enable access for assistive devices". I unchecked it and
> LibreOffice works again.

So this is really a duplicate of bug 47368, just like Michael suggested (comment #1). Therefore I mark it as RESOLVED/DUPLICATE.

*** This bug has been marked as a duplicate of bug 47368 ***
Comment 4 Roman Eisele 2012-07-17 06:44:05 UTC
(In reply to comment #2)
> However, I don't remember having ever changed anything in "Universal Access".
> Is "Enable access for assistive deviced" checked by default?

A good question. I can't tell for MacOS X 10.7 (Lion) because I have to stay with MacOS X 10.6.x for technical reasons; at least on 10.6.x, it is *not* checked by default, but maybe Apple has changed this on 10.7?

You could help us to find out about that, and this would be very interesting for us all. IMHO Apple will use the default settings for any newly created account. To create a new account (you can delete it again later!), please open your MacOS System Preferences, select 'Users', click the lock icon at the bottom left to allow changes, and then click on the [+] or 'Add' button below the accounts list to create a new account. In the dialog window which asks you about some details please select type 'Standard' and enter a name and a password of your choice (just be sure to remember the password ;-). Now log out and log in again, this time with the name of the recently created account. Open the System Preferences again, select "Universal Access" and look if "Enable access for assistive deviced" is checked or not -- now you know it! Finally, log out and log in again with your own account. If you want, you can delete the recently created account now: just open 'Users' again, select the recently created account and click on [-] or 'Delete'.

If you could try this and tell us about the results (here) it would be very helpful, thank you in advance!

*

Another possibility is: have you installed any window management utility/app, e.g. Moom, Cinch, or RightZoom? I wonder if some utilities of this kind tell MacOS X to "Enable access for assistive deviced" when you install them.
Comment 5 Kal Sze 2012-07-18 02:38:47 UTC
Just like Roman Eisele guessed, I have Cinch and ShiftIt installed on my system for a very very long time. Both applications require the "Enable access for assistive devices" option in Universal Access, which means that the option must have been enabled for a very very long time, regardless of whether it is the default. Meanwhile, I have also been using LibreOffice since its first release.

However, I am still unsure whether this a simple duplicate of or a regression related to #47368 because I can't remember how long it has been since I last opened LibreOffice's Preferences.
Comment 6 Roman Eisele 2012-07-24 09:28:05 UTC
Created attachment 64599 [details]
Crash log (1) created with Norbert's debug version of 3.6.0.2+ and RightZoom running

For the record:

I tried to reproduce this bug with Norbert’s debug version of LibO 3.6.0.2+, on MacOS X 10.6.8 (Intel), with "Enable access for assistive devices" checked and RightZoom running.

With this setting, I can reproduce the crash (I can’t without RightZoom running). LibO does not always crash immediately, even if I select the Language Settings (this section of the preferences/options dialog seems to cause crashes in most causes); sometimes I have to click forth and back trough all the different option panes until some of them will crash -- ofthen the Language Settings, but sometimes even the 1st (General) one.

I did not find anything interesting in the console log, only the following debug message may be of interest:
24.07.12 09:49:40	[0x0-0x76076].org.libreoffice.script[1494]	warn:legacy.osl:1494:1:/Volumes/Raid0/g_core/cui/source/options/optcolor.cxx:965: too few helpIDs for color listboxes

(1) On the crashs, I get two slightly different kinds of log files; attached to this you find an example of the 1st kind -- the topmost line of the Thread 0 trace ends with "osl_acquireMutex + 7".
Comment 7 Roman Eisele 2012-07-24 09:29:07 UTC
Created attachment 64600 [details]
Crash log (2) created with Norbert's debug version of 3.6.0.2+ and RightZoom running

(2) This is the other kind of crash log I get; there is a slight difference in the trace of Thread 0 -- the topmost line ends with "pthread_mutex_lock + 6".
Comment 8 Roman Eisele 2012-09-12 08:51:44 UTC
Mac Accessibility Related Bugs Survey Results
---------------------------------------------

All tests done on Mac OS X 10.6.8 (Intel).
To test, I used the following steps:
0) Rename your LibO user profile folder, to make sure that
   there is no influence of any special settings on the test
   (I always do so before such tests).
1) Start LibreOffice;
   -> the Start Center window appears.
2) Select "LibreOffice > Preferences..." from the menu;
   -> the "Options" dialog window appears.
3) In the list at the left side of the window,
   click on any top-level entry -- I mean, one of the
   entries "Load/Save", "Language Settings", "LibreOffice Base",
   "Charts", "Internet", which can be unfolded to show the
   sub-entries.
   -> Most times LibreOffice will crash now;
   if not, click on another top-level entry.
   It _may_ be necessary that the top-level entry is not
   unfolded, but closed before you click on it.

Using these steps, the crash is REPRODUCIBLE with
* LibreOffice 3.6 daily (3.6.2.0+), Build ID: cfbfa26,
  Pull time: 2012-09-07 10:35:10, German langpack installed
* LOdev 3.7.0.0.alpha0+, Build ID: 5ca197c,
  Pull time: 2012-09-06 07:07:33, US English langpack installed

But the crash is NO longer reproducible with
* LibreOffice 3.6 daily (3.6.2.0+), Build ID: c303961,
  Pull time: 2012-09-11 08:49:57, German langpack installed
* LOdev 3.7.0.0.alpha0+, Build ID: 2df0884,
  Pull time: 2012-09-11 01:28:39, US English langpack installed

This indicates that this bug was fixed by Michael Meek’s patch for bug 47368:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=3234b715b5a6d13ee673b41066eb565706be5ec9

This means in turn that this bug is correctly marked as a duplicate of bug 47368, which was fixed by the commit cited above.
Comment 9 Roman Eisele 2012-09-12 09:00:15 UTC
The fix mentioned above will appear in LibreOffice 3.6.2 and 3.7.0.
Comment 10 Roman Eisele 2012-09-12 10:24:13 UTC
*** Bug 46981 has been marked as a duplicate of this bug. ***