Bug 46981 - Crashes in preferences menu
Summary: Crashes in preferences menu
Status: RESOLVED DUPLICATE of bug 52147
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-05 11:22 UTC by jsherk
Modified: 2012-09-12 10:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
crash report (165.52 KB, text/plain)
2012-03-05 11:22 UTC, jsherk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jsherk 2012-03-05 11:22:39 UTC
Created attachment 58041 [details]
crash report

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Mac OS X Lion v10.7.3

Just installed LibreOffice on my MacBook Pro and everytime I go to Preferences and then start clicking thru all the different options it will crash.

Usually I have to click on about 5 to 10 different options in the list before it crashes.

I used Open Office for a while and recall this same issue with it as well.

Have attached crash report.
Comment 1 Rainer Bielefeld Retired 2012-03-05 22:33:21 UTC
Related to 
"Bug 31919 - Mac: program beach-balls and then crashes when topic is selected within Preferences."
"Bug 37913 - LibreOffice crashes frequently when settings-dialog is opened"?
Comment 2 Roman Eisele 2012-04-19 01:22:05 UTC
This bug seems to be identical or at least related to the one reported as bug 37913 - "LibreOffice crashes frequently when settings-dialog is opened".

Therefore I mark this present bug report as a duplicate of the one for bug 37913. This is important to show how many people are affected by this bug and that it is a important bug, having some duplicates.

*** This bug has been marked as a duplicate of bug 37913 ***
Comment 3 Roman Eisele 2012-09-12 10:24:13 UTC
Mac Accessibility Related Bugs Survey Results
---------------------------------------------

This bug is very very similar to bug 52147 and bug 54282, which have been both
fixed by Michael Meek’s patch for bug 47368:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=3234b715b5a6d13ee673b41066eb565706be5ec9

Therefore it is very probable that this bug has been fixed by that commit, too.

This is also indicated by the fact that the crash dump attached to the present
bug contains many (recursive) references to hitTestRunner(); there was a problem with endless (?) recursion of this function which should have been fixed by the commit cited above.

This means in turn that this bug should be marked as a duplicate of bugs 52147 or 54282, which were fixed by the commit cited above.

This fix will appear in LibreOffice 3.6.2 and 3.7.0.

*** This bug has been marked as a duplicate of bug 52147 ***
Comment 4 Roman Eisele 2012-09-12 10:29:40 UTC
@ jsherk :

It would be very helpful if you could test if you can still reproduce this
crash with the upcoming LibreOffice 3.6.2; in a few days, a first release candidate will be available at

   http://www.libreoffice.org/download/pre-releases/

Or, if you are more adventurous, you can use the current daily build of
LibreOffice 3.6; it is available at

http://dev-builds.libreoffice.org/daily/MacOSX-Intel@3-OSX_10.6.0-gcc_4.0.1/libreoffice-3-6/current/

(Please note that the daily build should not be used for productive work.)


If you can NOT reproduce the crash with any of these versions, you could leave
a short note about that result in the present bug report. 

But IF you still CAN reproduce the same (!) crash with any of these versions,
please set the Status of this bug report to REOPENED, and try to describe in as
much detail as possible what exactly is necessary to get the crash -- step by
step, even mouse click by mouse click.

Thank you very very much in advance!