Bug 37913 - LibreOffice crashes frequently when settings-dialog is opened
Summary: LibreOffice crashes frequently when settings-dialog is opened
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: All Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: a11y-macOS
  Show dependency treegraph
 
Reported: 2011-06-04 02:03 UTC by christitze
Modified: 2012-11-15 11:46 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
OS X crash report of the described bug. (85.46 KB, text/plain)
2011-06-06 03:15 UTC, christitze
Details
/Applications/LibreOffice.app/Contents/MacOS/unopkg list --bundled > /users/christian/Desktop/bundled.txt (16.17 KB, text/plain)
2011-06-06 08:06 UTC, christitze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description christitze 2011-06-04 02:03:52 UTC
Open "LibreOffice -> Settings" menu and click on any category, e.g. "Language Settings" (since I use the German version it could be, that it has a slightly different title in English). LibreOffice crashes in over 90% of the time you do this. If it doesn't crash the first time just click on another category and then it's going to crash.

I could reproduce this bug on Mac OS X Snow Leopard with any version of LibreOffice since the first final release.

This makes a productive use of LibreOffice (any version) on Mac OS X (at least v10.6) impossible and it needs to be fixed ASAP.
Comment 1 Alex Thurgood 2011-06-04 02:25:01 UTC
Hi,

1) Do you have Accessibility Tools (i.e. things like VoiceOver, Zoom functions etc) activated in your Mac system preferences ?


2) Which version of Java ?

3) Which version of OSX 10.6 ? Latest updates installed ?

Alex
Comment 2 christitze 2011-06-04 04:59:38 UTC
1.) No Accessibility Tools are activated.

2.) Java-Preferences says the following: Java SE 6, Apple Inc., Version 1.6.0_24-b07-334 (both for 32 and 64-Bit)

3.) Version 10.6.7, everything is up to date.

(In reply to comment #1)
> Hi,
> 
> 1) Do you have Accessibility Tools (i.e. things like VoiceOver, Zoom functions
> etc) activated in your Mac system preferences ?
> 
> 
> 2) Which version of Java ?
> 
> 3) Which version of OSX 10.6 ? Latest updates installed ?
> 
> Alex
Comment 3 Alex Thurgood 2011-06-05 08:32:54 UTC
Hmm, OK. A suggestion then :

Rename and move your LibreOffice user profile from /Users/username/Library/Application Support to somewhere else on your disk (e.g. your Desktop). Restart LibreOffice and see if that makes any difference.

I'm saying this because the biggest cause of instability I have found so far with LibreOffice on Mac comes from the user profile getting regularly screwed up by installation of successive versions over the top of existing ones.


Alex
Comment 4 christitze 2011-06-05 09:46:29 UTC
I just tried your suggestion - it doesn't make any difference. Am I the only one with this problem? I think such a huge problem would've been reported earlier if more people had experienced it.

(In reply to comment #3)
> Hmm, OK. A suggestion then :
> 
> Rename and move your LibreOffice user profile from
> /Users/username/Library/Application Support to somewhere else on your disk
> (e.g. your Desktop). Restart LibreOffice and see if that makes any difference.
> 
> I'm saying this because the biggest cause of instability I have found so far
> with LibreOffice on Mac comes from the user profile getting regularly screwed
> up by installation of successive versions over the top of existing ones.
> 
> 
> Alex
Comment 5 Alex Thurgood 2011-06-05 22:50:18 UTC
Hi,

I've only seen one other report so far, with regard to a previous version of LibreOffice, where this behaviour was indicated. As for the present case, no one else that tests/works/develops on Mac could reproduce the problem, so there must be a particular set of circumstances that causes the crashing to happen. The difficulty is in narrowing down those circumstances.

When the app crashes, the Apple Crash Reporter should start and provide a trace of what was going on at the time the application crashed. Do you think you could provide us with a text file of that crash report ? Just attach it to the current issue using the link "Add an attachment". At least with that, we might stand a better chance of finding out what is happening on your system.


Alex
Comment 6 Petr Mladek 2011-06-06 01:57:30 UTC
It seems to be specific for the given user => should not block the whole release => reducing severity a bit.

Anyway, thank you both for tracking this down.
Comment 7 christitze 2011-06-06 03:15:20 UTC
Created attachment 47593 [details]
OS X crash report of the described bug.
Comment 8 christitze 2011-06-06 03:18:22 UTC
Hi,

that's strange as I had it with every version of LO since the first final release but with none of the previous versions of OpenOffice.org.

Could it be a special problem with the computer I work on? If you need to know it: I'm using a 2010 MacBook Pro 17" (MacBook Pro 6,1) with the Intel i7 2,66GHz processor.

Thank you, I attached the report.
Comment 9 Alex Thurgood 2011-06-06 06:16:22 UTC
Hi christitze,

Could you list the extensions that you currently have installed ?
In a terminal type :

/Applications/LibreOffice.app/Contents/MacOS/unopkg list --shared

and :

/Applications/LibreOffice.app/Contents/MacOS/unopkg list --bundled

and post the results here or as a file attachment ?


Alex
Comment 10 christitze 2011-06-06 08:06:52 UTC
Created attachment 47608 [details]
/Applications/LibreOffice.app/Contents/MacOS/unopkg list --bundled > /users/christian/Desktop/bundled.txt

--shared says <none>
Comment 11 Alex Thurgood 2011-06-06 08:38:40 UTC
Thanks for the attachment. Unfortunately, I can see no obvious difference in comparison to mine. I even have the German language helppack, interface and dictionary installed (just to test whether it might have been a problem with the langpack).

The only difference I have is in my --shared list, but that is because I added the mysql connector driver extension (if anything, this causes even more problems).


At present, the only other thing I can suggest is to delete the LibreOffice application from your Applications folder, delete the LibreOffice folder from /Usrs/username/Library/Application Support and try and re-install with a new download from the LibreOffice website. If it still does not work, then I would suggest that you have some other application on the system that interferes.


Alex
Comment 12 Kriton Kyrimis 2011-09-02 11:12:24 UTC
I wonder if this is the same bug as Bug 40359 on Windows XP, where I can consistently crash Libre Office by selecting "Language Settings->Languages" from the LibreOffice options, but only with this particular option.

I can reproduce that problem on both my home and work PC, but not on a freshly installed VM, with only LibreOffice, Java and Firefox installed.
Comment 13 MarcS 2011-10-01 10:16:24 UTC
Same exact thing was happening to me, but the answer (for me) was on this thread:

 System Preferences > Universal Access > uncheck Enable access for assistance devices
(it's the first checkbox on the bottom of the Universal Access preference pane) 

I don't know why or when that system pref was enabled, but now LibreOffice does not crash on preferences anymore.
Comment 14 Björn Michaelsen 2011-12-23 12:05:24 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 15 Julien Nabet 2012-04-09 12:04:43 UTC
Don't hesitate to revert the status if you disagree.

*** This bug has been marked as a duplicate of bug 47368 ***
Comment 16 Roman Eisele 2012-04-19 01:15:45 UTC
After careful examination of this and some similar bug reports, I think we should NOT mark this bug report as a duplicate of Bug 47368 ("Many crashes when accessibility enabled on MAC").

Of course, MarcS says in comment #13 that he solved this issue by unchecking "Enable access for assistance devices". So his issue was indeed (more ore less) identical with Bug 47368.

But:
1) The original reporter of this present bug (christitze@web.de) says explicitely in comment #2: "No Accessibility Tools are activated." So his/her issue seems NOT to be identical with bug 47368.
2) The OS X crash report attached to this report looks NOT very similar to the one attached to Bug 47368.
3) This present report talks specifically about a crash when changing the categories of the Preferences/Settings dialog, while bug 47368 reports about various crashes in various actions.
4) There are some more bug reports which talk specifically about the same (or a very similar) issue as this present report: about crashes when changing the categories of the Preferences/Settings dialog.

So, this prensent issue is not "specific for the given user" (as comment #6 stated), but of some importance, as it affects more LibreOffice for MacOS users.

Therefore, I propose:
-- to reopen the present bug report
-- to mark the other bug reports talking about crashes within the Preferences/Settings dialog of LibreOffice for MacOS as duplicates of this present bug report (the one that contains the most facts and the longest discussion) in order to show the relation of these problems.
Comment 17 Roman Eisele 2012-04-19 01:20:04 UTC
*** Bug 40301 has been marked as a duplicate of this bug. ***
Comment 18 Roman Eisele 2012-04-19 01:22:05 UTC
*** Bug 46981 has been marked as a duplicate of this bug. ***
Comment 19 Roman Eisele 2012-04-19 01:23:58 UTC
*** Bug 39701 has been marked as a duplicate of this bug. ***
Comment 20 Roman Eisele 2012-04-19 01:26:59 UTC
*** Bug 31919 has been marked as a duplicate of this bug. ***
Comment 21 Roman Eisele 2012-04-19 02:50:14 UTC
After the collection of at least 4 duplicates of this bug, I realize it is far more important than I believed before. Having never faced before this problem with a release version of LibreOffice myself, I did not think that so much users are affected.

Of course, it is still possible that the root of all these problems with the Settings dialog on MacOS is indeed some Accessibility Tools setting, which is just not remembered by the users anymore. Therefore it is still possible that this bug is indeed a special case of bug 47368 ("Many crashes when accessibility enabled on MAC").

But before we could decide about this question, I wanted to collect all bug reports which specifically talk about problems with selecting items from the settings list in the "LibreOffice -> Settings" dialog on MacOS X (as opposed to crashes anywhere, as the report for bug 47368 does).

When I read the different reports I get the impression that Accessibility Tools settings are one cause of these problems (like, e.g., in bug 33359, in bug 42014, or in comment #13 below), but that there could be also another cause of these problems, independed from Accessibility Tools settings (see, e.g., comment #2 below!). This distinction could correspond to the differences in the description of the crash: in some cases, LibreOffice crashes immediately when the user selects another category in the settings list, in other cases it does not crash but hangs. Isn't it possible that there are really two different bugs, the one related to Accessibility Tools settings, the other one not?
Comment 22 Roman Eisele 2012-09-12 14:15:23 UTC
Mac Accessibility Related Bugs Survey Results
---------------------------------------------

This bug is very very similar to bug 52147 and bug 54282, which have been both
fixed by Michael Meek’s patch for bug 47368:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=3234b715b5a6d13ee673b41066eb565706be5ec9

This fix will appear in LibreOffice 3.6.2 and 3.7.0.

But the present bug shows a rather different stack trace: instead of the typical endless (?) recursion of hitTestRunner(), the stack trace of the present bug (attachment 47593 [details]) shows a endless (?) recursion of SystemToOfficeDragActions() from libvclmxi.dylib. Additionally, it contains no reference to any accessibility stuff, as far as I can see.

Therefore it seems probable that the present bug is NOT a duplicate of bug 47368, bug 52147, and bug 54282, but a bug “sui generis”, which needs additional debugging. IMHO this examination should begin with the question why there is such an endless (?) recursion of SystemToOfficeDragActions().


About Duplicates
----------------

Long time ago, I had marked four bugs as duplicates of the present bug, but this was too hasty. Only one of them (bug 40301) is similar to the present one (stack trace contains references to SystemToOfficeDragActions()). Another bug (bug 46981) is rather similar to bug 52147 and bug 54282, therefore I have now marked it as a duplicate of bug 52147, which should be fixed in LibO 3.6.2 and 3.7.0 (see above). The two remaining bugs (bug 39701 and bug 31919) don’t include the necessary information (no crash log, etc.), therefore I have reset the status of both bug reports to NEEDINFO, in the hope either to get the missing information or to close them as RESOLVED/WORKSFORME.
Comment 23 Roman Eisele 2012-09-15 16:08:26 UTC
Set Version field according to comment #7.

(Please note that the Version field should always contain the FIRST version which is known to contain the problem, and NOT the last one, so please do not “update” the Version field. Thank you!)
Comment 24 Roman Eisele 2012-09-21 14:04:34 UTC
@ Christitze:

Hello Christitze,

you have reported this bug for LibreOffice 3.4.0. In the upcoming release 3.6.2 we have finally fixed a very important bug which could cause the same symptoms as you describe (LibreOffice crashes when the application options dialog is open). So I hope this bug will be fixed now for you, too.

But I can’t tell for sure, because your Mac OS X crash report shows a very unusual stack trace, so that it is possible that you experienced a special bug which is still not fixed. I can’t test this, because I can’t get LibreOffice (regardless which version) to crash with a stack trace similar to your one.

The only way to find out whether the bug reported by you is still active, and needs futher action, or is fixed, too, is that you test this issue again. Could you please do so? This would be extremely helpful!

To test again, please download the current pre-release 3.6.2.1 from

   http://www.libreoffice.org/download/pre-releases/

install it and try if you can still reproduce the crash. And please report your results here.

Thank you very very much in advance!
Comment 25 Roman Eisele 2012-11-15 11:46:44 UTC
Dear bug reporter,

I am sorry, but we can not do anything about this issue without more information from you. The questions asked in comment #24 have not been answered for about two months now, therefore we need to close this bug report.

I can not manage to reproduce this bug in any way with a current version of LibreOffice (3.6.3). It seems very probable that this bug was identical with bug 47368, which has been fixed in between. Therefore I mark this bug report as RESOLVED/WORKSFORME.

Feel free to open this bug report again, if you still experience the problem
with a current version of LibreOffice (3.6.3 or better).

Thank you very much!