Download it now!
Bug 39701 - LibO 3.4.2 FINAL Crashes because of double clicking in Preferences menu
Summary: LibO 3.4.2 FINAL Crashes because of double clicking in Preferences menu
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86 (IA32) Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: a11y-macOS
  Show dependency treegraph
 
Reported: 2011-07-31 10:20 UTC by C. Gagnon
Modified: 2012-11-15 11:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description C. Gagnon 2011-07-31 10:20:51 UTC
LibreOffice crashes every time I DOUBLE click on preference menus to expand them (LibreOffice, Load/Save, Language settings...) .

No problem with a SINGLE click on the menus or with the triangle expanders.
Comment 1 Jeffrey 2011-07-31 18:17:57 UTC
Failed to reproduce on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux.

On this version you only need to single click on the items to expand them. So double clicking would expand and collapse the items successively. There is no problem at all that I see.
Comment 2 C. Gagnon 2011-08-01 00:26:25 UTC
you may only need to single click to expand, but libreoffice should not crash. and NO, single clicking does not expand the menus.


Le 31 juil. 2011 à 21:17, bugzilla-daemon@freedesktop.org a écrit :

> https://bugs.freedesktop.org/show_bug.cgi?id=39701
> 
> Jeffrey <jeffdchang@gmail.com> changed:
> 
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                 CC|                            |jeffdchang@gmail.com,
>                   |                            |yfjiang@novell.com
> 
> --- Comment #1 from Jeffrey <jeffdchang@gmail.com> 2011-07-31 18:17:57 PDT ---
> Failed to reproduce on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux.
> 
> On this version you only need to single click on the items to expand them. So
> double clicking would expand and collapse the items successively. There is no
> problem at all that I see.
> 
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 3 Björn Michaelsen 2011-12-23 12:28:01 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 Roman Eisele 2012-04-19 00:19:47 UTC
I tested this issue in order to clarify the present state of affairs. Result:

NOT reproducible with LibreOffice 3.4.5, 3.4.6, 3.5.2, all with German langpack installed, all running on MacOS X 10.6.8 German.
Single clicks double clicks etc.: everything works as expected.

@C. Gagnon:
Could you please tell us if you can still reproduce this issue, i.e. if this problem persists for you?

If not, I think we can savely close this bug report. I have never seen this issue while I have been using LibreOffice since its 1st version on MacOS, so I think that some especially unfortunate software constellation caused these problems on C. Gagnon's machine ...
Comment 5 Roman Eisele 2012-04-19 00:26:08 UTC
This bug may be related to bug 40301 - "LibreOffice 3.4.2 with German language pack under OSX Lion 1.7.0 and 1.7.1 (German) crashes when trying to change settings."

@C. Gagnon:
Which version of MacOS did you use when you reported this bug? MacOS X Lion (10.7.x), like the reporter of bug 40301? This could explain why I have never seen this bug (I'm still using 10.6.x). If this is true, and if the issue is still reproducible for you, we should not close this bug report but try to collect more information about the problems in order to get them fixed ...
Comment 6 Roman Eisele 2012-04-19 01:23:58 UTC
This bug seems to be identical or at least related to the one reported as bug
37913 - "LibreOffice crashes frequently when settings-dialog is opened".

Therefore I mark this present bug report as a duplicate of the one for bug
37913. This is important to show how many people are affected by this bug and
that it is a important bug, having some duplicates.

*** This bug has been marked as a duplicate of bug 37913 ***
Comment 7 Roman Eisele 2012-09-12 13:49:31 UTC
Mac Accessibility Related Bugs Survey Results
---------------------------------------------

This bug is very very similar to bug 52147 and bug 54282, which have been both
fixed by Michael Meek’s patch for bug 47368:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=3234b715b5a6d13ee673b41066eb565706be5ec9

Therefore it is very probable that this bug has been fixed by that commit, too. This fix will appear in LibreOffice 3.6.2 and 3.7.0.

But I can’t tell for sure, especially because no crash log is attached to this bug report; therefore I can’t even tell if this bug is related to Mac OS Accessibility features (like bug 52147 and bug 54282) or not.

Therefore I was too hasty when I marked this bug as a duplicate of bug 37913. Instead, I should have asked the original reporter for more details, and therefore this is what I need to do now -- sorry!


@ C. Gagnon:
To resolve this issue, we need to ask you some questions.

1) Can you still reproduce this issue with a current version of LibreOffice (3.5.6 or 3.6.1)?

If yes, could you please attach the debug information created by Mac OS X on the crash to this bug report? (If you need instructions how to do this, please send me a short mail to   bugs@eikota.de   -- thank you!)

If yes, please answer also the following questions:

2) Do you have any accesibility features enabled? Apple’s accessibility
features like "VoiceOver" or "Enable access for assistive devices", which get
enabled in "System Preferences > Universal Access" (in German:
"Bedienungshilfen"; dont’t know about other languages), are known to cause many
crashes in LibreOffice (see bug 47368). So please try to disable any
accesibility features, i.e. uncheck "VoiceOver", "Enable access for assistive
devices", etc.

3) Do you have installed any window management/user interface utilities/apps
for MacOS X like 
* Moom      (see bug 42014)
* Cinch     (see bug 51791)
* RightZoom (see bug 51686)
* ShiftIt   (see bug 52147)?
All these and many similar utilities rely heavily on accessibility issues and
therefore cause LibreOffice to crash. So please check if you have installed any
utility of this kind and try to disable it (or to add LibreOffice to the list
of excluded applications for the utility, if there is such a thing).

Disabling both Apple’s accessibility features and all
accessibility-related/window management utilities, and then re-starting your
Mac should fix the LibreOffice crash. Please try this.

Thank you very much in advance!
Comment 8 Roman Eisele 2012-11-15 11:47:50 UTC
Dear bug reporter,

I am sorry, but we can not do anything about this issue without more information from you. The questions asked in comment #7 have not been answered for more than two months now, therefore we need to close this bug report.

I can not manage to reproduce this bug in any way with a current version of LibreOffice (3.6.3). It seems very probable that this bug was identical with bug 47368, which has been fixed in between. Therefore I mark this bug report as RESOLVED/WORKSFORME.

Feel free to open this bug report again, if you still experience the problem
with a current version of LibreOffice (3.6.3 or better).

Thank you very much!