Download it now!
Bug 40301 - LibreOffice 3.4.2 with German language pack under OSX Lion 1.7.0 and 1.7.1 (German) crashes when trying to change settings.
Summary: LibreOffice 3.4.2 with German language pack under OSX Lion 1.7.0 and 1.7.1 (G...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: a11y-macOS
  Show dependency treegraph
 
Reported: 2011-08-23 01:45 UTC by christoph
Modified: 2012-11-15 11:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Mac OS X 1.7.1 Crashlog LibreOffice 3.4.2 (340.95 KB, text/plain)
2011-08-23 01:45 UTC, christoph
Details

Note You need to log in before you can comment on or make changes to this bug.
Description christoph 2011-08-23 01:45:06 UTC
Created attachment 50475 [details]
Mac OS X 1.7.1 Crashlog LibreOffice 3.4.2

When trying to change the settings category from the list on the left hand side the application crashes. Changing my personal data however works.
Renaming or deleting ˜/Library/Application Support/LibreOffice did nit change that behavior. Clean install without language pack also produces that error.
Comment 1 Björn Michaelsen 2011-12-23 12:39:33 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Roman Eisele 2012-04-19 00:31:45 UTC
This bug may be related to bug 39701 - "LibO 3.4.2 FINAL Crashes because of double clicking in Preferences menu".

I can NOT reproduce it (just like bug 39701) with LibreOffice 3.4.5, 3.4.6, or 3.5.2, all with German langpack installed, all running on MacOS X 10.6.8 German. And I have never seen such an issue. But maybe the MacOS Version makes a difference here ...


@christoph@larnhof.at:
Thank you very much for your report!
Could you please tell us if this issue (bug) is still reproducible for you, even if you try a current version of LibreOffice (3.4.6 or 3.5.2)? I.e., does LibreOffice still crash?

If this is true, and if the issue is still reproducible for you, we should not close this bug report but try to collect more information about the problems in order to get them fixed ...


@everybody else with MacOS X 10.7.x (Lion):
Could you please test if you can reproduce this issue? I can't, but maybe this is due the MacOS X version, see above.
Comment 3 Roman Eisele 2012-04-19 01:20:04 UTC
This bug seems to be identical or at least related to the one reported as bug 37913 - "LibreOffice crashes frequently when settings-dialog is opened".

Therefore I mark this present bug report as a duplicate of the one for bug 37913. This is important to show how many people are affected by this bug and that it is a important bug, having some duplicates.

*** This bug has been marked as a duplicate of bug 37913 ***
Comment 4 Roman Eisele 2012-09-22 15:06:23 UTC
Sorry for all the changes, but I keep learning ;-)

Because of the questions in comment #2, it is saver to leave this bug in status NEEDINFO; it is not sure if this bug is really the same as bug 37913 (the stack traces are quite different).

Therefore again my question @ everybody who has once experienced this bug, especially <christoph@larnhof.at>:
  Can you still reproduce this bug with a current version of LibreOffice, i.e. 3.6.1 or better?

Any answer would be very helpful for us. Thany you in advance!
Comment 5 Roman Eisele 2012-11-15 11:50:32 UTC
Dear bug reporter,

I am sorry, but we can not do anything about this issue without more information from you. The questions asked in comment #2 have not been answered for more than six months now, therefore we need to close this bug report.

I can not manage to reproduce this bug in any way with a current version of LibreOffice (3.6.3). It seems very probable that this bug was identical with bug 47368, which has been fixed in between. Therefore I mark this bug report as RESOLVED/WORKSFORME.

Feel free to open this bug report again, if you still experience the problem
with a current version of LibreOffice (3.6.3 or better).

Thank you very much!