Download it now!
Bug 40359 - Crash when selecting Language Settings->Languages
Summary: Crash when selecting Language Settings->Languages
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.3 RC1
Hardware: x86 (IA32) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 40585 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-24 10:30 UTC by Kriton Kyrimis
Modified: 2012-11-20 07:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Tools > Options > Language Settings > Language (UI: el) (39.24 KB, image/png)
2011-08-25 21:59 UTC, manj_k
Details
MacOS X log file generated on crash when accessing Language settings a 2nd time (53.02 KB, text/plain)
2012-04-17 03:40 UTC, Roman Eisele
Details
The Language settings preferences pane, as it appears at Step 7) of Comment #37 (344.99 KB, image/png)
2012-04-17 03:53 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kriton Kyrimis 2011-08-24 10:30:10 UTC
If I select Language Settings->Languages from the LibreOffice options, LibreOffice crashes.
Comment 1 Kriton Kyrimis 2011-08-24 11:44:55 UTC
This is probably related to Bug 37195, which had just bitten me. After trying the workaround described in the bug's page, the Languages panel appears without a problem.

An error message would have been preferable to a crash, of course!
Comment 2 manj_k 2011-08-24 12:07:17 UTC
Not reproducible with
LibO 3.4.3 RC1 [UI: English (USA)] on Win XP 32b
[LibreOffice 3.4.3 OOO340m1 (Build:301)].

(1)
Tried 'Tools > Options > Language Settings > Languages...
- via StartCenter
- via Writer (Untitled 1)
Changed 'Language of User interface' to 'French (France)'.
Closed LibO.

(2)
Restarted LibO, UI French (France).
Changed the language of UI back to 'English (USA)'
via StartCenter 'Outils > Options > Paramètres linguistiques > Langues >
Langue pour Interface utilisateur > Anglais (U.S.A.)'.

That works fine for me.
Comment 3 manj_k 2011-08-24 12:37:49 UTC
No-one has observed such a crash in conjunction with bug 37951 (me too, with a lot of tests), so it is obviously not a duplicate of that bug.

Due to coment #1:
CLOSED NOTABUG

@kyrimis
Feel free to reopen this bug, if the crash can be reproduced.
Comment 4 Kriton Kyrimis 2011-08-25 00:12:58 UTC
The way I got around bug 37951 was to delete the contents of Application Data/LibreOffice/3/user/extensions and run the extension manager to recreate them. As soon as I did that, the crashes stopped.

After verifying that all was well, and reporting it, I thought I'd reinstall the English help pack, for good measure. As soon as I did that, the crash reappeared and persisted until I reapplied the workaround.

It sounds like the problem has something to do with my particular installation. Is there something I could send you (e.g., stack trace, configuration files) that might help identify it?

One thing that may be relevant is that, starting from version 3.4.0 RC1 and ending with version 3.4.1 RC2, I had been going back and forth between versions 3.3 and 3.4, each time a new 3.4 version came out, until bug 37670 was fixed, which was a blocker for me. Could this have resulted in the corruption of my profile and that I simply need to erase it?
Comment 5 manj_k 2011-08-25 06:44:59 UTC
(In reply to comment #4)

1. Please specify your Windows OS.

> The way I got around bug 37951 was to delete the contents of Application
> Data/LibreOffice/3/user/extensions and run the extension manager to recreate
> them. As soon as I did that, the crashes stopped.

2. Reinstalling 'shared' and 'user' extensions may clear errors, which hang together with these extensions, or the way how they had been installed (possible cause of the crash).
The described workarounds for bug 37951 (q.v.) don't need any reinstalling of extensions.
 
> After verifying that all was well, and reporting it, I thought I'd reinstall
> the English help pack, for good measure. As soon as I did that, the crash
> reappeared and persisted until I reapplied the workaround.

3. The installation of the "English help pack" is a new aspect, not mentioned until now (another possible cause of the crash--e.g.: the way it has been installed). [But that works fine for me.]

> It sounds like the problem has something to do with my particular installation.
> Is there something I could send you (e.g., stack trace, configuration files)
> that might help identify it?
>
> One thing that may be relevant is that, starting from version 3.4.0 RC1 and
> ending with version 3.4.1 RC2, I had been going back and forth between versions
> 3.3 and 3.4, each time a new 3.4 version came out, until bug 37670 was fixed,
> which was a blocker for me. Could this have resulted in the corruption of my
> profile and that I simply need to erase it?

5. How to replicate all these steps? ;)

Are you able to reproduce the bug--as described in the summary "Crash when selecting Language Settings->Languages"--with a default user profile?
(Renaming the directory 'user' to 'user_old'; restarting LibO will create such a default user profile.)

Please try a reproducible step-by-step description.

By the way, bug 37670 is obviously a duplicate of 'Bug 37488 - PRINTING table borders in Writer not printed if there are also images in the document, DRAW object printed crippled'.
Comment 6 Kriton Kyrimis 2011-08-25 10:07:57 UTC
1. Windows XP SP3, fully patched, English version.

2. Obviously, we both meant bug 37195, not 37951. Anyway, fixing configmgr.ini required going through quite a bit of text in the discussion, so I chose the first suggested workaround, which was to simply delete the entire extensions folder. If it hadn't worked, I would have restored from backup and tried doing it the more complicated way. In any case, I didn't have to reinstall any extensions: the shared and user folders were re-created as soon as I opened the extensions manager.

3. This was a new aspect for me, too, which is why I reported it. One thing I did not make clear is that along with the crashes, bug 37195 reappeared, after installing the help pack, which is why I tried the work-around again.

5. (Or, rather, 4.) How to replicate all these steps:

This is more of a description of how I ended up with my current configuration than actually expecting someone to do this!

* Install OpenOffice.org 3.2. (Better still, install 3.0 and upgrade to 3.1 then 3.2).
* Uninstall OpenOffice and Install LibreOffice 3.3.
* Upgrade LibreOffice for every release candidate of 3.3.x, up until what was current when 3.4.0 RC1 came out.
* For each release candidate of 3.4.x before 3.4.2 RC1: update to the release candidate then downgrade to whatever was the current 3.3.x version.
* Update to 3.4.2 RC1, then keep upgrading to every 3.4.x release candidate until 3.4.3 RC1.

(I guess I'm a sucker for release candidates!)


As for reproducing the bug with a default user profile, yes I can. Here are the steps:

* Rename C:\Documents and Settings\...\Application Data\LibreOffice\3\user to user.old
* Run LibreOffice Writer. The Languages option works fine.
* Exit LibreOffice Writer.
* Run LibO_3.4.3rc1_Win_x86_helppack_en-US.exe and select "Repair".
* Run LibreOffice Writer. The Language option crashes Writer.

Note that, after restoring my original profile, I had to do the work-around for bug 37195 again, as I kept getting crashes, even with the old, fixed profile. That help pack seems to be doing something nasty!


Finally, thanks for closing bug 37670!
Comment 7 manj_k 2011-08-25 13:23:32 UTC
(In reply to comment #6)
> [...]
> 2. Obviously, we both meant bug 37195, not 37951. [...]

Sorry, my mistake.
 
> 5. (Or, rather, 4.) [...]

Oops, another...

> How to replicate all these steps:
> 
> This is more of a description of how I ended up with my current configuration
> than actually expecting someone to do this! [...]

Thanks--I cannot possibly do this... ;)

> As for reproducing the bug with a default user profile, yes I can. Here are
> the steps:
> 
> * Rename C:\Documents and Settings\...\Application Data\LibreOffice\3\user to
> user.old
> * Run LibreOffice Writer. The Languages option works fine.
> * Exit LibreOffice Writer.
> * Run LibO_3.4.3rc1_Win_x86_helppack_en-US.exe and select "Repair".
> * Run LibreOffice Writer. The Language option crashes Writer.

I tried this as follows--but I could not replicate the bug:

A. 
- Installed LibO 3.4.3 RC2 [LibreOffice 3.4.3 OOO340m1 (Build:302)] 
over v3.4.2 release (custom setup with selected dictionaries, extensions, language packs; without 'quickstart.exe')
- Rebooted WinXP
- Installed helppacks en-US and de-DE
- Renamed my original user profile

B. 
- Started Writer - Tools > Options > Language Settings > Languages:
OK - no crash
- 'configmgr.ini' workaround due to occuring bug 37195
- Restarted Writer (all installed dictionaries available); closed LibO

C.
- (Extracted) helppack en-US 3.4.3 RC2: 'libreoffice34.msi' > 'Repair'...
- Started Writer - Tools > Options > Language Settings > Languages:
OK - no crash

D.
- Restored original user profile
- Started Writer (this time without bug 37195) - 
Tools > Options > Language Settings > Languages:
OK - no crash

E.
- Tried now with 'LibO_3.4.3rc2_Win_x86_helppack_en-US.exe' > 'Repair'...
- Started Writer - Tools > Options > Language Settings > Languages:
OK - no crash


Maybe, you want to try it again with LibO 3.4.3 RC2...
Comment 8 manj_k 2011-08-25 13:33:49 UTC
Addendum:
Do you have modified the default path (...\Program Files\LibreOffice 3.4\) for installing\repairing the helppack?
Comment 9 Kriton Kyrimis 2011-08-25 14:28:52 UTC
Some differences from what I did:

Step A: I did not reboot. In addition, I only installed the en-US help pack. 

Step B: I did not apply the workaround for bug 37195 after renaming my profile.

Another difference may be that you have probably configured Windows to use either the English or the German locale, while I'm using the Greek locale. (E.g., there is no Greek dictionary available, by default, which might be significant.) Plus, of course, there is the Greek dictionary that I'm using, which was made for OpenOffice. Could it be that it is no longer compatible with LibreOffice, thus causing problems?

I just downloaded 3.4.3 rc2 from http://dev-builds.libreoffice.org/pre-releases/

* I ran LibO_3.4.3rc2_Win_x86_install_multi.exe
* I started writer. The Languages option works fine.
* I ran LibO_3.4.3rc2_Win_x86_helppack_en-US.exe
* I started writer. The Languages option crashes LibreOffice as with 3.4.3 rc1.

* I renamed my profile.
* I started writer. The Languages option works fine.
* I ran LibO_3.4.3rc2_Win_x86_helppack_en-US.exe again. specifying "repair".
* I started writer. Again, the Languages option crashes LibreOffice.

At this point, if you cannot reproduce my problem, I could try reproducing your lack thereof by completely eradicating LibreOffice from my computer and reinstalling. Do I need to erase anything, other than my profile, after uninstalling, to ensure that no leftovers remain from the previous installation?


Re: Comment #8, I have installed both the program and the help pack in the default folders.
Comment 10 manj_k 2011-08-25 21:56:24 UTC
Another try--but the crash is still not reproducible:

I uninstalled LibO 3.4.3 RC2 and the helppacks (with 'Revo Uninstaller', Level 4). Then I cleaned the Windows registry once more (with 'CCleaner').

A. 
- Installed LibO 3.4.3 RC2 [LibreOffice 3.4.3 OOO340m1 (Build:302)] 
- Renamed my original user profile
- Started Writer (UI: default de-DE) - 
Tools > Options > Language Settings > Languages:
OK - no crash

B. 
- Installed helppack 'LibO_3.4.3rc2_Win_x86_helppack_en-US.exe'
- Started Writer (UI: default de-DE) - 
Tools > Options > Language Settings > Languages:
OK - no crash

C.
- Started Writer with my original user profile (UI: en-US) - 
Tools > Options > Language Settings > Languages:
OK - no crash

D.
- Tried now with 'LibO_3.4.3rc2_Win_x86_helppack_en-US.exe' > 'Repair'...
- Started Writer (UI: en-US) - Tools > Options > Language Settings > Languages:
OK - no crash

E. 
- Started Writer with the default user profile (UI: de-DE) - 
- Changed UI to Greek (el)
- Started Writer again (UI: el) - 
Tools > Options > Language Settings > Languages:
OK - no crash [see attached screenshot]

F.
- Started Writer with my original user profile (UI: en-US)
- Installed 'Dictionary and Hyphenation for Greek language (el_gr_v110.oxt 1.1)'
- Restarted Writer -
Tools > Options > Language Settings > Languages:
OK - no crash
Comment 11 manj_k 2011-08-25 21:59:25 UTC
Created attachment 50583 [details]
Tools > Options > Language Settings > Language (UI: el)
Comment 12 Kriton Kyrimis 2011-08-26 00:39:58 UTC
I tried it the other way round:

* I moved my old profile out of the way.
* I uninstalled the help pack using the standard uninstaller.
* I uninstalled LibreOffice using Revo uninstaller with the highest setting.
* I cleaned the windows registry a few times with CCleaner, until nothing new was found.
* I installed LibreOffice from LibO_3.4.3rc2_Win_x86_install_multi.exe
* I started writer. The Languages option worked fine.
* I exited writer and installed the english help pack from LibO_3.4.3rc2_Win_x86_helppack_en-US.exe.
* I started writer again. The Languages option crashed LibreOffice!
* I exited writer, renamed my profile, and moved back my original profile.
* I started writer again. The Languages option worked fine. 

Whatever the problem is, it is somewhere in my profile, and now I have a bare bones profile with no extensions or other accumulated junk in it. Would it make sense if I zipped it and mailed it to you? (It's 236K, zipped.)


Here's another data point: as I mentioned above, after restoring my old profile, the Languages option worked fine. After exiting writer, I ran it again, and this time it didn't. I tried replacing just configmgr.ini and, while this worked around bug 37195, it did not fix the crash. Deleting the "bundled" and "shared" folders in my profiles fixed it, but only for the first time I ran writer. After exiting and starting writer again, the crash reoccurred. It would seem that LibreOffice rebuilds the information in these folders correctly, in memory, but it does not write it correctly in the profile.

Based on this, it would seem that installing the help pack has nothing to do with the problem. It is running writer for a second time that causes it. To verify this:
* I uninstalled the help pack.
* I renamed my profile.
* I started writer. The Languages option works fine.
* I exited writer and started it once more. The Languages option crashes LibreOffice!


One difference between your setup and mine, during your last attempt with Greek, is that I do not use the Greek UI of LibreOffice. Instead, I use the Greek locale in Windows XP:

From the Regional and Language Options control panel:
* In Regional Options:
  Standards and formats: Greek
  Location: Greece
* In Languages:
  You can probably skip this step, as I doubt whether it has anything to do with LibreOfice: Selecting Greece, above, will install the Greek keyboard. I have replaced it with the "Greek Polytonic" keyboard by hitting the "Details" button, adding the "Greek Polytonic" keyboard, and deleting the plain "Greek" keyboard.
* In Advanced:
  Select a language to match...: Greek (This will require a reboot to take effect.)
Comment 13 manj_k 2011-08-26 09:10:28 UTC
Yes, please send me your user profile, I'll test it.
I agree to ignore the helppack for now.
I cannot see an interrelation with the crash.

Maybe a similar bug report (on Mac) : 
'Bug 37913 - LibreOffice crashes frequently when settings-dialog is opened'

Could you try to replicate the crash with a new user (ASCII characters only) on WinXP?

BTW: I cannot read Greek, and I don't understand it... ;)
Comment 14 Kriton Kyrimis 2011-08-27 00:49:06 UTC
I've e-maled you the profile.

Bug 37913 sounds suspiciously like the same bug, except that they imply that it appears on other parts of the settings, even though they only mention Languages. I just tried all settings, and only Languages crash on my computer.

I created a new windows XP account. The first two times I started writer from that account, the Languages option worked fine. From the third time onwards, it crashes consistently.

BTW, you shouldn't need to read Greek to deal with this bug. The only Greek I get to see is the Greek I type myself into LibreOffice: as I mentioned before, I use the English version of Windows XP and the default, English, UI of LibreOffice. The Windows XP settings that I mentioned should not have any effect on the Windows XP or LibreOffice UI.

On the other hand, if LibreOffice makes some decisions based on the locale (e.g., the locale is Greek, so let's load the default Greek dictionary--oops! there isn't one!) it's probably worth investigating whether the bug is caused by the different locale, especially as we seem to have eliminated everything else.
Comment 15 manj_k 2011-08-28 02:21:58 UTC
Sorry, I'm unable to generate a crash 'Language Settings > Language' with your user profile.

- The first start with that profile shows the 'LibreOffice Document Recovery' window. I've tried 'Start Recovery' and 'Cancel' (it makes no difference).
- Recovered 'Untitled 1' (Writer); application window not maximized.
- 'Available language modules': empty box.

- I've tried 'Language Settings > Language' several times (+5 in each case) with different conditions: missing language modules, modified 'configmgr.ini', removed folders 'bundled' and 'shared' from 'user\extensions'); quickstarter enabled/disabled; UI: default (de-DE), en-US.
That always worked well, as expected.

At the moment: no more ideas...
(Brainstorming: quickstarter · background application · crash report / stack trace ?)

Anybody else with a fresh point of view?
Comment 16 Kriton Kyrimis 2011-08-28 03:36:50 UTC
At least you got to see that there have been crashes on my machine!
Comment 17 Kriton Kyrimis 2011-08-28 05:13:16 UTC
I tried reproducing the problem on a freshly installed copy of Windows XP, but I couldn't. It looks like this is one of those problems that are solved by reformatting the Windows partition and reinstalling Windows, which is something I am not prepared to do.

At this point, I'm out of ideas, too. :-(
Comment 18 Kriton Kyrimis 2011-09-02 11:02:50 UTC
I tried this on the PC at work, and I get crashes there, too. :-(
Comment 19 digital ant 2011-09-06 14:05:34 UTC
3.4.3 on Windows XP Pro SP3 (32bit), JRE 6u26

Fresh install of 3.4.3 - prior to install, removed old versions, cleaned registry and removed old LibO profile in App Data.

Followed steps listed in bug report and cannot confirm the crash. BUT after following the steps, LibO does pause for a good 5 - 8 seconds before the right side of the language screen populates. After that first delay, going back to the Languages option has no delay unless I close and re-open LibO - but even then, it only takes about 2 secs.

While watching task manager, when you click on the Languages option, soffice.bin jumps to 72% CPU utilization until the language screen is populated.
Comment 20 Kriton Kyrimis 2011-09-14 06:37:17 UTC
This is somehow related to bug 40585: Deleting the "bundled" and "shared" folders in the profile fixes that bug temporarily as well, until I exit LibreOffice.
Comment 21 Kriton Kyrimis 2011-10-28 11:53:27 UTC
The bug persists in 3.4.4 RC1.
Comment 22 Kriton Kyrimis 2011-11-04 16:25:24 UTC
The bug persists in 3.4.4 RC2.
Comment 23 Rainer Bielefeld Retired 2011-11-12 22:57:28 UTC
NOT reproducible with "LibreOffice 3.4.4RC2  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:402)]" 

@kyrimis@alumni.princeton.edu
Currently  I can't see anything indicating that that WIN problem affects any other than your system(s).

Please
- add information 
  -- concerning your PC (video card, RAM, Processor, ...)
  -- concerning your LibO  localization (UI language)
  –- Libo settings that might be related to your problems 
     (video hardware acceleration ...)
  -- how you launch LibO 
  -- everything else crossing your mind after you read linked texts

Please try a parallel master installation following instructions on <http://wiki.documentfoundation.org/Installing_in_parallel#Windows> and <http://wiki.documentfoundation.org/Testing_Daily_Builds>, report your results here.
Comment 24 Kriton Kyrimis 2011-11-13 07:03:09 UTC
I have seen the problem on two systems:

System 1:
Processor: Intel E8600 @ 3.33 GHz
Ram: 4 GB (3.25 GB visible by the OS)
Video card: nVidia GeForce 9600 GT
Localization: Greek Locale(*) in US English version of Windows XP. US English version of LibreOffice installed, with US English UI and help files.
Libo settings that might be related to your problems (video hardware acceleration ...): I didn't even know there is such an option in LibO. Presume I have the default. Hardware acceleration for Windows XP is set to full.
how you launch LibO: I use shortcuts for "LibreOffice Calc" and "LibreOffice Writer" on my desktop, copied from the start menu.

System 2:
Processor: Intel Pentium 4 @ 3 GHz
Ram: 2 GB.
Video card: nVidia GeForce 6200
Localization: Greek Locale(*) in US English version of Windows XP. US English version of LibreOffice installed, with US English UI and help files.
Libo settings that might be related to your problems (video hardware acceleration ...): I didn't even know there is such an option in LibO. Presume I have the default. Hardware acceleration for Windows XP is set to full.
how you launch LibO: I use shortcuts for "LibreOffice Calc" and "LibreOffice Writer" on my desktop, copied from the start menu.

(*) In the Regional and Language Options control panel:
Regional Options tab:
  Standards and Formats: Greek
  Location: Greece
Languages tab:
  Text services and input languages:
    Details:
      Default input language: English (United States) - US
      Installed services: EN and EL
Advanced tab:
  Language version of non-Unicode programs: Greek


I tried a parallel install on System 1. The problem persists. (Ditto for bug 40585, which seems to be related.) If you've read through this thread, I had already tried doing a full uninstall with Revo uninstaller, before reinstalling, and there was no change after reinstalling.

I have also tried running LibO in safe mode, to see if there was interference from some other installed program, but I still get crashes. I think that the only thing that was left activated was my use of X-Mouse (configured using TweakUI), but deactivating it didn't help, either.

The problem is not present in version 3.3, so this is definitely a regression. It was also present in an earlier version of 3.5, that I tried a while back.


I know that at least two people (you and manj_k) cannot reproduce this problem, but since I've seen it on both my home and work computers, I am convinced that the problem is quite real, so I don;t thing that "works for me" is a satisfactory answer. Please help me to help you: we know we have two systems (mine) on which the bug can be consistently reproduced, so how can we take advantage of this? Is there a way to produce stack traces, e.g.? I'd even be willing to build a debug version of LibO, if there is no other way to produce stack traces.


If this bug is indeed related to bug 40585, where someone, who had encountered it on Linux, was able to fix it by installing a newer version of ICU, could it be that I need to install a newer version of some localization library by hand? Both my systems are fully patched, as far as windows update goes, but I might be missing something else.
Comment 25 Rainer Bielefeld Retired 2011-11-13 08:02:00 UTC
Also NOT reproducible with "LibreOffice 3.4.4  - WIN7 Home Premium (64bit) Greek UI  [OOO340m1 (Build:402)]".

@kyrimis@alumni.princeton.edu
Did you create a new user profile for your parallel installation?
Comment 26 Kriton Kyrimis 2011-11-14 00:48:54 UTC
I followed the procedure described in http://wiki.documentfoundation.org/Installing_in_parallel#Windows where bootstrap.ini is modified to keep profiles in the installation directory, so presumably I had a different profile.

Moreover, if you look at comment 12, I think we have already verified that this is not a problem with my profile:
* I removed my profile, eradicated LibO using Revo Uninstaller and CCleaner, then reinstalled: the problem persists, with a freshly installed profile.
* I sent said profile to manj_k, who did not have the problem, and verified that he still did not have that problem with that profile.


Now, if this had happened to only one of my two systems, I might write this off as a problem with that particular installation. With two systems, this is more of an indication that there may be something wrong with LibO. Rare, perhaps, but wrong nevertheless. So, let me iterate: is there a way we can take advantage of the fact that we have two systems available, where this problem appears?
Comment 27 Jorge Meza 2011-12-15 12:53:44 UTC
Well i have a spanish version LibreOffice 3.4 running on Windows 7 32 bits
I reproduced this many times, when i selected Herramientas> Opciones> Configuración de Idioma

Tools> Options> Language Settings, and writer crashes for a little while, then it works right! So this is a reproducible bug, but after a moment it works.
Comment 28 Björn Michaelsen 2011-12-23 14:30:25 UTC
needs reproducable scenario.
Comment 29 Kriton Kyrimis 2011-12-26 11:21:56 UTC
Bug persists with both 3.4.5rc1 and 3.5.0beta2.
Comment 30 Rainer Bielefeld Retired 2011-12-26 22:41:43 UTC
> Moreover, if you look at comment 12, I think we have already verified that this
> is not a problem with my profile

Yes, indeed, you already did the test.

I do not know whether "Process Monitor" can be useful:
<http://technet.microsoft.com/en-us/sysinternals/bb896645>
Comment 31 Kriton Kyrimis 2011-12-28 13:17:18 UTC
> I do not know whether "Process Monitor" can be useful:

Filtering for "swriter.exe" I don't see anything printed during the crash.

Filtering for "soffice.bin", I get a few occurrences of

QueryOpen  C:\Program Files\LibreOffice 3.4\program\soffice.bin.Local

but I also get them before the crash, as well. Note that this particular file does not seem to exist on my computer.
Comment 32 Eike Rathke 2012-01-03 03:59:26 UTC
*** Bug 40585 has been marked as a duplicate of this bug. ***
Comment 33 Eike Rathke 2012-01-03 04:02:08 UTC
@kyrimis: no one seems to be able to reproduce your problem, this and bug 40585. I doubt there's anything we can do unless someone with a debugger attached to the soffice.bin process is able to reproduce. So maybe you could be that hero? :-)
Comment 34 Eike Rathke 2012-01-03 04:13:27 UTC
Can anyone reproduce this on Windows XP with the Regional Settings setup as described in comment 24?
Comment 35 Kriton Kyrimis 2012-01-04 06:45:35 UTC
> So maybe you could be that hero? :-)

I spent about a day trying to build LibreOffice, and failed miserably.

Using the sources from git (actually, the weekly tarball), I had to deal with an increasing amount of problems (mysterious hangs, syntax errors in unknown configuration files, resulting in erroneous commands, that I had to fix and run by hand), until, with less than 20 modules to go, I encountered some unresolved symbols during linking, which I had no idea how to resolve.

Assuming that this was because the git sources may not be in a stable state right now, I tried compiling the 3.4.4 sources. I started getting a mysterious hang again, only this time restarting the build process would hang again at the same place.

At this point, I have reached the point of diminishing returns: reinstalling windows is probably going to be quicker (not that I'm going to do it), and will likely fix the problem, so I give up.

It would seem that building LibreOffice under windows is a black art. I may have gained more respect for those people who actually do it every day, but it is definitely not for someone who is not interested in developing LibreOffice, but only in producing a one-off debug build to see where a crash occurs. This makes it more imperative that automatic crash reporting is implemented in LibreOffice.

I would appreciate it if the bug was left open, as fixing something else might fix this, as well. I got the impression that there has been quite a bit of restructuring between 3.4 and the git version (3.6!) so this is not unlikely.
Comment 36 Rainer Bielefeld Retired 2012-01-08 09:24:46 UTC
> It would seem that building LibreOffice under windows is a black art. 

@kyrimis@alumni.princeton.edu 
I'm afraid it's even worse :-(
Currently if we are lucky we get a WIN build every week.
Did you ever think about MinGW?
Comment 37 Roman Eisele 2012-04-17 03:39:06 UTC
[REPRODUCED] this (or a very similar bug) on MacOS X 10.6.8 German with the current master build: LOmaster 3.6.0alpha0+, Build ID: 55823d3 (installation file: master~2012-04-14_05.23.05_LibO-Dev_3.6.0alpha0_MacOS_x86_install_en-US.dmg).

What I did:
1) Download the current master build (see above) and the US English langpack.
2) Delete any previous LibreOffice/LOdev installation.
3) Install the current release and, immediately after that, install the US English langpack.
   NB: Do NOT install any additional dictionaries, extensions, etc.
4) Delete any LibreOffice related stuff (settings etc.) in ~/Library/Application Support/LOdev/ (the complete folder) and in ~/Libray/Preferences/ (I found two files with names starting with org.libreoffice...).
5) Start LOdev.app.
6) Select 'Preferences ... > Language Settings > Languages'.
7) The right dialog pane appears, everything is fine.
8) Click 'OK' (without changing anything).
9) Quit LOdev. Note that the folder at ~/Library/Application Support/LOdev/ is created again.
10) Start LOdev.app, the 2nd time now.
11) Select 'Preferences ... > Language Settings > Languages', the 2nd time now.
12) Expected: the dialog pane should appear again, like in step 7.
    Result: CRASH.

I can repeat steps 4 to 12 again and again:
Everytime I delete the complete folder at ~/Library/Application Support/LOdev/ first, LOdev will show the 'Language' settings again, but if then I quit and restart LOdev and try to access the Language settings once more, LOdev crashes again.

I will attach the MacOS X log file generated on the crash.

This is either the same or a new, but very similar bug. I did not notice this behaviour before with LibreOffice on MacOS X. Either there has something changed in Master (then this would be a new, but very similar bug), or the reason may be related to the fact that this time I have only installed the US English help pack, no German or other help pack, and that the Language of the user interface is still US English, while the OS language is German ...
Comment 38 Roman Eisele 2012-04-17 03:40:27 UTC
Created attachment 60158 [details]
MacOS X log file generated on crash when accessing Language settings a 2nd time
Comment 39 Kriton Kyrimis 2012-04-17 03:50:16 UTC
(In reply to comment #37)

Out of curiosity, can you also reproduce bug 40585 (crash after selecting a cell in calc, then selecting Format->Cells from the menu) which has been marked as a duplicate of this bug?
Comment 40 Roman Eisele 2012-04-17 03:53:24 UTC
Created attachment 60159 [details]
The Language settings preferences pane, as it appears at Step 7) of Comment #37

This screenshot may be of little help, but at least it shows what language settings LOdev chooses automatically when I open 'Preferences... > Langage Settings > Languages' for the 1st time.
Comment 41 Roman Eisele 2012-04-17 04:02:27 UTC
Additional observation to my comment #37:
If I don't quit LOdev after step 8), but open 'Preferences ... > Language Settings > Languages' again, the preferences pane is shown correctly again. It is necessary to quit LOdev and to start it again at least once -- then the crash appears everytime I select 'Preferences ... > Language Settings > Languages'.

Additional note to my comment #37:
This test was done on a near-to-empty user profile (not with my real working profile) with no special settings, LOdev was installed for this user profile only (not for all users).
Comment 42 Roman Eisele 2012-04-17 07:02:28 UTC
(In reply to comment #39)
> Out of curiosity, can you also reproduce bug 40585 (crash after selecting a
> cell in calc, then selecting Format->Cells from the menu) which has been marked
> as a duplicate of this bug?

"Yes, we can!" ;-) The log file produced by MacOS X for the crash by bug 40585 looks nearly identical to the one I attached to this (present) bug report. I will add some details to the bug report for bug 40585 soon.
Comment 43 Roman Eisele 2012-04-21 11:04:23 UTC
When I wrote about how I reproduced this bug with a Master build (comment #37), I had the hope that the crash I got by the given steps was not another bug newly introduced into Master, but that some change in the codebase had made it easier to reproduce this bug for me and that the MacOS X log files for the crash I attached to this bug report would be of some help to track down this annoying bug.

But now I have tested this issue again with a newer Master build: LOdev 3.6.0alpha0+, Build ID: 503c8fd (installation file: master~2012-04-20_00.38.41_LibO-Dev_3.6.0alpha0_MacOS_x86_install_en-US.dmg), again on MacOS X 10.6.8. And -- the bug is gone for me: I don't get a crash anymore, I can view and change the Language Settings as expected again. The same is true for bug 40585, which is identical with (or related to) the present bug.

So I think that probably the crash I could reproduce so easily in the Master build dated 2012-04-14 was not the long standing issue this report is talking about, even if everything looked the same way and all circumstances were identical, but that I just triggered some new instability which raised in the Master codebase and now has gone away again. On the one hand, this is good (because Master builds are now much more easy to use and test again for me), on the other hand, this is bad, because I may have distracted your attention from more important problems. I am sorry for any inconvenience this may have cause to you.
Comment 44 Kriton Kyrimis 2012-11-19 15:51:29 UTC
The bug seems to have magically disappeared!

I checked both the computer at work, where I had just installed 3.6.4RC1, and the computer at home, where I'm still running 3.6.3, and on both machines Language Settings->Language and Format->Cells (duplicate bug #40585) work fine. Given that I'm sure I checked that the problem was still present when version 3.6.3 was released, I can only assume that the fix is due to one of the Windows updates that were released last week. This, presumably, means that the cause of the problem may have been some earlier Windows update!
Comment 45 Roman Eisele 2012-11-20 07:29:25 UTC
@ kyrimis:
Thank you for your comment! So, if you can no longer reproduce this bug,
I suggest to close this bug (for now) as RESOLVED/WORKSFORME. If you ever happen to reproduce this bug again, you can easily set its status to REOPENED ...

Thank you very much!