Bug 31919 - Mac: program beach-balls and then crashes when topic is selected within Preferences.
Summary: Mac: program beach-balls and then crashes when topic is selected within Prefe...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: a11y-macOS
  Show dependency treegraph
 
Reported: 2010-11-25 09:57 UTC by Chris Makepeace
Modified: 2012-11-15 11:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Makepeace 2010-11-25 09:57:58 UTC
Component: UI?? Happens when Preferences (what component is that?) is up and a topic is selected.
Version: is actually OOo 3.2 and up.  No change with any recent version.

If a Console dump is needed, I'll install LO/OOo and make one.

This doesn't happen with current Neo Office.
Comment 1 Thorsten Behrens (CIB) 2010-11-25 11:00:59 UTC
Chris, yes, please - since I don't see the crash here, please obtain & attach log.
Comment 2 Alex Thurgood 2010-11-25 12:54:35 UTC
This doesn't affect me either, running LibO 3.3 Beta 3 (the latest available public beta) on Mac OSX 10.6.5.

What version of Java do you have ?


Alex
Comment 3 Chris Makepeace 2010-11-25 13:26:36 UTC
Alex,

On 25 November 2010 20:54, <bugzilla-daemon@freedesktop.org> wrote:

> What version of Java do you have ?
>

Java SE 6

HTH,
Comment 4 Alex Thurgood 2010-11-25 13:32:27 UTC
Not enough info, I'm afraid, can you type in java -version into the Terminal.app and let us know what the output is ?


Alex
Comment 5 Alex Thurgood 2010-11-25 13:33:37 UTC
You mention OOo 3.2.1 - which version of LibO are you using ?


Alex
Comment 6 Alex Thurgood 2010-11-25 13:34:17 UTC
Oh and which version of Mac OS X ?

Thanks,

Alex
Comment 7 Chris Makepeace 2010-11-25 14:00:29 UTC
Alex,

On 25 November 2010 21:32, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=31919
>
> --- Comment #4 from Alex Thurgood <alex.thurgood@gmail.com> 2010-11-25
> 13:32:27 PST ---
> Not enough info, I'm afraid, can you type in java -version into the
> Terminal.app and let us know what the output is ?
>
>
>
>
It says:
BigMac:~ chrism$ java -version
java version "1.6.0_22"
Java(TM) SE Runtime Environment (build 1.6.0_22-b04-307-10M3261)
Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03-307, mixed mode)
BigMac:~ chrism$
Comment 8 Chris Makepeace 2010-11-25 14:06:31 UTC
On 25 November 2010 19:00, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=31919
>
> tbehrens@novell.com


This behaviour doesn't happen on my other Mac (mini) with identical OS and
Java.

...So you know.
Comment 9 Alex Thurgood 2010-11-25 14:44:48 UTC
Which version of LibreOffice ?

I had similar behaviour with the Beta 1 of LibreOffice, but not with beta 2 or beta 3.

I don't have the problem with OOo 3.2.1 either.

You still haven't said which version of Mac OSX ?
Or which version of LibreOffice ? (even if you have the same OS on your MacMini) :-)


Are the graphics chips different on each machine ? (me thinking of OpenGL bugs here, perhaps ?)

The trouble is, if its an OpenGL problem, then AFAIK you can only get to it via...the Preferences menu to turn off OpenGL rendering - catch 22 :-/

This is the graphics chip on my MacBook Pro :
NVIDIA GeForce 320M
VRAM (totale) :	256 Mo
Fournisseur :	NVIDIA (0x10de)
Identifiant du périphérique :	0x08a0
Identifiant de révision :	0x00a2
Révision de la ROM :	3533



Alex
Comment 10 Alex Thurgood 2010-11-25 14:51:33 UTC
Forget my last comment, the Preferences > General > View doesn't have the "Hardware acceleration" option activated (in fact it is greyed out) in my beta 3.

You're not running the OS in 64bit mode, are you ?

I don't know how good LibO (and OOo for that matter), run in 64bit mode on the Mac OS platform - the Mac versions of LibO/OOo are currently 32bit compiled only I seem to recall. It doesn't mean they won't run, but I don't know how stable they are in 64bit mode. Perhaps others here with Macs already do that and have feedback.


Alex
Comment 11 Chris Makepeace 2010-11-25 15:38:06 UTC
On 25 November 2010 22:51, <bugzilla-daemon@freedesktop.org> wrote:

> You're not running the OS in 64bit mode, are you ?
>
> I don't know how good LibO (and OOo for that matter), run in 64bit mode on
> the
> Mac OS platform - the Mac versions of LibO/OOo are currently 32bit compiled
> only I seem to recall. It doesn't mean they won't run, but I don't know how
> stable they are in 64bit mode. Perhaps others here with Macs already do
> that
> and have feedback.
>

Am running 10.6.5.  10.6.x runs by default in 64-bit mode, I understand, but
drops to 32 if needed.  half the progs on my box are 32-bit and run fine on
it.  Doesn't mean they all will, I imagine.

Anyone with OS X and LO familiarity care to comment?
Comment 12 Alex Thurgood 2010-11-25 15:55:56 UTC
Just checked on mine, bought only 2 months ago. Mine boots into 32 bit mode by default. Allegedly, the 64bit mode default was only made available in Mac OS shipped from April 2010 (so I must have a machine from older stock). 

Alex
Comment 13 Chris Makepeace 2010-11-25 16:06:26 UTC
On 25 November 2010 23:55, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=31919
>
> --- Comment #12 from Alex Thurgood <alex.thurgood@gmail.com> 2010-11-25
> 15:55:56 PST ---
>
> Just checked on mine, bought only 2 months ago. Mine boots into 32 bit mode
> by
> default. Allegedly, the 64bit mode default was only made available in Mac
> OS
> shipped from April 2010 (so I must have a machine from older stock).
>
> Alex
>
> Hmm... my mini is April 2008 (2 GHz core 2 Duo) but running 10.6.5 and runs
64 by default.  Only 20% of Apps are 32-bit, according to 'Sys. Profiler,
Applications'.
Comment 14 Alex Thurgood 2010-11-25 16:15:32 UTC
OK, booted into 64bit, and can still navigate the Preferences menu entries without it crashing.

Alex
Comment 15 Chris Makepeace 2010-11-26 03:59:13 UTC
Hi all,

On 26 November 2010 00:15, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=31919
>
> --- Comment #14 from Alex Thurgood <alex.thurgood@gmail.com> 2010-11-25
> 16:15:32 PST ---
> OK, booted into 64bit, and can still navigate the Preferences menu entries
> without it crashing.
>

I think this report is peculiar to my machine: some wires-crossing that is
screwing its use up.  As such I don't want to intrude on your more general
improvement/bug-hunting work.

It's funny that the only OOo-type version that works on this machine is
NeoOffice, whose version no. seems to be 'NeoOffice 3.1.2 Patch 0'.  Both
have the same (latest) Java RE
(java version "1.6.0_22"
Java(TM) SE Runtime Environment (build 1.6.0_22-b04-307-10M3261)
Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03-307, mixed mode)

Any suggestions where else I could listen and look to get help with this
oddity?  I don't want a whole re-install again - I gave that up with
Windows.

Many thanks to you all for your help with this.
Comment 16 Thorsten Behrens (CIB) 2010-11-26 13:18:09 UTC
Chris, as per my private answer to you - it looks like you have some sort of accessibility tool (VoiceOver, maybe?) enabled, that triggers a code path apparently not too stable. Could you check which tool is running & report back?

Alex, the above is the difference to our systems.
Comment 17 Alex Thurgood 2010-12-21 02:30:35 UTC
@Thorsten :

Hmm, I recall the accessibility thing as being a previously known issue with OOo and Mac, but can't remember the bug number.

Alex
Comment 18 Roman Eisele 2012-04-19 01:26:59 UTC
This bug seems to be identical or at least related to the one reported as bug
37913 - "LibreOffice crashes frequently when settings-dialog is opened".

Therefore I mark this present bug report as a duplicate of the one for bug
37913. This is important to show how many people are affected by this bug and
that it is a important bug, having some duplicates.

*** This bug has been marked as a duplicate of bug 37913 ***
Comment 19 Roman Eisele 2012-09-12 13:52:53 UTC
Mac Accessibility Related Bugs Survey Results
---------------------------------------------

This bug is very very similar to bug 52147 and bug 54282, which have been both
fixed by Michael Meek’s patch for bug 47368:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=3234b715b5a6d13ee673b41066eb565706be5ec9

Therefore it is very probable that this bug has been fixed by that commit, too.
This fix will appear in LibreOffice 3.6.2 and 3.7.0.

But I can’t tell for sure, especially because no crash log is attached to this
bug report; therefore I can’t even tell if this bug is related to Mac OS
Accessibility features (like bug 52147 and bug 54282) or not.

Therefore I was too hasty when I marked this bug as a duplicate of bug 37913.
Instead, I should have asked the original reporter for more details, and
therefore this is what I need to do now -- sorry!


@ Chris Makepeace :
To resolve this issue, we need to ask you some questions.

1) Can you still reproduce this issue with a current version of LibreOffice
(3.5.6 or 3.6.1)?

If yes, could you please attach the debug information created by Mac OS X on
the crash to this bug report? (If you need instructions how to do this, please
send me a short mail to   bugs@eikota.de   -- thank you!)

If yes, please answer also the following questions:

2) Do you have any accesibility features enabled? Apple’s accessibility
features like "VoiceOver" or "Enable access for assistive devices", which get
enabled in "System Preferences > Universal Access" (in German:
"Bedienungshilfen"; dont’t know about other languages), are known to cause many
crashes in LibreOffice (see bug 47368). So please try to disable any
accesibility features, i.e. uncheck "VoiceOver", "Enable access for assistive
devices", etc.

3) Do you have installed any window management/user interface utilities/apps
for MacOS X like 
* Moom      (see bug 42014)
* Cinch     (see bug 51791)
* RightZoom (see bug 51686)
* ShiftIt   (see bug 52147)?
All these and many similar utilities rely heavily on accessibility issues and
therefore cause LibreOffice to crash. So please check if you have installed any
utility of this kind and try to disable it (or to add LibreOffice to the list
of excluded applications for the utility, if there is such a thing).

Disabling both Apple’s accessibility features and all
accessibility-related/window management utilities, and then re-starting your
Mac should fix the LibreOffice crash. Please try this.

Thank you very much in advance!
Comment 20 Roman Eisele 2012-09-12 14:21:57 UTC
Set Version field according to comment #1 (“OOo 3.2 and up” means since the first version, therefore we use “3.3.0 Beta2”).
Comment 21 Roman Eisele 2012-11-15 11:44:37 UTC
Dear bug reporter,

I am sorry, but we can not do anything about this issue without more information from you. The questions asked in comment #19 have not been answered for more than two months now, therefore we need to close this bug report.

I can not manage to reproduce this bug in any way with a current version of LibreOffice (3.6.3). It seems very probable that this bug was identical with bug 47368, which has been fixed in between. Therefore I mark this bug report as RESOLVED/WORKSFORME.

Feel free to open this bug report again, if you still experience the problem
with a current version of LibreOffice (3.6.3 or better).

Thank you very much!