Bug 33379 - Searching in all sheets will not work after using the Find toolbar
Summary: Searching in all sheets will not work after using the Find toolbar
Status: RESOLVED DUPLICATE of bug 33593
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
3.3.0 RC4
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Kohei Yoshida
QA Contact:
: 37973 (view as bug list)
Depends on:
Blocks: mab3.4
  Show dependency treegraph
Reported: 2011-01-23 05:18 UTC by Tohotom
Modified: 2011-08-02 05:55 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Tohotom 2011-01-23 05:18:41 UTC
To reproduce:

1. Open a spreadsheet file with multiple sheets (I used a file with 25 sheets containing text. I have tried it with both .osd and .xls formats).
2. Search for something using the Find toolbar.
3. Hit Ctr + F, enable "Search in all sheets" option.
4. Search for something that is not on the active sheet. 

The program will search only in the active sheet, even if the "Search in all sheets" option is enabled.

Searching in all sheets will work properly if used prior to the Find toolbar.
Comment 1 Rainer Bielefeld Retired 2011-01-23 06:32:22 UTC
[Reproducible] with "LibreOffice 3.3.0 RC4 - WIN7  Home Premium (64bit) German UI  [OOO330m19 (build 6 / tag]", I tried with a simple 3 pages sample. 

"Search all sheets" also will be lost for all other open sheets.

You will have to close LibO to get "search all sheets" working again.
Comment 2 Rainer Bielefeld Retired 2011-01-23 06:54:54 UTC
Also reproducible with "Ooo-Dev 3.4.0 multilingual version English UI WIN XP: [OOo300m98 (Build 9568)]"!
Comment 3 Cor Nouws 2011-05-13 06:53:05 UTC
also problem in 340beta5 (Ubuntu)
Comment 4 vitriol 2011-06-06 01:45:26 UTC
*** Bug 37973 has been marked as a duplicate of this bug. ***
Comment 5 Rainer Bielefeld Retired 2011-07-15 06:42:07 UTC
I believe Kendy also should have look, seems to be Findbar related
Comment 6 Jan Holesovsky 2011-07-26 15:16:32 UTC

*** This bug has been marked as a duplicate of bug 33593 ***
Comment 7 iron51 2011-08-02 05:35:07 UTC
Just downloaded version 3.4.2 and the problem is still there


On Wed, Jul 27, 2011 at 12:16 AM,  <bugzilla-daemon@freedesktop.org> wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=33379
> Jan Holesovsky <kendy@suse.cz> changed:
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>             Status|ASSIGNED                    |RESOLVED
>         Resolution|                            |DUPLICATE
> --- Comment #6 from Jan Holesovsky <kendy@suse.cz> 2011-07-26 15:16:32 PDT ---
> *** This bug has been marked as a duplicate of bug 33593 ***
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
Comment 8 Rainer Bielefeld Retired 2011-08-02 05:55:50 UTC
It's not very useful to post in "dead" Bugs marked as DUP, if you think you have useful information please leave it in the report you can reach with the link in the bug number behind RESOLVED DUPLICATE
If you would have looked there you would have found in Comment 9 that it's fixed for MASTER (currently means: for 3.5).
Can you please write comments without citatation? the cited text is completely useless.
If you are interested in learning more about LibO's bug fixing process you should jump at the chance and join our Bug Hunting Session, you fin information here:

Thank you for your attention!