Bug 33571 - Add Russian extension for spell check
Summary: Add Russian extension for spell check
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Andras Timar
QA Contact:
URL:
Whiteboard:
Keywords:
: 33235 33594 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-26 22:46 UTC by Alexander L. Slovesnik
Modified: 2011-01-30 23:36 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander L. Slovesnik 2011-01-26 22:46:04 UTC
Currently LibreOffice ships without Russian spell check dictionary. I propose to include in LibreOffice Russian spell check dictionary, shipped in Mozilla products (Firefox/Thunderbird/SeaMonkey).
A bit of history: Initially license of Russian spell check dictionary prevented it from inclusion in Mozilla products. Per request from Mozilla, author of Russian spell check dictionary has changed its license to BSD (see ftp://scon155.phys.msu.su/pub/russian/ispell/LICENSE or ftp://scon155.phys.msu.ru/pub/russian/ispell/LICENSE), Mozilla has approved this dictionary and it was included in Mozilla products (see https://bugzilla.mozilla.org/show_bug.cgi?id=389071).
This dictionary also has been packed as extension http://extensions.services.openoffice.org/en/project/dict_ru_RU (note that author of this extension forgot to update its license).

Please, consider to include Russian spell check dictionary in LibreOffice. Andras, can you please help here? I'm kinda new to LibreOffice development process, should I create patch and request review or something like that?
Comment 1 Andras Timar 2011-01-26 23:16:50 UTC
Can I take the dictionaries from Mozilla's repository? Do you have the latest version there? I'll create the patch.
Comment 2 Alexander L. Slovesnik 2011-01-26 23:23:00 UTC
(In reply to comment #1)
> Can I take the dictionaries from Mozilla's repository? Do you have the latest
> version there? I'll create the patch.
Yes, the latest version of dictionary is in hg.mozilla.org/l10n-central/ru/
Please, take this version.
Comment 3 Andras Timar 2011-01-27 11:51:46 UTC
*** Bug 33594 has been marked as a duplicate of this bug. ***
Comment 5 Alexander L. Slovesnik 2011-01-29 06:44:27 UTC
*** Bug 33235 has been marked as a duplicate of this bug. ***