Download it now!
Bug 33912 - File registrymodifications.xcu is resetted after closing LibreOffice
Summary: File registrymodifications.xcu is resetted after closing LibreOffice
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: PowerPC Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Customize-Dialog-Keyboard
  Show dependency treegraph
 
Reported: 2011-02-04 10:20 UTC by j.t.d.jager
Modified: 2012-08-31 10:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description j.t.d.jager 2011-02-04 10:20:46 UTC
After closing LibreOffice, the file registrymodifications.xcu will be resetted. (It happened right after closing. Not at the moment of restarting.)
So the next time LibreOffice starts, it starts with default options (e.g.: default general options, default autocorrection-options, default toolbars). The file is situated in ~/.libreoffice/3/user/.

Note: Not always when closing LO, the file will be resetted. Up to this moment I can't figure out what is making the reset happens.

Note: when using quickstart: after a reset of the file the icon of the quickstart changes from LibreOffice-icon tot OpenOffice-icon
Comment 1 herrdeh 2011-02-15 05:37:31 UTC
me too!
Comment 2 j.t.d.jager 2011-02-17 05:18:32 UTC
(In reply to comment #0)
> After closing LibreOffice, the file registrymodifications.xcu will be resetted.
> (It happened right after closing. Not at the moment of restarting.)
> So the next time LibreOffice starts, it starts with default options (e.g.:
> default general options, default autocorrection-options, default toolbars). The
> file is situated in ~/.libreoffice/3/user/.
> 
> Note: Not always when closing LO, the file will be resetted. Up to this moment
> I can't figure out what is making the reset happens.
> 
> Note: when using quickstart: after a reset of the file the icon of the
> quickstart changes from LibreOffice-icon tot OpenOffice-icon

It seems to be this will NOT happens, if NOT saving changes to your document when closing LO. That will say: to the last document you close. Ex.: You are working at 6 files. You can close 5 of them without any problems. When you close the last one, you have to close it without saving changes.
Comment 3 herrdeh 2011-03-17 02:29:15 UTC
I cannot confirm commen #2: This workaround does not work on my Macs (Mac OS X 10.5.8 Leopard, PPC ).
Comment 4 Rainer Bielefeld Retired 2011-10-18 10:54:06 UTC
This one might be related to "Bug 40578 - CONFIGURATION: Tools-Customize-Keyboard changes should be persistent".
Comment 5 Björn Michaelsen 2011-12-23 11:47:40 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 6 Florian Reisinger 2012-08-14 14:00:46 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 14:01:53 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 8 Florian Reisinger 2012-08-14 14:06:35 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 9 Florian Reisinger 2012-08-14 14:08:37 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian