Download it now!
Bug 40578 - CONFIGURATION: Tools-Customize-Keyboard changes should be persistent
Summary: CONFIGURATION: Tools-Customize-Keyboard changes should be persistent
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 34685 (view as bug list)
Depends on:
Blocks: Customize-Dialog-Keyboard
  Show dependency treegraph
 
Reported: 2011-09-02 05:11 UTC by Robert Schiele
Modified: 2012-02-02 03:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Schiele 2011-09-02 05:11:01 UTC
User-changes under menus Tools/Customize/Keyboard should be made persistent as is done under menus Tools/Options, without the need for users to manually save a separate configuration text file and subsequently to manually reload said configuration file each time WRITER is run as is currently the case.
Comment 1 Rainer Bielefeld Retired 2011-10-06 23:53:49 UTC
@Robert Schiele:
I do not understand the problem you want to solve. Please contribute a concrete scenario.
Comment 2 Robert Schiele 2011-10-07 05:01:38 UTC
(In reply to comment #1)
> @Robert Schiele:
> I do not understand the problem you want to solve. Please contribute a concrete
> scenario.

I'll try. Currently (v 3.43) there is no way to make permanent, persistent changes to keyboard shortcuts. User can use Tools/Customize/Keyboard dialog box to change/delete default keyboard shortcuts, but changes made are neither permanent nor persistent from session to session. It is possible to save changes made to a file, then load file each time LibreOffice Writer is run, but this seems unnecessarily clunky.

One proposed solution would be to have changes thus made saved and then automatically reloaded on program start as are changes made under Tools/Options dialogs. Another, less optimal but acceptable solution would be ability to present Libre Office Writer with custom keyboard.cfg file on startup via command line, since this could be included and made persistent via a desktop shortcut.

Hope the above helps, and thanks for looking into it.
Comment 3 Rainer Bielefeld Retired 2011-10-07 07:22:27 UTC
How I tried to reproduce with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  d3d1481-3f8994a-2ba0a9f)]" (110909):

1. Start LibO from WIN Start Center
   LibO Start Center appears
2. open new WRITER document from start Center and Type word "Bold"
3. Menu 'Tools -> Customize -> Key board'
4. select 'Contro+B', in list "Shortcut keys" click button <delete>
   Function "Bold will be deleted" for that short cut
5. select 'Alt+Shift+E'
6. Select Category=Format, Function=bold
7. Radio button "Writer", click <Modify>
   Bold appears behind  Shortcut Key 'Alt+Shift+E'
8. doubleclick word "Bold" in document, oo shortcut 'Alt+Shift+E'
   as expected toggles bold - not bold
9. Menu 'File -> Exit' LibO without saving
10. Redo steps 1,2,8
    as expected toggles bold - not bold

Analogous result with "LibreOffice 3.4.3  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]"

Even after a PC reboot both new shortcuts worked fine in both Versions. So I can't reproduce reporter's results.

@Robert Schiele:
Please contribute a step by step instruction as you see here how to reproduce your problems. General descriptions as you contributed are very very problematic, because a QA tester never can know whether he tried exactly the same like you. And reproducibility is the base for all further thoughts.

Please additionally
- contribute information
  -- concerning your PC (especially: video card)
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO localization (UI language)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  –- If you can contribute an OOo Issue that might be useful
  -- whether really only a WRITER problem
  -- everything else crossing your mind after you read a.m. URL
Comment 4 Rainer Bielefeld Retired 2011-10-07 07:48:31 UTC
And some new results!
As I saw in my test the new shortcut was persistent, but unexpectedly the old shortcut 'Control+B' also was visible for Category=Format, Function=bold after reboot - I did not check before. So I did the test again with an other Master version: Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  3b32204-7f92fce-2ba0a9f)]" (110903)

A) After step 8: Old shortcut does not work, new one does, in newly opened
   Customize Menu only new shortcut for Bold is visible
B) Close document so that Start Center Appears, I newly open 
   New WRITER document and type a word:
   Old shortcut does not work, new one does, in newly opened
   Customize Menu only new shortcut for Bold is visible
C) I proceed steps 9,10 
   New WRITER document and type a word:
   Old shortcut DOES work, new one DOES, in newly opened
   Customize Menu BOTH shortcuts for Bold are visible

So the problem seems to be that newly defined shortcuts using unused combinations are persistent, but default shortcuts reappear after Exit LibO?
Comment 5 Robert Schiele 2011-10-07 07:57:14 UTC
(In reply to comment #4)
> And some new results!
> As I saw in my test the new shortcut was persistent, but unexpectedly the old
> shortcut 'Control+B' also was visible for Category=Format, Function=bold after
> reboot - I did not check before. So I did the test again with an other Master
> version: Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium
> (64bit) English UI [(Build ID:  3b32204-7f92fce-2ba0a9f)]" (110903)
> 
> A) After step 8: Old shortcut does not work, new one does, in newly opened
>    Customize Menu only new shortcut for Bold is visible
> B) Close document so that Start Center Appears, I newly open 
>    New WRITER document and type a word:
>    Old shortcut does not work, new one does, in newly opened
>    Customize Menu only new shortcut for Bold is visible
> C) I proceed steps 9,10 
>    New WRITER document and type a word:
>    Old shortcut DOES work, new one DOES, in newly opened
>    Customize Menu BOTH shortcuts for Bold are visible
> 
> So the problem seems to be that newly defined shortcuts using unused
> combinations are persistent, but default shortcuts reappear after Exit LibO?

Yes, default shortcuts reappear. This might not be major issue if the desire is to redefine shortcut as new key, since new key assignment does seem to take precedence, but if desire is to completely remove shortcut (i.e. to cause particular key or combinations of keys NOT to act as shortcut), default reappears anyway.

BTW, I am working with Windows 7 Home Premium with Service Pack 1, 64-bit, US English version, also LibreOffice v 3.43 (Build:302), win_X86 install version.
Comment 6 Rainer Bielefeld Retired 2011-10-07 08:32:12 UTC
The observed LibO behavior differs from OOo 3.1.1, there the new shortcut persists, old default did not reappear after Exit.

Observed behavior of LibO 3.4.3 and Master also [Reproducible] with "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6 Tag 3.3.0.4)]" 

Related Bugs might be:
Bug 36628 - Can't delete default shortcut keys  (My favorite)
Bug 34685 - Shortcut editor broken
Bug 34703 - New keyboard shortcuts are sometimes not remembered
Bug 33912 - File registrymodifications.xcu is resetted after closing LibreOffice
Bug 35017 - Shortcuts that can not be modified permanently should be marked
Bug 36975 - feature request across the LO suite re: font size

and with low probability
Bug 32876 - Keyboard shortcuts for go to Begin and End of line are not overriding default behaviour
Bug 34704 - Keyboard shortcut editor is insufficient
Bug 34804 - EDITING: Keyboard shortcut for Format-Highlighting does not work
Bug 35034 - Shift key and caps lock activate menu shortcuts

I will add a hint concerning this bug to all or them, hoping we can reduce number of reports by some DUPs.
Comment 7 Rainer Bielefeld Retired 2011-10-19 08:25:26 UTC
*** Bug 34685 has been marked as a duplicate of this bug. ***
Comment 8 Björn Michaelsen 2011-12-23 12:36:51 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 9 sasha.libreoffice 2012-02-02 03:31:10 UTC
in LibO 3.5.0 beta it works properly
change status to WorksForMe

@ Robert
Please, if this problem appears again, change status to Reopened