Bug Hunting Session
Bug 35017 - Shortcuts that can not be modified permanently should be marked
Summary: Shortcuts that can not be modified permanently should be marked
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 36161 (view as bug list)
Depends on:
Blocks: Customize-Dialog-Keyboard mab3.4
  Show dependency treegraph
 
Reported: 2011-03-04 07:09 UTC by sasha.libreoffice
Modified: 2012-01-02 00:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2011-03-04 07:09:26 UTC
any component of office not saves functions assigned on key
To demonstrate this problem, for example, in Writer do Tools->Customize then on tab Keyboard select F2 in upper window and press Delete on right to it and then Ok. Now if press F2 nothing happens. But if close office and start Writer again and press F2, appears formula.
Calc also not saves settings. And other components.
produced on LibreOffice 3.3.1.2 on Mandirva 64 bit and windows XP 32 bit
Comment 1 Rainer Bielefeld Retired 2011-03-05 01:13:30 UTC
Generally that function works with "LibreOffice 3.3.1  – WIN7  Home Premium  (64bit) English UI [OOO330m19 (build 8 / tag 3.3.1.2)]", but indeed, some will not be saved.


Something that will be saved correction:

1. Open new WRITER document
2. press <f4> some times, nothing should happen
3. Menu 'Tools > Customize > Keyboard - F4': 
   In functions select "Styles - Numbering - Numbering 1"
4. Radio button "Writer"  
5. <Modify> 
   "Nmbering 1" will be added in shortcut keys list
6. <ok>
   Dialog closes
7. <f4>
   modifies paragraph style to "Numering" as expected
8. Create new docuemnt and test <f4>
   modifies paragraph style to "Numering" as expected
9. Exit from LibO without saving
10. Launch LibO and redo from step 8.

I did again analogously from step 1, tested <f2> (on / off for formula bar) and deleted this function from shortcuts list.

As reported: no longer available (after step 6)
As reported: default <f2> function reappears after exit / relaunch LibO

It seems that this shortcut key is "harcoded", oyu see that in Menu 
'tools > Customize >  Keyboard - Functions Cat.=Insert / Function=Formula'
(take second "Formula") in the "Keys" field a "F2" appears that can not be deleted

Also <cntrl>+<shift>+<j> ("Full screen") shows the same "hard coded" behavior as <f2>, and I belive all other ones where a key is shown in the key pane will show it, soon. 

But:
----
key <Save> after <Modify> will make permanent a modification of <cntrl>+<shift>+<j>, but not of <f2>

I believe it's intended that such very important functions can not be modified permanently. I agree that the current behavior can be worrying. Such shortcuts should be marked by special color, Italic or something else in the shortcut keys list.

Additionally this should be described in help. A good, but also not complete description you can find here:
<http://wiki.services.openoffice.org/wiki/Documentation/OOoAuthors_User_Manual/Getting_Started/Assigning_shortcut_keys>

I wonder where <save> saves the configuration, and I would like to know where I can find those configuration files.

@kendy: 
I still am worried, and I believe Help should be completed.
Comment 2 Rainer Bielefeld Retired 2011-03-05 02:06:11 UTC
Please also see Bug 35030 - RESET does not reset customized shortcut keys!
Comment 3 sasha.libreoffice 2011-04-06 07:03:01 UTC
LibreOffice saves information about key bindings in this place:
/.libreoffice/3/user/registrymodifications.xcu
it is differs from OpenOffice. LibreOffice holds almost all settings in this file and OpenOffice holds settings in some different files.

When I, for example, delete assignment from key Insert and press OK, in this file appears this line (I use Mozilla as viever):
<node oor:name="INSERT" oor:op="remove"/>
When I close LibreWriter, this line there still exist

When I start LibreOffice next time, this file contain this:
<node oor:name="INSERT" oor:op="replace">
    <prop oor:name="Command" oor:op="fuse">
        <value xml:lang="en-US">.uno:InsertMode</value>
    </prop>
</node>

Conclusion: keyboard settings disappear while starting of LibreOffice
Comment 4 Jan Holesovsky 2011-04-14 15:03:50 UTC
*** Bug 36161 has been marked as a duplicate of this bug. ***
Comment 5 Rainer Bielefeld Retired 2011-10-18 10:54:03 UTC
This one might be related to "Bug 40578 - CONFIGURATION: Tools-Customize-Keyboard changes should be persistent".
Comment 6 Björn Michaelsen 2011-12-23 11:47:40 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 7 sasha.libreoffice 2012-01-02 00:33:34 UTC
on Fedora 64 bit not reproducible in LibO 3.5.0 beta 1
my be fixed. Change status to worksforme in hope that it will work ok for me.