Bug 36975 - Can't assign keyboard shortcuts for Increase Font / Reduce Font
Summary: Can't assign keyboard shortcuts for Increase Font / Reduce Font
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 RC2
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 36981 (view as bug list)
Depends on:
Blocks: Customize-Dialog-Keyboard
  Show dependency treegraph
 
Reported: 2011-05-08 12:14 UTC by sh
Modified: 2012-05-04 03:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sh 2011-05-08 12:14:34 UTC
Best advice I found for feature request were a couple threads saying do it via bug report. If I'm wrong, please forward to the right recipient.

In Word I frequently used Increase/ or Decrease text size to best fit areas of text on a page. Often a block of text includes, for example, headlines or subheads in varying sizes. In LO I have to select each size of text, then assign a different specific size, and do that several times in trial-and-error to get a good fit. If there are several sizes of text I'm working with, I have to do the same tedious process with each size. It takes forever.

A simple keyboard command that enlarges or shrinks a block of text by a point enables the trial and error it takes to fit a whole block, including all its sizes and styles, into the most pleasing design.

Having this would make life easier by far! Thanks for all the great work on LO.

S. Hull
Comment 1 sh 2011-05-08 12:15:56 UTC
Using Mac OS 10.6.7
Comment 2 vitriol 2011-05-09 02:32:04 UTC
LibO already has this feature. You have to configure the Formatting toolbar to show properly icons (clic down arrow at right of toolbar), and/or you can add custom keyboard shortcuts via Tools > Customize...
I mark this bug as works for me. Feel free to reopen if this in not exactly what you wants.
Comment 3 sh 2011-05-09 12:15:06 UTC
Thank you very much. Added both to the personal custom toolbar I'd created, but am unable to create keyboard shortcut. I have assigned keys for both LibO and Writer, and reopening Tools>Customize shows both increase and reduce for the keys I assigned, but neither works.  Load... and Save... open a list of docs, but even after choosing the current doc to save or load, command does not work. (It also makes no sense. Surely, it isn't necessary to create the command for every doc individually.) 

I'm not a stranger to customizing keys, having done it for years in every app that allows it for Mac or Win 7. LibO does have a very different process than I've encountered anywhere else, so I must be doing something wrong or out of sequence. 

As it stands now, the assigned keys show in the shortcut keys list for both LibO and Writer, but neither works.

Completely flummoxed. Can you shed any light?

Thanks.
Comment 4 Noel Power 2011-05-10 08:08:59 UTC
*** Bug 36981 has been marked as a duplicate of this bug. ***
Comment 5 Noel Power 2011-05-10 08:15:17 UTC
I'd say there is maybe a problem with custom key assignments ( macos specific )

First I'd remove ( or rename ) the existing libreoffice configuration ( just in case there has been some strange corruption there )

e.g. assuming macos configuration is in the same place as linux from a terminal

mv ~/.libreoffice ~/libreoffice-old 

should do the trick,

The try and create new key assignments for the 'Increase' & 'Reduce' Format commands. I would *not* select the 'Libreoffice' radio button when changing the key assignment but just ensure that writer is selected.

putting here which key assignments that don't work might be useful too.

( adding thorsten cc on this bug too )
Comment 6 Rainer Bielefeld Retired 2011-10-18 10:54:11 UTC
This one might be related to "Bug 40578 - CONFIGURATION: Tools-Customize-Keyboard changes should be persistent".
Comment 7 Stefan Knorr (astron) 2012-02-06 03:50:07 UTC
Changing title to better reflect the bug's nature.

Also:
Using Linux and 3.4.5, I can't confirm what you describe in comment 3.
The shortcuts I used were Ctrl-Shift-F1 and Ctrl-Shift-F2 (and they work both globally and for Writer only).
So, I guess, Noel is right about this being a Mac-specific bug.

Any Mac users to test this?
Comment 8 Thorsten Behrens (CIB) 2012-02-13 14:02:01 UTC
Yes. Just played with a 3.5.0 RC3 - went to Tools->Customize, selected Toolbar. Enabled Increase/Decrease Fontsize for Formatting toolbar. Went to "keyboard" tab, assigned shift-command-F7 to increase. Works here, closing the bug. Please reopen if the problem persists with 3.5.0
Comment 9 Roman Eisele 2012-05-04 03:42:44 UTC
This is a Writer issue, therefore changed the 'Component' field appropriately.