Bug 36981 - assigning keyboard shortcuts doesn't work
Summary: assigning keyboard shortcuts doesn't work
Status: RESOLVED DUPLICATE of bug 36975
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.2 RC2
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-08 13:49 UTC by sh
Modified: 2011-05-10 08:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screen shot of Customize Keyboard popup window (128.78 KB, image/tiff)
2011-05-08 13:49 UTC, sh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sh 2011-05-08 13:49:12 UTC
Created attachment 46454 [details]
screen shot of Customize Keyboard popup window

I rely heavily on keyboard shortcuts and have been unable to make any custom assignments work. I believe I'm following documentation instructions, but keying the shortcut simply does nothing. Contrary to instructions, clicking Load... or Save... opens to a list of folders and files and does not act upon the key sequence at all. Even some of the preset keyboard functions do nothing or do something other than what is preset. 

There are also some confusing Function terms in the keyboard shortcuts window. Trying to assign Command-Shift-C or Command-Option-C for example, to align center some selected text, I select the Category>Format, but in the Function list of Format there are 5 "center this selection" possibilities (Center, Center, Centered, Centered, Centered--see attached image). Absolutely no way to tell which actually means "center this selection". For the record, I've tried every single one, and the keyboard command does not work, period.

This is a make it/break it issue for me, as having to move back and forth from keyboard to menus/mouse cuts speed and productivity in half, at least. Solving it is really important.

Thanks for all the great work you do on LO!
Comment 1 Noel Power 2011-05-09 12:42:00 UTC
(In reply to comment #0)
> Created an attachment (id=46454) [details]
> screen shot of Customize Keyboard popup window
> 
> I rely heavily on keyboard shortcuts and have been unable to make any custom
> assignments work. I believe I'm following documentation instructions, but
> keying the shortcut simply does nothing. Contrary to instructions, clicking
> Load... or Save... opens to a list of folders and files and does not act upon
> the key sequence at all.
you don't need to use 'Load' or 'Save' at all if you wish to save custom assignments for the application. The 'Load' & 'Save' buttons are for loading/saving custome assignments to/from files ( or even documents )

> Even some of the preset keyboard functions do nothing
> or do something other than what is preset. 
you would have to be more precise then that e.g. cntl+shift+something should do A but does B ( or nothing or whatever ) but please open a separate bug for that. 
> 
> There are also some confusing Function terms in the keyboard shortcuts window.
> Trying to assign Command-Shift-C or Command-Option-C for example, to align
> center some selected text, I select the Category>Format, but in the Function
> list of Format there are 5 "center this selection" possibilities (Center,
> Center, Centered, Centered, Centered--see attached image). Absolutely no way to
> tell which actually means "center this selection".
Not sure what you mean by "center this selection" but yeah, would agree that it it's completely confusing and probably worth a separate bug.
> For the record, I've tried
> every single one, and the keyboard command does not work, period.\
Well I know the first 'Centered' is the justification one, the shortcut ( on linux ) works for me. 

->thorsten, any chance you could check this ( might be mac specific )
Comment 2 sh 2011-05-09 13:26:14 UTC
Thanks for responding so quickly.


> > I rely heavily on keyboard shortcuts and have been unable to make any custom
> > assignments work. I believe I'm following documentation instructions, but
> > keying the shortcut simply does nothing. Contrary to instructions, clicking
> > Load... or Save... opens to a list of folders and files and does not act upon
> > the key sequence at all.
> you don't need to use 'Load' or 'Save' at all if you wish to save custom
> assignments for the application. The 'Load' & 'Save' buttons are for
> loading/saving custome assignments to/from files ( or even documents )

OK. Glad I can forget Load and Save altogether.  I have assigned keyboard shortcuts for Increase Font (Command +) and Decrease Font (Command -) for LibO and for Writer. Closing and reopening the Tools>Customize>Keyboard window confirms that both shortcuts are now in the Shortcut Keys list. But, neither shortcut works (i.e., when I select some text in the current doc and use the new keyboard command, nothing happens except the 'clunk' sound that tells me no-go).

In my perfect world it would be possible to just key any desired sequence and assign it to a function, rather than having to choose from the shortcut keys list, which doesn't include, for example, the sequence for Increase/Decrease that are my system-wide sequences--Command ] and Command [.

> > There are also some confusing Function terms in the keyboard shortcuts window.
> > Trying to assign Command-Shift-C or Command-Option-C for example, to align
> > center some selected text, I select the Category>Format, but in the Function
> > list of Format there are 5 "center this selection" possibilities (Center,
> > Center, Centered, Centered, Centered--see attached image). Absolutely no way to
> > tell which actually means "center this selection".
> Not sure what you mean by "center this selection" but yeah, would agree that it
> it's completely confusing and probably worth a separate bug.
> > For the record, I've tried
> > every single one, and the keyboard command does not work, period.\
> Well I know the first 'Centered' is the justification one, the shortcut ( on
> linux ) works for me. 

Thanks. Justification was what I was after, and changing the command to that first 'centered' DOES work. First time I've succeeded with a custom shortcut. Yay! 

It wouldn't be a bad idea to fix that list of 5 possible center/centered functions (orig screen shot). There is absolutely no way to tell what each of the five does. 

Thanks in advance for your help with the still-nonfunctioning Increase/Decrease.
Comment 3 sh 2011-05-09 13:29:54 UTC
Forgot to add that I tried setting Increase or Decrease to a different custom key sequence, and that doesn't work, either.
Comment 4 Noel Power 2011-05-10 08:08:59 UTC
(In reply to comment #3)
> Forgot to add that I tried setting Increase or Decrease to a different custom
> key sequence, and that doesn't work, either.

aren't we mixing up stuff from bug #36975 here. I think it makes sense to close one ( this one ) and make it a duplicate of 36975 where it appears that maybe these keycombination perhaps don't work for macos

*** This bug has been marked as a duplicate of bug 36975 ***