Bug Hunting Session
Bug 34023 - FILEOPEN: Particular WORD (97?) document can not be opened
Summary: FILEOPEN: Particular WORD (97?) document can not be opened
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-08 02:07 UTC by dave whitman
Modified: 2011-07-12 11:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
a word97/2000 doc saved in OO 3.2 (21.50 KB, application/msword)
2011-02-08 02:07 UTC, dave whitman
Details
Test Word97 .dot file (549.50 KB, application/msword)
2011-02-28 12:38 UTC, NoOp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dave whitman 2011-02-08 02:07:59 UTC
Created attachment 43088 [details]
a word97/2000 doc saved in OO 3.2

Could not open an old word95 file, I got an error message that this was not a word97/2000 file. I was able to open it in OpenOffice 3.2, where I saved it in Word97/2000 format. I was still unable to open this file.
I have attached the file. The contents is in Russian.
Comment 1 Rainer Bielefeld Retired 2011-02-08 08:27:11 UTC
[Reproducible] with "LibreOffice 3.3.0 RC4 - WIN7  Home Premium (64bit) English UI  [OOO330m19 (build 6 / tag 3.3.0.4)]"

I can't open sample document (Word.Document.8) neither from OOo file dialog nor from WIN Explorer. 

Additional ugly effect: lockfile remains after unsuccessful attempt with LibO

WORD VIEWER and OOo 1.4.1 open the document without problems.

Cédric, can you help?
Comment 2 NoOp 2011-02-28 12:38:17 UTC
Created attachment 43940 [details]
Test Word97 .dot file
Comment 3 NoOp 2011-02-28 12:39:05 UTC
Tested a Word97 .dot file (attached) provided by a user on the user mailing list (E_Base.dot) with the following results:
o Word97/2003 Word - opens fine
o OOo 3.3.0 (Windows 2000/XP/7) - opens fine
o OOo 3.3.0 (linux - standard version from openoffice.org) - opens fine
o (U)OOo 3.2.1 (linux - Ubuntu/go-oo version) - fails & crashes
o LO 3.3.1 (linux - from libreoffice.org) - fails "Read-Error. This is
not a WinWord97 file."
o LO 3.3.1 (Windows XP/7) - fails "Read-Error. This is not a WinWord97 file.
Comment 4 Rainer Bielefeld Retired 2011-04-17 22:10:50 UTC
Same roots like "Bug 36315 - FILEOPEN impossible for docs with code highlight"?
Comment 5 Caolán McNamara 2011-07-02 13:35:47 UTC
fixed this as a pure, "don't have .doc importer code with"
writer/1e232c44978e7dc4d134195a411f834610faa67d
for attachment 1
Comment 6 Caolán McNamara 2011-07-02 13:42:15 UTC
I'm not sure, why attachment #2 is shoved in here as well
Comment 7 Caolán McNamara 2011-07-02 14:02:32 UTC
fixed attachment 2 as a pure, "don't crash .doc importer code with"
filters/1891704c091105bfbcd1db522fa1be60811e260f

caolanm->noelp: Might want to look over those changes, they're vba/ww8toolbar related
Comment 8 Noel Power 2011-07-12 11:25:03 UTC
(In reply to comment #5)
> fixed this as a pure, "don't have .doc importer code with"
> writer/1e232c44978e7dc4d134195a411f834610faa67d
> for attachment 1 [details]

not sure why that changes is necessary at all, doesn't it mean we've read past the of the stream ? ( and the nId isn't overwritten and it's value remains what it was intialised with ) which happens to be an exit condition. Seems there must before something worse going on here.

hmm after looking abit more it seems that this document appears to be corrupt ( at least my ms2000 & ms2003 won't read it ) So, if that is the case I'd nearly prefer to leave things the way they were and fail hard rather than hide the problem ( looks like there is most likely an export problem here )
Otoh hanging is not good either, maybe I could look to see if we can detect the end of stream earlier and fail out
Comment 9 Noel Power 2011-07-12 11:26:20 UTC
(In reply to comment #7)
> fixed attachment 2 [details] as a pure, "don't crash .doc importer code with"
> filters/1891704c091105bfbcd1db522fa1be60811e260f
> 
> caolanm->noelp: Might want to look over those changes, they're vba/ww8toolbar
> related

you mean http://cgit.freedesktop.org/libreoffice/filters/commit/?id=d6a98cf1a5fafb0e96bdd224846952dbc499987e I guess

oops, my ( *very* ) bad, thanks for the fix