Download it now!
Bug 36315 - FILEOPEN impossible for particular .doc documents created with WPS office software
Summary: FILEOPEN impossible for particular .doc documents created with WPS office sof...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) All
: low enhancement
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-16 21:07 UTC by lijilin
Modified: 2013-11-24 19:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
the test file (24.00 KB, application/msword)
2011-04-16 21:07 UTC, lijilin
Details
Word97 test file created in MS Word 97 SR-1 (19.00 KB, application/msword)
2011-04-18 15:17 UTC, NoOp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lijilin 2011-04-16 21:07:50 UTC
Created attachment 45722 [details]
the test file

please see the below file
Comment 1 Rainer Bielefeld Retired 2011-04-17 21:13:53 UTC
Effect is [Reproducible] with "LibreOffice 3.3.2  – WIN7  Home Premium  (64bit) German UI [OOO330m19 (Build:202 / tag 3.3.2.2)]", I can't open the sample document. Same with OOo-dev 3.4. 

"Ooo 3.3.0  – WIN7  Home Premium  (64bit) German UI [OOO330m20 (build 9567)]" opens the document without problems, same with MS OWRD VIEWER.

My suspect: It isn't a valid WORD97 document, i'm used to find "Word.Document.8" at the end of the document, what is missing in the sample document.
On the other hand, WIN Explorer recognizes the document as 
"Microsoft WORD97-2003"

@lijilin:
How has the document been created?
Please explain "docs with code highlight"!
What OS did you test?
Comment 2 Rainer Bielefeld Retired 2011-04-17 22:10:09 UTC
May be this one has the same roots like 
Bug 34023 - FILEOPEN: Particular WORD (97?) document can not be opened
One similar effect is the remaining lock file.
An other common ground is the strange document identifier 
"W o r d D o c u m e n t"

A difference is that sample document here contains identifier "Word.Document.8"

@lijilin:
How has the sample document been created?

@Cédric:
Can you please check?
Comment 3 Kohei Yoshida 2011-04-18 12:19:43 UTC
If I open the document in Word XP, and re-save it, Writer can open it just fine.

@lijilin: What application created this document?  Was the document created by Microsoft Word, or some 3rt party application?
Comment 4 NoOp 2011-04-18 15:15:33 UTC
The file appears to have been created in MS Works and saved as a .doc file. I see "Normal.wpt" in the document properties using MS Word 97. 

- MS Word 97 
    opens the file
- OpenOffice.org 3.2.1 
OOO320m19 (Build:9505)
ooo-build 3.2.1.4, Ubuntu package 1:3.2.1-7ubuntu1.1
    opens the file
- OpenOffice.org 3.2.0 (linux)
    does not open the file & gives error "Read-Error. This is
not a WinWord97 file."
- LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2
    does not open the file & give error "Read-Error. This is
not a WinWord97 file."

$ file test.doc
test.doc: CDF V2 Document, corrupt: Can't expand summary_info

Whereas a Word 97 document gives:
$ file Word97Test.doc
Word97Test.doc: CDF V2 Document, Little Endian, Os: Windows, Version 5.0, Code page: 1252, Title: This is a test document created in Microsoft Word 97 SR-1, Author: gg, Template: Normal.dot, Last Saved By: gg, Revision Number: 1, Name of Creating Application: Microsoft Word 8.0, Total Editing Time: 02:00, Create Time/Date: Sun Apr 17 21:33:00 2011, Last Saved Time/Date: Sun Apr 17 21:35:00 2011, Number of Pages: 1, Number of Words: 8, Number of Characters: 50, Security: 0

Attaching a Word 97 test file for comparison:
Word97Test.doc
Comment 5 NoOp 2011-04-18 15:17:10 UTC
Created attachment 45784 [details]
Word97 test file created in MS Word 97 SR-1
Comment 6 NoOp 2011-04-18 15:29:39 UTC
Both KWord (ver 2.2.2) and Abiword (ver 2.8.6) also open test.doc. And a correction:

- OpenOffice.org 3.2.0 (linux)
    does not open the file & gives error "Read-Error. This is

Should read:

- OpenOffice.org 3.3.0 (linux)
    does not open the file & gives error "Read-Error. This is

This appears to be a regression between 3.2 and 3.3 as 
- OpenOffice.org 3.2.1 
OOO320m19 (Build:9505)
ooo-build 3.2.1.4, Ubuntu package 1:3.2.1-7ubuntu1.1
is built using the former go-oo (now LibreOffice) packages and it does open the file.
Comment 7 Kohei Yoshida 2011-04-18 19:18:39 UTC
Thanks for the analysis.

With that, I'll hand this off to Cedric.
Comment 8 lijilin 2011-04-19 19:48:47 UTC
(In reply to comment #1)
> Effect is [Reproducible] with "LibreOffice 3.3.2  – WIN7  Home Premium  (64bit)
> German UI [OOO330m19 (Build:202 / tag 3.3.2.2)]", I can't open the sample
> document. Same with OOo-dev 3.4. 
> 
> "Ooo 3.3.0  – WIN7  Home Premium  (64bit) German UI [OOO330m20 (build 9567)]"
> opens the document without problems, same with MS OWRD VIEWER.
> 
> My suspect: It isn't a valid WORD97 document, i'm used to find
> "Word.Document.8" at the end of the document, what is missing in the sample
> document.
> On the other hand, WIN Explorer recognizes the document as 
> "Microsoft WORD97-2003"
> 
> @lijilin:
> How has the document been created?
> Please explain "docs with code highlight"!
> What OS did you test?



my  os  are  win7 Ultimate (32bit)   and  ubuntu 10.10 (32bit),both them can't open it.
Comment 9 lijilin 2011-04-19 19:51:36 UTC
(In reply to comment #1)
> Effect is [Reproducible] with "LibreOffice 3.3.2  – WIN7  Home Premium  (64bit)
> German UI [OOO330m19 (Build:202 / tag 3.3.2.2)]", I can't open the sample
> document. Same with OOo-dev 3.4. 
> 
> "Ooo 3.3.0  – WIN7  Home Premium  (64bit) German UI [OOO330m20 (build 9567)]"
> opens the document without problems, same with MS OWRD VIEWER.
> 
> My suspect: It isn't a valid WORD97 document, i'm used to find
> "Word.Document.8" at the end of the document, what is missing in the sample
> document.
> On the other hand, WIN Explorer recognizes the document as 
> "Microsoft WORD97-2003"
> 
> @lijilin:
> How has the document been created?
> Please explain "docs with code highlight"!
> What OS did you test?



my  os  are  win7 Ultimate (32bit)   and  ubuntu 10.10 (32bit),both them can't open it.
Comment 10 lijilin 2011-04-19 19:53:39 UTC
the  test file only  own  "public stastic   void  main()"
Comment 11 lijilin 2011-04-19 19:55:58 UTC
(In reply to comment #1)
> Effect is [Reproducible] with "LibreOffice 3.3.2  – WIN7  Home Premium  (64bit)
> German UI [OOO330m19 (Build:202 / tag 3.3.2.2)]", I can't open the sample
> document. Same with OOo-dev 3.4. 
> 
> "Ooo 3.3.0  – WIN7  Home Premium  (64bit) German UI [OOO330m20 (build 9567)]"
> opens the document without problems, same with MS OWRD VIEWER.
> 
> My suspect: It isn't a valid WORD97 document, i'm used to find
> "Word.Document.8" at the end of the document, what is missing in the sample
> document.
> On the other hand, WIN Explorer recognizes the document as 
> "Microsoft WORD97-2003"
> 
> @lijilin:
> How has the document been created?
> Please explain "docs with code highlight"!
> What OS did you test?

 you can open it by windows office 2010
Comment 12 lijilin 2011-04-21 06:32:16 UTC
  Sorry,I had a mistake.The file was created by WPS(a popular office software in China),and copy some java code from Eclipse,then save it in doc format.
  It's so strange that it can be opened by MS Office,and only when all the colored(syntax highlight) texts are deleted,it could be opened by LibreOffice.
Comment 13 Rainer Bielefeld Retired 2011-04-27 21:27:08 UTC
Currently the main problem seems to be that WPS creates improper WORD documents. Because OOo and viewer can open those documents there might be some interest to be able to do that with LibO, too?
Comment 14 lijilin 2011-05-30 06:39:22 UTC
It is fixed in 3.4RC2,thanx
Comment 15 Rainer Bielefeld Retired 2011-05-30 08:47:03 UTC
Due to
<https://bugs.freedesktop.org/page.cgi?id=fields.html#status>
we should used FIXED only if a known fix has solved the problem; if the problem only disappeared without known reason, please use WORKSFORME.