Download it now!
Bug 34045 - LibreOffice 3.3 runtime error during installation and startup failure with fatal error
Summary: LibreOffice 3.3 runtime error during installation and startup failure with fa...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: x86 (IA32) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-08 09:03 UTC by alexsupra
Modified: 2012-08-21 22:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
windows with error (27.86 KB, image/png)
2011-02-08 09:03 UTC, alexsupra
Details
windows with error during startup (67.72 KB, image/png)
2011-02-08 09:03 UTC, alexsupra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alexsupra 2011-02-08 09:03:01 UTC
Created attachment 43117 [details]
windows with error

Hi. I got 2 errors on several machines in the latest stable build of LibreOffice 3.3:

    * runtime error during (at the end of) installation process, but installation seems to be finished;
    * startup failure with fatal error, when starting any of the package applications.

Operating system: Windows XP Professional Build 2600 Service Pack 3 32-bit

I tried before posting here:

    * removing of all previous program installations;
    * removing program profile at %appdata%;

and it didnt help at all.

Thus it is very interesting to know what I should try to do to make this software work?
Comment 1 alexsupra 2011-02-08 09:03:50 UTC
Created attachment 43118 [details]
windows with error during startup
Comment 2 alexsupra 2011-02-08 09:04:25 UTC
I catched some additional information about installation process with using of Anvir utility.

01/30 16:06:16    LibO_3.3.0_Win_x86_install_multi.exe 1152 started by 780 SUPRA\admin    C:\public\27-01-2011\LibO_3.3.0_Win_x86_install_multi.exe /S   
01/30 16:06:50    setup.exe 952 started by LibO_3.3.0_Win_x86_install_multi.exe SUPRA\admin    C:\docs\admin\temp\LibreOffice 3.3 (4d36e9e0) Installation Files\setup.exe -lang 1049     /qr -ignore_running   
01/30 16:06:50    vcredist_x86.exe 1972 started by setup.exe SUPRA\admin    C:\docs\admin\temp\LibreOffice 3.3 (4d36e9e0) Installation Files\redist\vcredist_x86.exe /QB   
01/30 16:06:50    install.exe 2084 started by vcredist_x86.exe SUPRA\admin    e:\3ef5071dfa8e5ecb3af8ebea318c37\install.exe /QB   
01/30 16:06:52    msiexec.exe 176 started by msiexec.exe SUPRA\admin    C:\WINNT\system32\msiexec.exe -Embedding 9F5C63B631331771BF73A1C48E820EA4   
01/30 16:06:54    msiexec.exe 176 terminated, CPU 0:00     C:\WINNT\system32\msiexec.exe   
01/30 16:06:56    vcredist_x86.exe 1972 terminated, worked 0:04, CPU 0:00     C:\docs\admin\temp\LibreOffice 3.3 (4d36e9e0) Installation Files\redist\vcredist_x86.exe   
01/30 16:06:56    install.exe 2084 terminated, worked 0:04, CPU 0:00     e:\3ef5071dfa8e5ecb3af8ebea318c37\install.exe   
01/30 16:06:56    msiexec.exe 2412 started by setup.exe SUPRA\admin    C:\WINNT\system32\msiexec.exe SETUP_USED=1 /I "C:\docs\admin\temp\LibreOffice 3.3 (4d36e9e0) Installation Files\libreoffice33.msi" TRANSFORMS="C:\docs\admin\temp\LibreOffice 3.3 (4d36e9e0) Installation Files\trans_ru.mst" /qr    
01/30 16:06:56    msiexec.exe 2452 started by msiexec.exe SUPRA\admin    C:\WINNT\system32\msiexec.exe -Embedding F31D94C242C95A855EB199DEE9469624 C   
01/30 16:06:56    msiexec.exe 3636 started by msiexec.exe SUPRA\admin    C:\WINNT\system32\msiexec.exe -Embedding 1BC7B738A5D7FC5F817DB6ADDBC04D03
01/30 16:09:20    unopkg.exe 1220 started by msiexec.exe SUPRA\admin    C:\programs\LibreOffice 3\program\unopkg.exe sync -env:BUNDLED_EXTENSIONS_USER=$BRAND_BASE_DIR/share/prereg/bundled -env:UNO_JAVA_JFW_INSTALL_DATA=$OOO_BASE_DIR/share/config/javasettingsunopkginstall.xml -env:UserInstallation=file:///C:/docs/admin/temp/upg9E.tmp   
01/30 16:09:20    unopkg.bin 1880 started by unopkg.exe SUPRA\admin    C:\programs\LibreOffice 3\program\unopkg.bin sync -env:BUNDLED_EXTENSIONS_USER=$BRAND_BASE_DIR/share/prereg/bundled -env:UNO_JAVA_JFW_INSTALL_DATA=$OOO_BASE_DIR/share/config/javasettingsunopkginstall.xml -env:UserInstallation=file:///C:/docs/admin/temp/upg9E.tmp "-env:INIFILENAME=vnd.sun.star.pathname:C:\programs\LibreOffice 3\program\redirect.ini" "-env:OOO_CWD=2C:\\WINNT\\system32"
Comment 3 Don't use this account, use tml@iki.fi 2011-02-08 09:17:06 UTC
Try without any anti-virus or other "useful" 3rd-party background software running?
Comment 4 alexsupra 2011-02-08 11:05:44 UTC
(In reply to comment #3)
> Try without any anti-virus or other "useful" 3rd-party background software
> running?

Thank you for your recommendation, its rather common. There is no so called anti-virus software, if you mean Anvir - it was never the reason of such problems during all the years of testing software but i allready tried without this useful program started without any success.

By the way there is information from various forums about OpenOffice and LibreOffice that possible reason is incorrect installation of Microsoft Visual C++ 2008 libs which is bundled inside OpenOffice distribution. Maybe in some cases it is fully functional but not in all of them. I remember some problems with OpenOffice and MS VC++ libs in previous OOo versions but they where not so fatal as the last ones. It seems to me that rather important difference is bundled MS VC++ 2008 package that is being installed not properly or smth like that.
Comment 5 Rainer Bielefeld Retired 2011-02-08 21:41:30 UTC
Related to or DUP of 
Bug 31764 - Unopkg add failed with pyUno code
?
Comment 6 alexsupra 2011-02-24 02:19:52 UTC
The same error occured in LibreOffice 3.3.1.

I noticed one interesting thing that OpenOffice 3.3.0 and LibreOffice 3.3.0 and 3.3.1 have different bundled versions of MS VC++ 2008. 
For 32-bit OS versions they are:
vcredist_x86_9.0.21022.8
vcredist_x86_9.0.30729.17
vcredist_x86_9.0.30729.4148
Comment 7 Rainer Bielefeld Retired 2011-11-11 08:51:23 UTC
@alexsupra:
Still a problem for you?
Comment 8 alexsupra 2011-11-11 17:34:25 UTC
(In reply to comment #7)
> @alexsupra:
> Still a problem for you?

The problem was found in conflict of custom system configuration settings with LibreOffice. The reason was system enviroment variable %data% (containing file system path). Removing of variable "data" is the solution.

Thanks.
Comment 9 Rainer Bielefeld Retired 2011-11-11 22:34:21 UTC
Closing due to comment 8
Comment 10 Robert Di Giorgio 2012-08-21 22:31:33 UTC
Error messages:
1. "FATAL ERROR  Unhandled exception  
file:///C:/----/Application%20Data/LibreOfice/3/user/extensions/bundled/registry.com.sun.star.comp.deployment.bundle.PackageRegistryBackend"

2."Runtime Error!
Program: C:\program files\LibreOffice 3.6\program\office.bin
This application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information."

OS: Windows XP SR3

This was my 3rd attempt to install it. The 1st 2 times it locked up the computer entirely, required power off to clear it. Those 2 might have been compromised by LO 3.4 which had failed to start earlier, and may have been hung up even though I thought it was off. 

For this last attempt, I had deleted LO3.4 and all previous downloads of 4.11 and was trying a brand new download of 4.11. Installation was set at Regular. Downloaded 8/21/2012

bobdi2@cox.net