Bug 34170 - LibreOffice.org Load/Save dialogue boxes delete files but dont use Trash
Summary: LibreOffice.org Load/Save dialogue boxes delete files but dont use Trash
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All Linux (All)
: medium enhancement
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-11 02:02 UTC by Tony Pursell
Modified: 2015-01-14 23:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen shot of generic file dialog from 4.2 (106.80 KB, image/jpeg)
2015-01-13 00:01 UTC, crxssi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Pursell 2011-02-11 02:02:41 UTC
If, in Tools > Options..., you have 'Use LibreOffice dialogue boxes' checked, you get dialogue boxes that allow you to right click and Delete. Files deleted like this do not go to the Deleted Items folder. This is dangerous because users can assume the behaviour is the same as in Nautilus.

This may apply to other Operating Systems. E.g not moving deleted files to Recycle Bin in Windows.

[This bug was originally reported against OpenOffice.org for Ubuntu. See https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/525440 where I have been asked to post this bug against LibreOffice]
Comment 1 Björn Michaelsen 2011-12-23 11:44:42 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Tony Pursell 2011-12-23 14:53:01 UTC
This affects LibreOffice 3.4.4. 

Although I think a warning box has been added it is not made absolutely clear that this is a permanent deletion (as you get in Nautilus when you use Shift-Delete).  

Will test 3.5 when it is available in Ubuntu, or if 3.5 can be installed alongside current stable version.
Comment 3 Tony Pursell 2011-12-29 14:17:05 UTC
I have installed LOdev3.5.0beta2 and have found that it is the same as I reported above for 3.4.4.

Deletion is permanent and Trash is not used.  There is no warning of permanent deletion.
Comment 4 Samuel Mehrbrodt (CIB) 2013-12-02 07:58:00 UTC
I think the easiest way is to just disable deleting.
The native Gnome dialog also doesn't allow you to delete in the Open dialog.
Comment 5 Caolán McNamara 2013-12-02 10:57:17 UTC
There is some use of the fileview thing in dbaccess as well for some non-fileopen dialog purpose. Maybe there we need to explicitly enable the possibility to delete as there presumably isn't any other way to do it.
Comment 6 Caolán McNamara 2013-12-02 11:03:23 UTC
added that bit myself now
Comment 7 Commit Notification 2013-12-02 11:03:35 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4f743082c10c735db0e92fbe2921e95c5bd02c4a

fdo#34170 Disable deleting in the native Open Dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 crxssi 2015-01-12 22:05:52 UTC
Just discovered this change today when I could no longer delete files.

I think this was mistake to remove the delete option from the generic file manager.  If you were to use KDE's file manager dialog, you would have the option to delete or at least trash files.  Those of us who use the generic file manager now have NO option to delete files, other than to use the command line (which also doesn't "trash" files) or a open a separate file manager.

Other historic Linux office automation products (for example Linux WordPerfect) have had delete options in the open dialog for many, many years.  People who use the generic file manager are probably those that are more savvy, anyway (most people will have the Gnome or KDE dialog).  If people here were so concerned that deleting really meant "delete" and that users can't understand that delete really means delete, then:

1) It could have been reworded to be "Permanently Delete File"
2) and/or have a warning on deleting action
3) and/or have an option in tools->options to disable delete

This greatly inconveniences me and a lot of my users.  :(
Comment 9 Tony Pursell 2015-01-12 23:34:51 UTC
I have Version: 4.2.7.2 (using Ubuntu 4.04LTS) and there is still a delete option on right click but it now has a 'Confirm Delete' dialogue, which would seem to be sufficient to stop accidental deletion.  The same happens if you press the Delete key.

I would prefer it to behave like Nautilus (now called Files) for consistency sake, but I am not going to object to what has been done.
Comment 10 crxssi 2015-01-13 00:00:02 UTC
(In reply to Tony Pursell from comment #9)
> I have Version: 4.2.7.2 (using Ubuntu 4.04LTS) and there is still a delete
> option on right click but it now has a 'Confirm Delete' dialogue, which
> would seem to be sufficient to stop accidental deletion.  The same happens
> if you press the Delete key.

They didn't remove the "delete" function until 4.3 and this is only for those people using the "generic" file dialog (you typically won't see the generic file dialog if you are using KDE or Gnome).

I am attaching a picture of what the generic dialog looks like in 4.2- you can delete files by pressing <Delete> or by right clicking.

> I would prefer it to behave like Nautilus (now called Files) for consistency
> sake, but I am not going to object to what has been done

You are not objecting probably because you still have the option to remove a file in some way, which people using the newly "improved" generic file dialog cannot.  I don't think you are even using the generic one and thus this doesn't even affect you.  But it does affect me at work, and all my users, who will now be forced to open a separate file manager PROGRAM (such as Thunar) just to delete a file.
Comment 11 crxssi 2015-01-13 00:01:49 UTC
Created attachment 112148 [details]
Screen shot of generic file dialog from 4.2
Comment 12 Tony Pursell 2015-01-14 11:24:48 UTC
Hi crxssi@hotmail.com

Are you saying that you get LO's Open/Save dialogues even when the option in Tools > Options > LibreOffice > General is not ticked (which is the default setting)?

I only have experience of Ubuntu Linux and Windows where I always use the system dialogues.

When I came to try OpenOffice.org's Open/Save dialogues back in 2010 they were much more rudimentary and, as far as I can remember, allowed *immediate* deletion of a file on right click.  I considered this highly dangerous as the normal file deletion routines put a deleted file into Trash/Rubbish Bin/Recycle Bin and I could see users unwittingly deleting files with no way of recovering them, to the detriment of OpenOffice.org's (and now LO's) reputation.

Now that there is a 'Confirm Delete' dialogue, I would agree with you that the Delete on right click should have been retained, although I would like the default action in the 'Confirm Delete' dialogue to be 'Dont Delete'.
Comment 13 crxssi 2015-01-14 23:59:30 UTC
(In reply to Tony Pursell from comment #12)

> Are you saying that you get LO's Open/Save dialogues even when the option in
> Tools > Options > LibreOffice > General is not ticked (which is the default
> setting)?

Not sure what option you are referring to.  Tools-> Options-> LO-> General is a menu, not an option.  And under that there is nothing related to the open/save dialog.  There is nothing under Tools-> Options-> Load/Save either.  (Vanilla Linux LO 4.3 without KDE/Gnome integration loaded)

> I only have experience of Ubuntu Linux and Windows where I always use the
> system dialogues.

Exactly.  That is what 99+% of users will see- KDE or Gnome dialogs.  This bug report is about the generic file manager that is built into LO for when KDE or Gnome (or compatible) is not being used.  WE are a thin client environment and use IceWM.

> When I came to try OpenOffice.org's Open/Save dialogues back in 2010 they
> were much more rudimentary and, as far as I can remember, allowed
> *immediate* deletion of a file on right click.

Yes, that is the generic one this bug references and what we at work are still using (by choice)

> I considered this highly dangerous as the normal file deletion routines put
> a deleted file into Trash/Rubbish Bin/Recycle Bin and I could see users
> unwittingly deleting
> files with no way of recovering them, to the detriment of OpenOffice.org's
> (and now LO's) reputation.

There are lots of Linux programs for which delete means delete (including the command line), although they are not as common as in the past.  This is not crazy behavior.  File managers that support a trash concept should label that function "trash" or "recycle" or something... not "delete" (but that is a whole other conversation).

I agree that new or novice users might not understand that delete means delete, which is why I proposed instead of completely removing a very useful feature, to rename it to sound more dangerous, like "Permanently Delete" or to add a warning, or to add an OPTION to turn it off (and perhaps even make the default for that option be off).  Of course most of these novice users will never see or use the built-in file dialog, anyway)
 
> Now that there is a 'Confirm Delete' dialogue,

Perhaps on the KDE or Gnome or other dialog that was added, but it wasn't added on the generic/built-in LO dialog.  Had they done that instead of completely removing delete, I would have been far less upset.

> I would agree with you that
> the Delete on right click should have been retained, although I would like
> the default action in the 'Confirm Delete' dialogue to be 'Dont Delete'.

I could even go for that too.  Anything is better than just removing it completely.