Download it now!
Bug 82324 - Can no longer delete file from inside LO file manager
Summary: Can no longer delete file from inside LO file manager
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-08 04:28 UTC by Jerry
Modified: 2015-01-12 22:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jerry 2014-08-08 04:28:54 UTC
Can no longer delete files from "Open File" dialog. 

Upgraded LO from version 4.2.0.4 to version 4.3.0.4. I do not know when in the intermediate versions of LO this functionality was lost. The Windows 7 operating system file dialog is much less convenient to use. For example it is not possible to simply move up a directory level in the system file directory as you can in the LO file manager.

Same bug is present throughout all modules of LO

Please return this functionality to LO!
Comment 1 Joel Madero 2014-08-08 04:45:36 UTC
Please provide reproducible steps - that are clear, simple and describes what is expected vs. what is observed.

marking as NEEDIFNO - once you provide simple steps, mark as UNCONFIRMED.

Updating title as "Very inconvenient" is entirely useless in the title
Comment 2 Jerry 2014-08-08 12:45:53 UTC
Previous version of LO (4.2.0.3) allowed the following steps:

1. Select "Open File"
2. Select file name with left click of mouse
3. Right click of mouse brought up 2 options: Delete and Rename
4. Select "Delete", file is deleted.

Multiple files could be selected at step 2 by using Ctrl key.
 
This was very convenient to clean up directory especially when having saved multiple versions of file as editing progressed.

Current version of LO (4.3.0.4) only brings up "Rename" at step 3.
Comment 3 Jerry 2014-08-09 03:25:58 UTC
To expand on my previous comment:

Previous version should be corrected to 4.2.0.4.

After selecting file(s) in step 2, the delete key could be used to delete files instead of using the mouse as described.  This functionality is also missing from the latest version.
Comment 4 ign_christian 2014-08-09 10:27:01 UTC
"Use LibreOffice dialogs" must be enabled in Options to see this issue.

Reproduced with LO 4.3.1.1 - Ubuntu 12.04 x86
Not reproduced with LO 4.2.6.2

But I don't know whether it's a bug or by design.
Comment 5 Maxim Monastirsky 2014-08-10 07:14:24 UTC
This is an intentional change made in Bug 34170.
Comment 6 crxssi 2015-01-12 22:13:48 UTC
(In reply to Maxim Monastirsky from comment #5)
> This is an intentional change made in Bug 34170.

Indeed it was.... And I just discovered this change today when I could no longer delete files (we are now testing 4.3 for company rollout).

I think this was mistake to remove the delete option from the generic file manager.  If you were to use KDE's file manager dialog, you would have the option to delete or at least trash files.  Those of us who use the generic file manager now have NO option to delete files, other than to use the command line (which also doesn't "trash" files) or a open a separate file manager.

Other historic Linux office automation products (for example Linux WordPerfect) have had delete options in the open dialog for many, many years.  People who use the generic file manager are probably those that are more savvy, anyway (most people will have the Gnome or KDE dialog).  If people here were so concerned that deleting really meant "delete" and that users can't understand that delete really means delete, then:

1) It could have been reworded to be "Permanently Delete File"
2) and/or have a warning on deleting action
3) and/or have an option in tools->options to disable delete

This greatly inconveniences me and a lot of my users.  :(