Download it now!
Bug 34221 - EDITING: Permit setting a footnote anchor prefix/suffix (in the text area)
Summary: EDITING: Permit setting a footnote anchor prefix/suffix (in the text area)
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 68950 (view as bug list)
Depends on:
Blocks: Footnote-Endnote
  Show dependency treegraph
 
Reported: 2011-02-12 21:02 UTC by Fahad Al-Saidi
Modified: 2018-11-21 15:05 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
A small document explains this bug. (97.17 KB, application/vnd.oasis.opendocument.text)
2011-11-08 03:52 UTC, Fahad Al-Saidi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fahad Al-Saidi 2011-02-12 21:02:07 UTC
This is a resubmitting of this bug (1). Here is a descriptions of it:

I'd like to use parentheses, for footnote anchors (in the text area), for better
separation.

For example: Foobar(1), with «(1)» in superscript.


However, although we can add characters, before and after the number, in the
footnote area (in the footnote settings, the «Before»/«After» fields -the fact
it applies only to the footnote area, is not clear enough, by the way), we
cannot add characters to the footnote anchor (in the main content).


It is good to keep the two locations independent, regarding prefixes/suffixes.

For example, in my case, in the footnote area, I use: 1. Lorem ipsum.


There should then be a new set of «Before»/«After» fields, in the footnote
settings, to set a prefix/suffix, for footnote anchors.


A more global solution (I didn't search for an existing report, but I guess it
exists), would be to permit to defined prefixes/suffixes, for any element, like
in CSS (the «:before» and «:after» selectors, with the «content» property).


This is a low priority enhancement, as we can just add the prefix/suffix
manually, which is not too problematic, for footnotes.



Thanks in advance to everyone who will work on this.


(1) http://www.openoffice.org/issues/show_bug.cgi?id=90842
Comment 1 Rainer Bielefeld Retired 2011-11-07 21:57:29 UTC
@Fahad Al-Saidi
Can you please try to add some info so that someone who never used a footnote in his life can understand the problem? Useful would be
- a mockup
- how your workaround works (sample document, every key press / mouse click)
- how you expect a soulution (not "here should then be a new set of 
  «Before»/«After» fields", but "In .... click ... then .... dialog ..." and
  so on
Comment 2 Fahad Al-Saidi 2011-11-08 03:52:47 UTC
Created attachment 53292 [details]
A small document explains this bug.
Comment 3 Fahad Al-Saidi 2011-11-08 03:53:56 UTC
(In reply to comment #1)
> @Fahad Al-Saidi
> Can you please try to add some info so that someone who never used a footnote
> in his life can understand the problem? Useful would be
> - a mockup
> - how your workaround works (sample document, every key press / mouse click)
> - how you expect a soulution (not "here should then be a new set of 
>   «Before»/«After» fields", but "In .... click ... then .... dialog ..." and
>   so on

Please see the attachment.
Comment 4 Björn Michaelsen 2011-12-23 11:43:42 UTC Comment hidden (obsolete)
Comment 5 Björn Michaelsen 2011-12-23 17:01:14 UTC Comment hidden (obsolete)
Comment 6 Florian Reisinger 2012-08-14 13:57:52 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 13:59:11 UTC Comment hidden (obsolete)
Comment 8 Florian Reisinger 2012-08-14 14:03:44 UTC Comment hidden (obsolete)
Comment 9 Florian Reisinger 2012-08-14 14:05:59 UTC Comment hidden (obsolete)
Comment 10 Fahad Al-Saidi 2012-08-14 14:35:15 UTC
This feature is not implemented yet. Please don't close it.
Comment 11 Buovjaga 2015-04-29 16:24:52 UTC
*** Bug 68950 has been marked as a duplicate of this bug. ***
Comment 12 Zayed 2018-11-21 15:04:25 UTC
Still isn't resolved in 6.1.