Bug Hunting Session
Bug 34479 - Sort order for additional Language Packs not alphabetical by Language name
Summary: Sort order for additional Language Packs not alphabetical by Language name
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other Windows (All)
: medium enhancement
Assignee: Andras Timar
URL:
Whiteboard: target:3.7.0
Keywords:
: 41438 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-19 06:30 UTC by Luuk
Modified: 2014-01-02 22:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
AdditionalLanguagePacks (44.25 KB, image/png)
2011-02-19 06:31 UTC, Luuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luuk 2011-02-19 06:30:27 UTC
see attached picture, 

'Dutch' is show in the list at ('N'), but other languages also show at the 'wrong' position.
Comment 1 Luuk 2011-02-19 06:31:31 UTC
Created attachment 43554 [details]
AdditionalLanguagePacks
Comment 2 Rainer Bielefeld Retired 2011-05-31 07:48:27 UTC
I eleted URL without additional information

I can confirm that problem. It becomes even more tedious if you install with a non English OS, but that is an other problem. 

I do not know whether it would be possible to do an alphabetical sort during runtime due to Language names in OS language when unfolding the languages selection. 

If not (or too "expensive"), my preferred solution would be to sort based on the language abbreviations, like
# AR - Arabic
.
.
.
# DE - German
.
# ES - Spanisch
.
# FR - French
.
# HU - Hungarian
Comment 3 Don't use this account, use tml@iki.fi 2011-05-31 08:04:58 UTC
Rainer: well, that *is* the order in which they are sorted already, as far as I know;) So to implement the suggestion in comment #2, just the English strings in the installer UI (and their translations) used for the UI language components need to be changed to include at the beginning the code (not "abbreviation") for the language.
Comment 4 Rainer Bielefeld Retired 2011-05-31 09:20:17 UTC
(In reply to comment #3)
> Rainer: well, that *is* the order

@Tor:
I thought so, too, but I believed that there seemed to be some errors in the order. I will check that as soon as I will have found a listing with the relations between abbreviations and Language names.
My additional Idea is to mention that Abbreviation in the Installation list, because abbreviations I speak about are the names in the Help Packages, what differ from English abbreviations. Example: ES - Spanish. IMHO that would ease finding of the required language, but I can't look into other users'  gyruses.
I will try to find out the real sort order when I will have some boredom.
Comment 5 Luuk 2011-05-31 10:24:12 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Rainer: well, that *is* the order
> 
> @Tor:
> My additional Idea is to mention that Abbreviation in the Installation list,
> because abbreviations I speak about are the names in the Help Packages, what
> differ from English abbreviations. Example: ES - Spanish. IMHO that would ease
> finding of the required language, but I can't look into other users'  gyruses.
> I will try to find out the real sort order when I will have some boredom.

In some country's (like Belgium (if you still want to call that a country ;)) more than 1 language is spoken.

Sorting on the Language ('Dutch', 'German', 'Spanish') is, in my opinion, the best way to do it.

Adding a country-code before the language is more confusing, inless 'B ...' (for Belgium) is in the list 3 times
Comment 6 Don't use this account, use tml@iki.fi 2011-05-31 10:34:47 UTC
Luuk: We are well aware of that. Nobody has suggested using country codes or names here.
Comment 7 Andras Timar 2011-06-07 01:52:13 UTC
We can set the Sortkey values in .scp files according to English alphabetical order of the language names (currently it is according to order of ISO language codes). 

Alternatively, we can sort the .idt tables (e.g. instsetoo_native\wntmsci12.pro\LibreOffice\native\idt_files\en-US\en-US\Feature.idt). This method is harder but better, because we can sort not only for en-US but for all languages.
Comment 8 Andras Timar 2011-06-09 07:32:51 UTC
I started to work on this.
Comment 9 Andras Timar 2011-06-29 03:31:28 UTC
http://cgit.freedesktop.org/libreoffice/bootstrap/commit/?id=5506e56823f11e38053e50c29342cf8469b6a641

As I told in comment 7, I sorted the Feature.idt. Sorting is done by ASCII order. Using locale specific collation order would be too complicated. Plain ASCII order is also good in most of the cases, and it is definitely better than it was before.
Comment 10 Andras Timar 2011-11-15 01:49:35 UTC
*** Bug 41438 has been marked as a duplicate of this bug. ***
Comment 11 ungifted 2012-02-15 06:35:35 UTC
I use Russian LibreOffice.
In 3.5.0 installer have broken sort order for both: interface languages and dictionaries.
Comment 12 Not Assigned 2012-09-27 16:30:44 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=08fef531b59412bd6a1ae4cf986c102994711127

Revert "sorting additional language packs and dictionaries fdo#34479"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Michael Bauer 2014-01-02 22:38:40 UTC
This bug seems to have reared its ugly head again. I just ran the installer for the latest version and Bengali is followed by Tibetan and Greek sits above English in the English installer. Someone must have reactivated sort order according to ASCII
Comment 14 Andras Timar 2014-01-02 22:57:31 UTC
Let's keep this old bug fixed. I fixed its new incarnation, bug 72945 two weeks ago.