Bug Hunting Session
Bug 34520 - Repair does not work from direct WIN7 selection
Summary: Repair does not work from direct WIN7 selection
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-21 01:22 UTC by Rainer Bielefeld Retired
Modified: 2011-08-02 22:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
please see original report (170.95 KB, application/x-download)
2011-02-21 01:22 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-02-21 01:22:12 UTC
Created attachment 43589 [details]
please see original report

Repair Installations failed for "LibreOffice 3.3.1 RC2 – WIN7  Home Premium  (64bit) German UI [OOO330m19 (build 8 / tag 3.3.1.2)]"

I had installed OOo 3.3 and parallel LibO, OOo was standard application.
I wanted to Repair LibO installation so that LibO would be default application for ODF documents.
Repair for LibO failed with message "close quick starter ...", but neither Ooo not LibO had quick starter open.
System reboot did not help.
OOo uninstall worked without problem, but LibO repair still impossible from direct "Repair" button in WIN Dialog (Organisieren - Deinstallieren - Ändern - Reparieren").
But "Ändern"(Modify) worked, after some time I got the radio buttons "Repair - Uninstall - Modify", and "Repair" worked.
I can't tell whether that also would have worked with still installed OOo.
Comment 1 Rainer Bielefeld Retired 2011-03-18 10:53:48 UTC
Same with 3.3.2RC2
Comment 2 Rainer Bielefeld Retired 2011-03-18 11:13:14 UTC
Correction:
Currently "Repair" and "Customize" seem to be totally impossible with "LibreOffice 3.3.2RC2  – WIN7  Home Premium  (64bit) German UI [OOO330m19 (Build:202 / tag 3.3.2.2)]"
Comment 3 Rainer Bielefeld Retired 2011-03-27 01:17:31 UTC
Might be related to
Bug 35709 - Can't upgrade Libre Office
Comment 4 André Schnabel 2011-08-02 10:05:53 UTC
@Rainer: can you please verify with a current 3.4.x build? Modifying the installation on Win7 64bit works fine for me
Comment 5 Rainer Bielefeld Retired 2011-08-02 22:33:32 UTC
@André Schnabel:
Yes, I can't see the problem any longer.