Bug Hunting Session
Bug 34721 - Particular SVG looks bad when open
Summary: Particular SVG looks bad when open
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Jan Holesovsky
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-25 07:04 UTC by kakadu.hafanana
Modified: 2014-06-28 01:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
This file I can't open. (442.83 KB, image/svg+xml)
2011-02-25 07:04 UTC, kakadu.hafanana
Details
test file 2 (774.70 KB, image/svg+xml)
2011-03-03 01:29 UTC, kakadu.hafanana
Details
Screenshot mentioned in second attachment's comment (105.70 KB, image/png)
2011-03-03 01:32 UTC, kakadu.hafanana
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kakadu.hafanana 2011-02-25 07:04:00 UTC
Created attachment 43805 [details]
This file I can't open.

Libre Draw reports `general input/output error`. 
I have no problem with Inkscape (everything works).
Comment 1 tester8 2011-02-26 04:22:24 UTC
Not reproduced with LO 3.3.1 RC2 Ubuntu 10.04 x86.
What is your OS? LO version?
Comment 2 kakadu.hafanana 2011-03-01 01:27:21 UTC
WinXP 32bit, 3.3.0
I'll test this bug on 3.3.1 in a few days.
Comment 3 kakadu.hafanana 2011-03-03 01:15:28 UTC
WinXP 32bit, OO 3.3.1. the same error. I have collected more information.

If I open attachement 43805 from start screen - OK. If I create new Drawing document and then  open this attachement - I see mentioned error: http://img833.imageshack.us/f/libre1.png/
Comment 4 kakadu.hafanana 2011-03-03 01:29:18 UTC
Created attachment 44060 [details]
test file 2

More information.

If I open LibreOffice and there select 'Open' to open this attachment - LibreOffice hangs.
If I open new Drawer document and than open this attachemnt - Libre Office hangs.

If I open this attach from recent documents - Drawer will not hang. But  presentation seems to be incorrect. I'll attach screenshot soon.
Comment 5 kakadu.hafanana 2011-03-03 01:32:02 UTC
Created attachment 44062 [details]
Screenshot mentioned in second attachment's comment
Comment 6 Rainer Bielefeld Retired 2011-11-26 08:14:06 UTC
Both look ugly, but open with "LibreOffice 3.4.4  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:402)]", same with Server installation of MSVC Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [(Build ID:  4f11d0a-adcf6d5-c4bb9bd)]" Windows_2008R8 - 111118)

[Reproducible] with parallel installation of MinGW Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI (Build ID:fba911f-2fcbe65-8b4f344-3bd0388) (daily/Win-x86@7-MinGW/master/2011-11-25_08.14.45)"

I add MinGW to summary because problem remains there

@Jan:
I assigned because problem only with MinGW.
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 7 mathog 2012-01-12 08:46:57 UTC
3.4.4 release on Windows
3.5.0b2 on Windows.

File -> open:  general error (both versions)
Insert -> Picture -> from file:
  3.4.4: immediately after import neither the "11" nor "http..." text
     is visible.  After "break" it looks more like it does in Inkscape,
     with the "http..." text now visible.  However, the "11" never appears.
  3.5.0b2: imported as an image.  Looks more like it does in Inkscape (coloring)
    but the text strings "11" and "http..." are not visible. 

Note that in Firefox 8.0.1 (Windows) the "11" is visible, the coloring is good, but the "http..." text is not shown.
Comment 8 Teo91 2013-09-29 12:53:11 UTC
I can confirm this with LO 4.1.1. on Windows 7 SP1:
- Draw is able to open both SVG files without hanging, BUT the rendering isn't correct
- AOO Draw 4.0 displays both SVG files correctly
Comment 9 Jan Holesovsky 2014-06-17 04:29:51 UTC
According to comment 8, this is not a MinGW-related problem.

Would be worth re-testing with recent LibreOffice, and close if it works correctly now.
Comment 10 Thomas Arnhold 2014-06-28 01:19:32 UTC
I confirm that Libo doesn't hang anymore. I'll open a new bug for the rendering issue, to keep it clear.