Download it now!
Bug 80616 - [SVG] Particular SVG looks bad when open
Summary: [SVG] Particular SVG looks bad when open
Status: RESOLVED DUPLICATE of bug 32248
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: SVG-Open
  Show dependency treegraph
 
Reported: 2014-06-28 01:28 UTC by Thomas Arnhold
Modified: 2015-12-01 10:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Testdoc from fdo#34721 (774.70 KB, image/svg+xml)
2014-06-28 01:28 UTC, Thomas Arnhold
Details
Screenshot with Chrome, correct rendering (44.28 KB, image/png)
2014-06-28 01:30 UTC, Thomas Arnhold
Details
Screenshot with Libo 4.2.5, incorrect (16.12 KB, image/png)
2014-06-28 01:31 UTC, Thomas Arnhold
Details
Screenshot with LO 4.4.x daily on Win 7, incorrect (126.54 KB, image/jpeg)
2014-06-29 12:05 UTC, Teo91
Details
Screen shot with LibreOffice 4.2.5.2 - Incorrect SVG (161.39 KB, image/png)
2014-07-16 11:58 UTC, rk601
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Arnhold 2014-06-28 01:28:51 UTC
Created attachment 101900 [details]
Testdoc from fdo#34721

Open the attached svg with draw. There are several rendering issues:

* The circles have no background color set
* Some circles are missing their text
* Mostly all texts are missing (right behind the circles and those "gsdfgsdfg" texts)

Tested with:

Version: 4.2.5.2
Build ID: 61cb170a04bb1f12e77c884eab9192be736ec5f
On Windows 7


Works fine with AOO (maybe a regression?):

AOO410m18(Build:9764)  -  Rev. 1589052
2014-04-22 11:43:54 (Di, 22 Apr 2014)

Comment from Teo91:

I can confirm this with LO 4.1.1. on Windows 7 SP1:
- [...] the rendering isn't correct
- AOO Draw 4.0 displays both SVG files correctly
Comment 1 Thomas Arnhold 2014-06-28 01:30:03 UTC
Created attachment 101901 [details]
Screenshot with Chrome, correct rendering
Comment 2 Thomas Arnhold 2014-06-28 01:31:11 UTC
Created attachment 101902 [details]
Screenshot with Libo 4.2.5, incorrect
Comment 3 Cor Nouws 2014-06-29 10:47:10 UTC
Hi Thomas,

thanks for the report. Looks OK in 4.3.0.1 on Ubuntu
Can you pls check that with Windows?
Comment 4 Teo91 2014-06-29 12:03:45 UTC
I can confirm this bug on Windows  SP1 with LO 4.4 (26th June daily build): the rendering isn't correct.
Open the related attached screenshot to see.

Is it possble this bug is Windows-only?
Comment 5 Teo91 2014-06-29 12:05:13 UTC
Created attachment 101973 [details]
Screenshot with LO 4.4.x daily on Win 7, incorrect
Comment 6 Thomas Arnhold 2014-06-30 09:42:46 UTC
Cor, it's the same under 4.3.0.1.

Tested with:
Version: 4.3.0.1
Build-ID: 67f5430184326974072b65403ef1d9d934fc4481
Under Windows 7 SP1 x64.
Comment 7 rk601 2014-07-16 11:58:27 UTC
Created attachment 102919 [details]
Screen shot with LibreOffice 4.2.5.2 - Incorrect SVG

We can confirm this bug on OS X 10.6.8 with LO Version: 4.2.5.2

Build ID: 61cb170a04bb1f12e77c884eab9192be736ec5f5 : SVG rendering is incorrect.

Please note that rendering correct text with SVG in LO has been a problem for a long time. For example see: Bug #40088

Open the related attached screenshot to see how this SVG renders on a Macintosh.

This BUG IS NOT "Windows-only."

Additional...the sample SVG renders correctly with Fri, 20 Sep 2013 version of Apache OpenOffice 4.0.1 : AOO401m5(Build:9714) - Rev. 1524958 on OS X 10.6.8.

It appears that LibreOffice has NOT completely integrated Armin Le Grand's SVG import features and updates. Please see:

https://blogs.apache.org/OOo/entry/good_news_libreoffice_is_integrating
Comment 8 V Stuart Foote 2015-02-19 04:10:15 UTC
This affects filter Opening in Draw (File -> Open) on all OS. It is also not correct on Linux builds.

Filter for inserting the SVG (Insert -> Image) into Draw or other components renders the SVG correctly.

@Cor, could you please have another look at your steps and confirm.
Comment 9 Xisco Faulí 2015-11-16 09:22:09 UTC
Color issue is fixed after 179f693ee0682c1e900f9047dfe67969c09a52f3
Comment 10 Xisco Faulí 2015-12-01 10:18:33 UTC
Text problem is a duplicate of bug 32248

*** This bug has been marked as a duplicate of bug 32248 ***