Download it now!
Bug 34880 - FTP communication URL/DDE - Problem from server to local computer
Summary: FTP communication URL/DDE - Problem from server to local computer
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords:
: 39376 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-01 10:58 UTC by Rémy Meunier
Modified: 2011-12-24 04:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rémy Meunier 2011-03-01 10:58:27 UTC
Impossible to open file, copy file or obtain data using DDE function when using macro from a local application or function with ftp address.

Exemple of sub-routine doesn't working well on version 3.3 (working fine on OOo version 3.2.1)

Sub CopyFile
dim demenageur As Object

demenageur = createUnoService("com.sun.star.ucb.SimpleFileAccess")
FileStart = "ftp://utilisateur:motdepasse@ftp.monsite.com/monfichier.ods"
FiileStop = converttourl("C:/monfichier.ods")

demenageur.copy(FileStart,FiileStop)        'False - Erreur d'exécution Basic  com::sun::star::ucb::InteractiveAugmentedIOException (import)

rem demenageur.copy(FiileStop,FileStart)        'OK this way (export)

end sub


Another non working sub routine when call from a local Calc file

Sub OpenFileSub
dim oDocument As Object, oSheet As Object, oCell As Object
dim fichier As STRING, Utilisateur As String

dim document as object, dispatcher as object
document = ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

Fichier = "ftp://test%40monsite.com:monmotdepasse@ftp.monsite.com/monfichier.ods"

dim args102(1) as new com.sun.star.beans.PropertyValue
args102(0).Name = "URL"
args102(0).Value = converttourl(Fichier)
args102(1).Name = "MacroExecutionMode"
args102(1).Value = 4

dispatcher.executeDispatch(document, ".uno:Open", "", 0, args102())

end sub


In other words, tring to get a file or a cell data value from a server does not work.  However, I did not see any problem to put file (or copy file) on a server.  The problem seems to be only on the import side (from server to local computer).  Everything is working fine on OOo ver 3.2.1.  So there is nothing with the ftp address itself.
Comment 1 Cédric Bosdonnat 2011-03-02 03:09:50 UTC
Confirmed in master build.

Here is a code pointer to start debugging it:
http://opengrok.libreoffice.org/xref/libs-gui/ucbhelper/source/client/content.cxx#1527
Comment 2 Rémy Meunier 2011-05-06 05:39:28 UTC
Did not ear about this one for awhile.  Is this tickey make part of the priority?  Need it fixed to upgrade some applications. Case else, I am stock behind with 3.2.1 ..... Regards.
Comment 3 Caolán McNamara 2011-08-16 03:22:05 UTC
So, I think this problem is one I saw and fixed earlier today, i.e.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3ae98a0ca5329a0205728a46b4e5dd0d4b46a9f3
Comment 4 Caolán McNamara 2011-08-16 03:23:16 UTC
*** Bug 39376 has been marked as a duplicate of this bug. ***