Download it now!
Bug 34938 - INDEX function gives error:511 for cell range from other spreadsheets
Summary: INDEX function gives error:511 for cell range from other spreadsheets
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All Windows (All)
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.4
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-02 12:11 UTC by Geza Gemes
Modified: 2011-03-03 14:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Geza Gemes 2011-03-02 12:11:30 UTC
We have a quite complex spreadsheet which uses data from other xls and ods files.
It contains some INDEX functions, which operates on those data (as a side-note, the MATCH functions, which also works from the same files are working as expected).
The spreadsheet was created originally with an ancient version of Openoffice (the Hungarian version, based on go-ooo sources) and later used without problems with each version of Openoffice up until 3.2.1. The problem appeared at upgrading to LibreOffice 3.3.0, and later 3.3.1. At the same time, if I try to reproduce the problem creating a new spreadsheet with only one INDEX function in it, with the cell range from an other spreadsheet, after closing the function wizard, the reference to the other file ('file://....) disappears and Calc errors about a wrong formula.
Comment 1 Kohei Yoshida 2011-03-02 12:23:20 UTC
I just fixed this on master.  The fix will be in 3.4.

*** This bug has been marked as a duplicate of bug 34356 ***
Comment 2 Kohei Yoshida 2011-03-02 12:24:12 UTC
Actually, does INDEX work outside the function wizard?
Comment 3 Kohei Yoshida 2011-03-02 12:29:00 UTC
I'll take this.
Comment 4 Geza Gemes 2011-03-02 13:16:21 UTC
(In reply to comment #2)
> Actually, does INDEX work outside the function wizard?
No it doesn't!

Actually testing it further it seems that there are two distinct bugs:
1. INDEX trowing error with cell range from other file
2. Function wizard deleting cell ranges from formulas if cell ranges from other file (checked with INDEX and MATCH functions)
Comment 5 Geza Gemes 2011-03-02 13:20:52 UTC
(In reply to comment #1)
> I just fixed this on master.  The fix will be in 3.4.
> 
> *** This bug has been marked as a duplicate of bug 34356 ***

Checking 34356 it seems, that my last posts second problem is already reported (#34356), but the original bug is still new:
INDEX function, with an already existing reference to external data gives error.
Comment 6 Kohei Yoshida 2011-03-03 08:41:41 UTC
Yes, the bug regarding the function wizard is fixed now, but I still need to adopt the INDEX function to handle external references.
Comment 7 Kohei Yoshida 2011-03-03 14:14:35 UTC
Fixed this on master.