Download it now!
Bug 35001 - spellcheck context menu contains too few variants
Summary: spellcheck context menu contains too few variants
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium trivial
Assignee: László Németh
URL:
Whiteboard: target:3.7.0 target:3.5.7 target:3.6.2
Keywords:
: 35002 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-03 22:24 UTC by sasha.libreoffice
Modified: 2014-09-05 03:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
spellcheck context menu contains too few variants (40.78 KB, application/vnd.oasis.opendocument.text)
2011-03-03 22:24 UTC, sasha.libreoffice
Details
same explanation in pdf format (51.62 KB, application/pdf)
2011-03-09 03:36 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2011-03-03 22:24:40 UTC
Created attachment 44110 [details]
spellcheck context menu contains too few variants

spellcheck context menu contains too few variants
explanations in Attachment
tryed on Linux 64 bit yet
Comment 1 sasha.libreoffice 2011-03-09 03:36:20 UTC
Created attachment 44267 [details]
same explanation in pdf format
Comment 2 Don't use this account, use tml@iki.fi 2011-03-09 03:37:21 UTC
Please try to write an explanation in text format, in-line in a comment?
Comment 3 Don't use this account, use tml@iki.fi 2011-03-09 03:39:41 UTC
Anyway, as far as I know, especially for LibreOffice as *normally* used on Linux (i.e. from the distro), the spell checking dictionaries are not produced by or shipped with LibreOffice, but are part of the system. The spell checker that chooses variants is hunspell, I think. Most likely you should file a bug against that. Anobody who knows better, please correct me if I am wrong.
Comment 4 sasha.libreoffice 2011-03-09 03:47:12 UTC
When we right click on word with error, context menu produces too few wariant
of right words. We can rarely find needed right word among them. Dictionary is inside Libreoffice install.
P.S. My be I should use pdf in my bugreports because is more handy to open?
Comment 5 Don't use this account, use tml@iki.fi 2011-03-09 03:50:27 UTC
Ao is your complaint that the suitable words are present in the dictionary but not listed? Or that the dictionary should contain more words?
Comment 6 sasha.libreoffice 2011-03-09 04:03:26 UTC
Just tested on Windows XP 32 bit. Strictly the same words.
I think in context menu should be 20 variants.
Comment 7 Don't use this account, use tml@iki.fi 2011-03-09 04:26:48 UTC
But are you using a distro build of LibreOffice on Linux that uses system dictionaries, or a generic Linux build? The generic build presumably indeed uses the same bundled dictionary as does the Windows build. And sure, the system dictionary for a language might be the same, more or less, as the one bundled with LibreOffice. Still, it isn't maintained by LibreOffice, as far as I know.
Comment 8 Don't use this account, use tml@iki.fi 2011-03-09 04:27:22 UTC
So you would prefer to see more variants even if they would not be close to the misspelled word at all?
Comment 9 Don't use this account, use tml@iki.fi 2011-03-09 04:30:57 UTC
I repeat: Is your complaint that suitable words are present in the dictionary (which one(s)?), but not listed as suggestions, or that the dictionary should contain more words?
Comment 10 sasha.libreoffice 2011-03-09 04:35:36 UTC
suitable words are present in the dictionary, but not listed as suggestions
I myself use russian
Comment 11 Don't use this account, use tml@iki.fi 2011-03-09 06:22:05 UTC
OK, so can you then give a *specific* example of a misspelled Russian word, the suggestions listed, and what other words in the dictionary that you think should also be listed, please?

Andras, do you think this falls into your ballpark? Feel free to assign back to the list if not, and/or tell the bug reporter who maintains the Russian dictionary, and resolve as NOTOURBUG perhaps?

Or is this a problem in the LibreOffice code, that it uses hunspell in a way that makes it list too few suggestions? Or is it a problem in the hunspell code?
Comment 12 sasha.libreoffice 2011-03-09 06:44:19 UTC
Entered пов and should be под and spellchecker propose: по and по в.
Comment 13 László Németh 2011-06-07 06:18:05 UTC
Short words with letter replacements are not ideal targets of the n-gram base search.

Try to add the following lines to your *.aff file:

MAXNGRAMSUGS 20
MAXDIFF 10
Comment 14 sasha.libreoffice 2011-06-10 00:17:48 UTC
Thanks for interesting in my problem
I have added these lines to /opt/libreoffice3.4/share/extensions/dict-ru/ru_RU.aff
but nothing changes.
Comment 15 sasha.libreoffice 2011-06-10 03:02:02 UTC
Slightly longer exaple in russian: entered дастает , should be достает but no such variant displayed.
Comment 16 László Németh 2012-08-23 15:17:26 UTC
The problem is the missing "TRY" affix file definition with the Russian alphabet.

From Hunspell manual (hunspell4.pdf in http://sourceforge.net/projects/hunspell/files/Hunspell/Documentation/):

The following affix file example defines UTF-8 character encoding. ‘TRY’ suggestions differ from the bad word with an English letter or an apostrophe. With these REP definitions, Hunspell can suggest the right word form, when the misspelled word contains f instead of ph and vice versa.

SET UTF-8
TRY esianrtolcdugmphbyfvkwzESIANRTOLCDUGMPHBYFVKWZ’

REP 2
REP f ph
REP ph f
Comment 17 Not Assigned 2012-08-24 14:42:22 UTC
Laszlo Nemeth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=f795b16970b65e977eb8ffc3fa33d94dd8e1e75b

fdo#35001 (add TRY for better suggestions)
Comment 18 László Németh 2012-08-24 14:43:30 UTC
Fixed by adding the following TRY definition to the Russian affix file:

TRY иаоентрвсйлпкыьямдушзбгчщюжцхфэъАКСВПМГБЛТДНИОРФЭЕХЧУЗШЯЮЦЖЙЩ
Comment 19 sasha.libreoffice 2012-08-27 09:33:24 UTC
Thanks for fixing this bug
Comment 20 Not Assigned 2012-08-27 11:01:53 UTC
Laszlo Nemeth committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=27caa10134f27e9bb342322af42e6ad8f1ddb4fb&g=libreoffice-3-5

fdo#35001 (add TRY for better suggestions)


It will be available in LibreOffice 3.5.7.
Comment 21 Not Assigned 2012-08-27 11:02:12 UTC
Laszlo Nemeth committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=3eda0173185565948d483469a5a838fa5a103c53&g=libreoffice-3-6

fdo#35001 (add TRY for better suggestions)


It will be available in LibreOffice 3.6.2.
Comment 22 Adolfo Jayme 2014-09-05 03:55:58 UTC
*** Bug 35002 has been marked as a duplicate of this bug. ***