Bug 35077 - [UI] Add an OPTION to switch off special effects, such as flashing lines around copy source cell(s)
Summary: [UI] Add an OPTION to switch off special effects, such as flashing lines arou...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: a11y Cut-Copy
  Show dependency treegraph
 
Reported: 2011-03-06 19:43 UTC by andréb
Modified: 2018-02-13 16:33 UTC (History)
18 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andréb 2011-03-06 19:43:54 UTC
When a cell (or group of cells) is selected for copy (with ctrl-C), very annoying flashing lines surround the source cell(s).

Not being an adept of the "cult of the dancing dog" (aka microsoft), I would like to be able to NOT see the flashing lines.
At least make it an option that can be turned off.

Without the flashing, the source cell(s) are surrounded by a heavy line, which lets the user know that the correct cells have be selected.  That is all that is necessary (or useful).

My system is Linux/x86, but I expect that this problem would apply to all platforms.
Comment 1 Rainer Bielefeld Retired 2011-03-06 23:03:12 UTC
@andréb:
That's you personal opinion that might be contrary to opinion of other users? for me that's an useful feature, so I can see what I selected for copy even when I moved cell cursor to the position where I want to paste. 

Can you contribute objective facts why the current behavior might be bad?
Comment 2 Kohei Yoshida 2011-03-07 05:43:27 UTC
(In reply to comment #0)
> When a cell (or group of cells) is selected for copy (with ctrl-C), very
> annoying flashing lines surround the source cell(s).

I find that useful and so do many other users.

> Not being an adept of the "cult of the dancing dog" (aka microsoft), I would
> like to be able to NOT see the flashing lines.
> At least make it an option that can be turned off.

This is a place to report bugs, not a place to make cute remarks about your anti-MS feelings.

> 
> Without the flashing, the source cell(s) are surrounded by a heavy line, which
> lets the user know that the correct cells have be selected.  That is all that
> is necessary (or useful).

Wrong.  Once the cursor moves all the heavy line is gone.  That's not useful at all.

This is a vital part of Calc's feature, and this can't be turned off.
Comment 3 sasha.libreoffice 2011-03-14 07:34:35 UTC
Option of stopping flashing lines or turning they off my be useful when working on small documents. Meanwhile we have two way to workaround this problem:
Press Esc imediately after Ctrl-C
Copy selected cells using drag and drop: begin drag selected cell and then press Ctrl before drop.
Comment 4 Rainer Bielefeld Retired 2011-05-15 22:40:26 UTC
I doubt that that option ever will come, IMHO it would be something nearby no user will use, for most users that flashing line is a useful feature, see "Bug 36100 - EDITING : Edit > Cut also should show blinking border around cells".

@andréb:
If you believe that we are wrong you can add this enhancement request to the nonofficial Voting Page
<http://wiki.documentfoundation.org/Vote_for_Enhancement>
But I believe it would be wasted time.
Comment 5 andréb 2011-06-07 21:50:49 UTC
Changing title to better reflect my objectives, since I reported the issue.

From :
Add option to switch off flashing lines around copy source cell(s)

To :
Add an OPTION to switch off special effects, such as flashing lines around copy source cell(s)

Further points :

in response to comment 1 :
That I find flashing lines very annoying is just as objective as you finding flashing lines a useful feature.
Perhaps I should have said "very distracting".

in response to comment 2 :
Adding an OPTION to remove special effects such as flashing lines does not in any way prevent others from keeping this behavior

The reference to Microsoft was only to clarify my point of view.  Sorry if that offends you, but many users dislike that sort of glitz.

Once having verified that the correct cells have been selected (with the heavy outline), many users like myself do not need to be reminded that the correct cells have been selected.  We already know.

Flashing lines are not a "vital part" of calc.  Although some users may find it useful, for me (and probably many others) it is very distracting.  By the way, they to not stay flashing as long as the data is in the copy buffer.  Entering data in another cell will stop the flashing.  So you can't depend on the flashing.
Comment 6 Kohei Yoshida 2011-06-07 21:55:42 UTC
(In reply to comment #5)

> Although some users may find it useful, for me (and probably many others) it is very distracting.

This sentence is meaningless.  We can easily swap the "some users" and "many others" to counter your personal opinion.

Anyway, there is zero chance we'll change this behavior.  I'll close it as WONTFIX.
Comment 7 andréb 2011-06-27 14:30:32 UTC
(In reply to comment #6)
> (In reply to comment #5)
> 
> > Although some users may find it useful, for me (and probably many others) it is very distracting.
> 
> This sentence is meaningless.  We can easily swap the "some users" and "many
> others" to counter your personal opinion.

I fail to see how you can deny that I find it very distracting.  That is a simple fact.  Perhaps if the background flashed alternately red and blue, you might understand ?  For me it would not be much worse.
This is a request for an OPTION, not to deny your preferred behavior.

> Anyway, there is zero chance we'll change this behavior.  I'll close it as
> WONTFIX.

If you don't use spreadsheets, you probably haven't noticed the incoherent behavior of these flashing lines.

1) The flashing lines are deactivated by editing a cell, as well as by pushing escape.  But the selected cells remain in the copy buffer.
The flashing lines need not be on the visible in the current window.
So it is not a reliable indicator of the copy buffer contents.
Particularly if copying a larger group of cells.
And if just copying a few cells, it's utility is just marginal at best, assuming that one doesn't have a very short attention span.

2) Pushing escape to cancel can lead to accidently another key, causing more unnecessary delays.

3) The flashing lines remain flashing if the block being copied touches the title line (set under the window menu.)


So why is it not reasonable to want to deactivate this special effect ?
Just as useful (to me) as a dancing paper clip.  (Which Microsoft removed from their office suite, only to recently reintroduce it.  But for them, it is an _option_)

Could you as least indicate where I can find the offending code, so I can deal with it myself ?
And maybe submit a patch to add the option ?
Comment 8 Kohei Yoshida 2011-07-07 09:41:47 UTC
Be my guest, but I have no interest in this.
Comment 9 Kohei Yoshida 2011-07-07 09:50:46 UTC
And DO make sure that you get input from our ux folks. BTW let me just express strong disapproval of adding this option.

Anyway, good luck.
Comment 10 Don't use this account, use tml@iki.fi 2011-07-08 00:22:20 UTC
We need *less* options. Not more. Just my opinion.
Comment 11 andréb 2011-07-11 19:02:11 UTC
If one really WANTS to show the selected bloc for copy, this function needs fixing.
If there were some manner to show the copy bloc without flashing, and all the anomolies, it probably wouldn't be a problem.
As it is, the flashing makes it difficult to concentrate on the task at hand, particularly in a big page with relatively small type.  It also sometimes distorts adjacent text, making it unreadable.
An option not to highlight text to be copied, or to switch off special effects,  seems an easy enough to understand.  There are already many obscure options.

Alternately, there could be an option for how to highlight the copy block.
Not at all being an evident choice (for myself), among others.
Maybe this approach would be more acceptable to everyone ?
Comment 12 Arnolf Best 2012-02-01 13:46:29 UTC
As a OO calc programmer, I fully agree with andréb. The flashing lines surrounding the copied area of cells are very annoying.

Curious about the LO, I wanted to test my application which was created in OO calc. Users of may application don't need those lines, since various copy operations of cell blocks will be done with the help of macros. Limits of cell blocks should be determined only programmatically. No direct user interaction is allowed.

I hope, you correct the behaviour of LO and introduce an option to turn it off.
Comment 13 Kohei Yoshida 2012-02-01 14:11:36 UTC
Don't add me please.  I'm not interested.
Comment 14 Arnolf Best 2012-02-06 06:11:56 UTC
Nobody wants to make an option? OK.

Give me just a tip, how could I turn off those flashing lines from within a macro.
Comment 15 crxssi 2013-02-20 22:12:08 UTC
The "marching ants" animation that was added to Calc has several negative effects:

* We use X11 thin clients, so the animation generates additional, unnecessary, continuous network traffic.
* The animation creates additional CPU load and battery usage on portable devices.
* The animation is extremely distracting to some people (myself included).

I strongly support adding an option to let users turn this animation off.  I have polled my users and most seem to think that it serves no useful purpose.  There is no such animation when copying and pasting in Writer, for example (thank God).  When you copy Draw objects they don't flash or animate (thank God).

At a very minimum it should time out after X number of seconds, or allow the user to choose an animation rate.  But I think having an option to turn it off in Tools-> Options-> Calc -> View (or General) makes more sense.
Comment 16 john.pratt 2013-03-01 17:28:42 UTC
I agree that this behaviour is annoying and inconsistent.  Every time I copy students test results I have to scroll my window as it is annoying.  The top remains even if I hit ESC, as it is next to the freeze window line, and the only way to clear it seems to be to scroll the window.  I also find that sometimes it starts to flash, but nothing has been copied (when I paste there is nothing there, or something from earlier).

It is simply incredibly annoying to me.
Comment 17 tmacalp 2013-03-02 00:12:46 UTC
I would LOVE to have a way to disable the this animation completely.

I, personally, find the animation to be extremely distracting and completely pointless. 

That said, I can understand people wanting to have a choice, so I fully support an option to enable/disable the animation. People seem to be either neutral, weakly in favor of, or EXTREMELY opposed to the animation. Whatever the case, it is enough of an annoyance to warrant an option to disable it.
Comment 18 crxssi 2013-07-26 16:11:27 UTC
No change in LO 4.1.

We are still seeking an option to allow users to suppress the marching ants animation completely or to at least have it time out after X number of seconds.

My suggestion would be to place it under tools-> options-> view-> "Graphics Output" section as a checkbox for "UI animations" which would turn off any animations in all modules.  Or under the "Selection" section as a checkbox for "Selection animations"
Comment 19 andréb 2013-07-27 05:07:51 UTC
(In reply to comment #18)
> We are still seeking an option to allow users to suppress the marching ants
> animation completely or ...

Good description :)

> 
> My suggestion would be to place it under tools-> options-> view-> "Graphics
> Output" section as a checkbox for "UI animations" which would turn off any
> animations in all modules.  Or under the "Selection" section as a checkbox
> for "Selection animations"

I'd go for the same page, "Selection" section,
 with a checkbox "Use animations"

On by default is not a problem as long as there is an option to AVOID the flashing.
Comment 20 crxssi 2013-11-01 11:50:13 UTC
@chtfn:

Could you please explain what your adding the word "VOTE" to the whiteboard means?  Thanks!
Comment 21 stragu 2013-11-03 12:11:55 UTC
Hi Crxssi

It simply means that this bug is listed on the Vote for Enhancement page on the TDF wiki: https://wiki.documentfoundation.org/Vote_for_Enhancement

Cheers
Comment 22 Joel Madero 2014-11-04 03:03:40 UTC
This was never confirmed by anyone on QA team or developer side - in fact, the most involved developers heavily disfavor this idea. That being said - REOPENED is incorrect. Moving to UNCONFIRMED and asking for UX input (as was originally requested by Kohei but no one took the time to do that).

Please stop messing with the severity/priority for your pet bugs....it doesn't help anyone.

Removing VOTE as it's meaningless and not used by anyone, not looked at by any developers, and has no impact on the project.
Comment 23 andréb 2014-11-07 09:19:42 UTC
(In reply to Joel Madero from comment #22)
> This was never confirmed by anyone on QA team or developer side - in fact,

This problem was confirmed by numerous users.  It is disingenuous at best to say that it is not confirmed.

> the most involved developers heavily disfavor this idea. That being said -

Just because developers aren't interested does not mean that users do not find it an important problem - as the comments clearly show.  (You did bother to read them, didn't you ?)
Note also that these same developers confirmed the behavior in question.  (One with the audacity to call the annoying behavior it a "vital part" of calc.)

> REOPENED is incorrect. Moving to UNCONFIRMED and asking for UX input (as was
> originally requested by Kohei but no one took the time to do that).
> 
> Please stop messing with the severity/priority for your pet bugs....it
> doesn't help anyone.

By calling it unconfirmed, you are messing inappropriately with the bug report.
Correcting the status to "new".
Comment 24 MarjaE 2016-06-12 22:33:37 UTC
I have nasty sensory processing issues, and could really use this. How fast are flashing cursors in LibreOffice? 4 Hz? How fast are flashing cell edges? 10 Hz?
Comment 25 Robinson Tryon (qubit) 2016-08-25 05:49:45 UTC Comment hidden (obsolete)
Comment 26 Heiko Tietze 2017-11-08 11:14:12 UTC
Marching ants are important for usability and accessibility as feedback for copy. And getting rid of it is quite simple with escape. So my take is wontfix.

However, many users report issues on X and ask for an option to switch it off. If such an option is implemented the best place is tools > options > advanced > expert configuration. 

Eike, what do you think?
Comment 27 MarjaE 2017-11-09 01:54:49 UTC
I have trouble seeing around flashing/blinking/etc. pain. I mostly use NeoOffice, because it works with a hack to stop the pain. I still occasionally use LibreOffice Draw, where escape drops the selection, so that workaround won't help.

So from my perspective, with my disabilities, flashing/blinking/etc. objects are an important barrier to usability and accessibility.
Comment 28 Eike Rathke 2017-11-10 14:13:50 UTC
(In reply to Heiko Tietze from comment #26)
> an option to switch it
> off. If such an option is implemented the best place is tools > options >
> advanced > expert configuration. 
> 
> Eike, what do you think?
I'm unbiased. Expert config is as fine for me.
Comment 29 crxssi 2017-11-10 14:39:18 UTC
After so many years of this annoyance, I would welcome ANY method of disabling it.  No doubt the easiest, quickest, safest, and least controversial way to accomplish that would be to just add an expert config option.  I don't think it is the ideal location, but it is a huge step forward.  Let's just add it there and worry about the UI down the road (if ever).
Comment 30 Telesto 2018-02-11 19:22:38 UTC
Fixing this bug isn't to hard :-). The expert configuration has a setting for it since 2015-03-09.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2e293978d80c5113ea37f4c7f4b18ee01f2022e1

1. Open Calc
2. Tools -> Options -> Advanced -> Open the expert configuration
3. Search for: AnimationsEnabled
4. Set it to: False
Comment 31 MarjaE 2018-02-11 20:28:55 UTC
Thank you! The workaround definitely helps.
Comment 32 Heiko Tietze 2018-02-12 15:51:11 UTC
(In reply to Telesto from comment #30)
> 1. Open Calc
> 2. Tools -> Options -> Advanced -> Open the expert configuration
> 3. Search for: AnimationsEnabled
> 4. Set it to: False

Haven't found it myself and kept this ticket in my inbox for a while. Thanks a lot!

Closing as WFM as Tools > Options > Advanced is the perfect solution.
Comment 33 MarjaE 2018-02-12 21:22:04 UTC
Won't that hide this from other users who need to protect themselves? I think this should be taken as an enhancement request, to make it easier to find these accessibility settings, when they exist.
Comment 34 crxssi 2018-02-12 21:59:28 UTC
(In reply to MarjaE from comment #33)
> Won't that hide this from other users who need to protect themselves? I
> think this should be taken as an enhancement request, to make it easier to
> find these accessibility settings, when they exist.

I agree.  I don't think this issue should be closed as "resolved" quite yet...

I am VERY glad there is an "expert configuration" option.  This will help a lot of people (if they can ever find it).  However, I thought part of the point of this bug/enhancement report/request was to also have something more visible for users to use in the UI to control it.

For example- in Tools-> Options-> Accessibility-> Misc Options   there are already checkboxes for "allow animated graphics" and "allow animated text".  It seems logical that if a user said they don't want to see animated graphics, that would include animated graphics of the selection process (or any other screen animation).  Perhaps not, but it seems plausible.  And if not, then if we have THOSE two available in options, why not add an "allow copy/paste animation" or "allow selection animation" option right there with them?
Comment 35 Heiko Tietze 2018-02-13 08:32:35 UTC
We have different levels of visibility for options:
* always on top (toolbar/sidebar) for features most frequently and repeatedly used in a session
* easy accessible (main/context menu) for features that are used a few times in a session
* user configuration (options dialog) for things that are usually not changed and if set onetime
* expert settings (registry) for options that are harmful when used wrong and very unlikely changed

You can always ask to what level a feature belongs, and depending on your use case the more prominent position might make sense. 

In the particular case the animated frame (usually called "marching ants") is a useful and familiar feature, annoying (but not disruptive) for only a few users, with the very simple corrective action to press escape. Promoting it to T>O would lead to confusion and requires documentation. The unclear relation to existing animations [1] is another argument against having it in T>O.

If we stay with hidden expert options I'm strongly against making it available somewhere. (The alternative is to move away from hidden options in general and have _all_ in T>O.)

[1] https://help.libreoffice.org/Common/Accessibility
Comment 36 MarjaE 2018-02-13 14:06:47 UTC
> In the particular case the animated frame (usually called "marching ants") is a useful and familiar feature, annoying (but not disruptive) for only a few users, with the very simple corrective action to press escape. Promoting it to T>O would lead to confusion and requires documentation. The unclear relation to existing animations [1] is another argument against having it in T>O.

"annoying (but not disruptive) for only a few users"

It can be hard to see what I'm doing when I can't see that part of the screen because of the painful flashing. It also triggers migraines and nausea. I'd call that disruptive.

"with the very simple corrective action to press escape."

The hidden setting can already block flashing in both Calc and Draw. The escape key helps in Calc, but loses focus in Draw.
Comment 37 V Stuart Foote 2018-02-13 16:32:38 UTC
Available in Expert Configuration:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2e293978d80c5113ea37f4c7f4b18ee01f2022e1

=> FIXED

Opened bug 115688 -- Add Checkbox option to disable animated overlay to Tools -> Options -> Accessibility panel