Bug 35111 - A combo box in writer document doesn't expose ROLE_COMBO_BOX to AT-SPI.
Summary: A combo box in writer document doesn't expose ROLE_COMBO_BOX to AT-SPI.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: a11y-Linux
  Show dependency treegraph
 
Reported: 2011-03-08 03:16 UTC by Dattatray Bhat
Modified: 2014-02-03 20:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Accerciser screen shot: Combo box in writer exposes ROLE_PANEL to AT-SPI. (144.04 KB, image/png)
2011-03-08 03:16 UTC, Dattatray Bhat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dattatray Bhat 2011-03-08 03:16:29 UTC
Created attachment 44223 [details]
Accerciser screen shot: Combo box in writer exposes ROLE_PANEL to AT-SPI.

A combo box in writer document doesn't expose ROLE_COMBO_BOX to AT-SPI. It exposes 'ROLE_PANEL'. If a combo box exposes the correct role, assistive tools like a screen reader can make the document more accessible.

Steps to reproduce:
1. Start Libre Office writer. Create a new text document. Add a combo box. Add three items say 'circle', 'triangle' and 'square'. Turn Design Mode off. Save the document.

2. Start Accerciser accessibility explorer.

3. Go to the accessible tree view at top left. As shown in attached screen-shot, select the accessible object corresponding to the combo box just created. The Role column shows 'panel'.

4. In the plug-in view at top right, select Interface Viewer. The first line
shows the role as 'panel'. though the name shown is Combo Box 1.

5. Go to the IPythonConsole at bottom. Command acc.getRole() returns the role
as ROLE_PANEL.
Comment 1 Björn Michaelsen 2011-12-23 11:52:04 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Dattatray Bhat 2011-12-27 00:08:11 UTC
Today I rechecked my observation with Libre Office dev 3.5.0 beta2 and found
that the bug persists. I suggest that the bug be moved back to NEW status.
Comment 3 Florian Reisinger 2012-08-14 14:03:52 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:04:47 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:09:16 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:11:16 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Joanmarie Diggs 2012-08-14 14:36:52 UTC
I don't know how I missed the bugmail, but this was never addressed.
Comment 8 Florian Reisinger 2012-08-15 12:36:41 UTC
Okay
Comment 9 Julien Nabet 2013-11-16 15:05:46 UTC
Dattatray: could you give a try with a newer LO version (last one is 4.1.3).

I gave a try but was stopped by 2 things:
1) I found combobox in Form Controls view but I can't put elements of my choice since I got to bind it to a DB. I suppose I missed or misunderstood something
2) I installed Debian package for accerciser
but when trying to launch, I got this:
Traceback (most recent call last):
  File "/usr/bin/accerciser", line 50, in <module>
    accerciser.main()
  File "/usr/lib/pymodules/python2.7/accerciser/__init__.py", line 35, in main
    main = Main()
  File "/usr/lib/pymodules/python2.7/accerciser/accerciser.py", line 62, in __init__
    self.window = AccerciserMainWindow(self.node)
  File "/usr/lib/pymodules/python2.7/accerciser/main_window.py", line 51, in __init__
    self._populateUI(node)
  File "/usr/lib/pymodules/python2.7/accerciser/main_window.py", line 110, in _populateUI
    paned.set_data('last_position', paned.get_position())
  File "/usr/lib/python2.7/dist-packages/gi/overrides/GObject.py", line 555, in _unsupported_data_method
    raise RuntimeError('Data access methods are unsupported. '
RuntimeError: Data access methods are unsupported. Use normal Python attributes instead

So I won't be able to test.
Comment 10 Julien Nabet 2013-11-16 17:31:47 UTC
Ok, I used git sources of acceciser and gave it a try, I reproduce the problem whereas we go there:
http://opengrok.libreoffice.org/xref/core/vcl/source/window/window.cxx#8849
Comment 11 Jacobo Aragunde Pérez 2014-02-03 20:09:11 UTC
Tested with 4.1.4 and 4.3 (master), it seems to be fixed nowadays.