Bug 35155 - No character border
Summary: No character border
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: low enhancement
Assignee: Zolnai Tamás
QA Contact:
URL:
Whiteboard:
Keywords:
: 42967 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-09 07:56 UTC by Paulo Correia
Modified: 2013-09-16 11:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
text, where some words has borders around them (18.18 KB, application/vnd.oasis.opendocument.text)
2012-01-20 06:37 UTC, sasha.libreoffice
Details
DOC with border around a word (23.50 KB, application/msword)
2013-01-14 23:17 UTC, Michael Zaugg
Details
DOCX with border around a word (12.93 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-01-14 23:18 UTC, Michael Zaugg
Details
Screenshot with border shown in Word 2010 (1.38 KB, image/png)
2013-01-14 23:19 UTC, Michael Zaugg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paulo Correia 2011-03-09 07:56:27 UTC
In All Libreoffice and old OpenOffice version don't have the character border function.
How i make this feature or add-on for Libreoffice ?
Thanks
Paulo Correia
Comment 1 Don't use this account, use tml@iki.fi 2011-03-09 08:26:37 UTC
Please describe what this functionality does. Maybe somebody can tell you how to work around it missing. (Or maybe tell you how to do it in LibreOffice, maybe you just didn't find it?)
Comment 2 Paulo Correia 2011-03-09 15:14:25 UTC
As the same as formatting a paragraph with a border, I would like format one or more characters with a border.
On the LibreOffice the borders tab only exists in the paragraph option on the format menu.
I would wish the borders tab would also exist on character option on the format menu.
Thanks
Paulo Correia
Comment 3 Cédric Bosdonnat 2011-03-14 02:40:42 UTC
The feature doesn't exist in LibreOffice. The idea here is to be able to add borders around some characters as this can be done around paragraphs. This can be perceived as an interop problem with MSO Word or HTML.

The feature consist in having the following equivalent of HTML:
<p>Some sample with <span style="border: thin solid red;">char</span> borders</p>

The feature isn't trivial to implement and I'm wondering how many users it would make happy... I mean is it worth the pain?

What would need to be done:
  * Hack the core to add one more character attribute [0]
  * Hack the UI to be able to use the feature [1]
  * Hack the layout to actually draw the borders [2]
  * Hack the filters to support the feature (ODF, WW8, DOCX, HTML, and maybe others)
  * Propose an ODF enhancement as borders attributes aren't valid for <style:text-properties> element.

[0] http://opengrok.libreoffice.org/xref/writer/sw/inc/hintids.hxx
[1] http://opengrok.libreoffice.org/xref/writer/sw/source/ui/chrdlg/chardlg.cxx
[2] http://opengrok.libreoffice.org/xref/writer/sw/source/core/layout/paintfrm.cxx.

Happy hacking to the one who picks this one (and contact me to get more code pointers)
Comment 4 Cédric Bosdonnat 2011-03-14 02:41:10 UTC
Provided info instead of reporter
Comment 5 Cédric Bosdonnat 2011-03-14 02:45:30 UTC
Report on OpenOffice.org bugzilla is here and has 19 votes since 2003-08-06:
http://openoffice.org/bugzilla/show_bug.cgi?id=17930
Comment 6 Paulo Correia 2011-11-15 18:36:02 UTC
(In reply to comment #5)
> Report on OpenOffice.org bugzilla is here and has 19 votes since 2003-08-06:
> http://openoffice.org/bugzilla/show_bug.cgi?id=17930

I can not do this alone.
Can anyone help me in this.
I don't have the knowledge necessary to do the hacking of LibreOffice and implement this feature.

When importing a doc and html file if have character bord the same disappears.
How do I ask an whislist ?

The OASIIS standard provided cacactere bord?

Thanks,

Paulo Correia
Comment 7 Björn Michaelsen 2011-12-23 11:46:39 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 8 sasha.libreoffice 2012-01-20 06:37:07 UTC
Created attachment 55831 [details]
text, where some words has borders around them

At this time standalone words or characters can be placed into frames, rectangles (or other drawing elements) and into text frames. Attachment demonstrates result. IMHO If goal is only open MSWord files and HTML files correctly, and not create such files in Writer, at first time Input Filter can place text(characters) with borders into such objects. It much easy than implement into Writer new thing.
Comment 9 Paulo Correia 2012-02-22 13:31:47 UTC
The Input filter not works fine.
When I input one html file with character border, The Writer (3.5) Convert the character border to an paragraph border.
When I save this html the character border is now an paragraph border.
I don't try with MSWord.
I find the source code but i don't know what to do.

http://docs.libreoffice.org/sw/html/hintids_8hxx_source.html
http://docs.libreoffice.org/sw/html/chardlg_8cxx_source.html
http://docs.libreoffice.org/sw/html/paintfrm_8cxx_source.html

Can anyone help me in this.
The OASIIS standard provided cacactere bord?

Thanks,

Paulo Correia
Comment 10 Florian Reisinger 2012-08-14 13:59:55 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 11 Florian Reisinger 2012-08-14 14:01:04 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 12 Florian Reisinger 2012-08-14 14:05:48 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 13 Florian Reisinger 2012-08-14 14:07:49 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 14 Michael Zaugg 2012-11-15 10:56:03 UTC
(In reply to comment #7)
> [This is an automated message.]
> This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
> started right out as NEW without ever being explicitly confirmed. The bug is
> changed to state NEEDINFO for this reason. To move this bug from NEEDINFO
> back
> to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2
> prereleases.
> Details on how to test the 3.5.0 beta1 can be found at:
> http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1
> 
> more detail on this bulk operation:
> http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-
> tp3607474p3607474.html
Comment 15 Rainer Bielefeld Retired 2012-12-20 05:44:08 UTC
Paulo Correia:
Can you contribute some very simple sample.doc / sample.docx created with WORD with that feature used in it?
Comment 16 Michael Zaugg 2013-01-14 23:17:44 UTC
Created attachment 73028 [details]
DOC with border around a word
Comment 17 Michael Zaugg 2013-01-14 23:18:11 UTC
Created attachment 73029 [details]
DOCX with border around a word
Comment 18 Michael Zaugg 2013-01-14 23:19:08 UTC
Created attachment 73030 [details]
Screenshot with border shown in Word 2010
Comment 19 Rainer Bielefeld Retired 2013-01-15 05:57:35 UTC
As Cédric already said, there are doubts concerning rewult of a costs / benefit calculation.
Currently the only real important argument I can see is MS WORD interoperability, currently LibO would damage a .doc using that feature.

Softmaker-FreeOffice and Symphony also do not support this feature.

@Paulo Correia:
a) Is this MS Office capability limited to Word or can also Excel do a border around a selected range of characters?
b) Is that MSO capability limited to do a border around a range or can also be  created a border around every single character?
c) Please contribute some "real life" examples where that is useful / important
Comment 20 Adam CloudOn 2013-06-16 13:24:34 UTC
(In reply to comment #19)
> As Cédric already said, there are doubts concerning rewult of a costs /
> benefit calculation.
> Currently the only real important argument I can see is MS WORD
> interoperability, currently LibO would damage a .doc using that feature.
> 
> Softmaker-FreeOffice and Symphony also do not support this feature.
> 
> @Paulo Correia:
> a) Is this MS Office capability limited to Word or can also Excel do a
> border around a selected range of characters?
> b) Is that MSO capability limited to do a border around a range or can also
> be  created a border around every single character?
> c) Please contribute some "real life" examples where that is useful /
> important

a) This capability is limited to Word.
   Excel and PowerPoint do not support this feature.
   (Tested in Office 2010).

b) A border can be created around a single character.
   However - if 2 adjacent characters are 'bordered' separately - Word will
   combine them to a single box border around them.

c) cannot think of a real-life example, except for ... wanting to put a box around several words.

In addition to the above - Word support shading to the border,
different border thickness and border color.
However, only a box border is supported ( cannot create a 'left' border on a character).
Comment 21 Zolnai Tamás 2013-06-26 12:23:46 UTC
*** Bug 42967 has been marked as a duplicate of this bug. ***
Comment 22 Michael Zaugg 2013-07-09 23:21:59 UTC
A real live example is a creating a manual where you have to show key caps (e.g. for shortcuts). To implement this you have to use graphics or character borders.

For an example of shortcuts with 'key caps' see http://en.wikipedia.org/wiki/Keyboard_shortcut
Comment 23 Zolnai Tamás 2013-09-16 11:14:25 UTC
Solved as a GSoC 2013 project.
Will be available in version 4.2.