Download it now!
Bug 35345 - Cells hidden with filters get changed
Summary: Cells hidden with filters get changed
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.0 RC1
Hardware: All All
: highest major
Assignee: Katarina Behrens
URL:
Whiteboard: target:3.4.1
Keywords:
: 35403 (view as bug list)
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-03-15 17:30 UTC by stgries
Modified: 2011-05-25 06:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
See Comment 1 (9.41 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-03-15 23:18 UTC, Rainer Bielefeld Retired
Details
steps to reproduce failure (273.08 KB, application/pdf)
2011-05-23 06:53 UTC, Alexei Neufeld
Details
Test document for the removed hidden cells; scenario from the comment #10 (7.73 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-05-23 07:14 UTC, Petr Mladek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stgries 2011-03-15 17:30:22 UTC
When the display of values is constrained with an autofilter, one cannot use dragging to autofill other cells without also affecting the cells the autofilter did hide. If you, say, hide several rows via Autofilter and then "drag-fill" data into cells that are still visible, hidden cells are overwritten as well. With Excel, those hidden fields are left untouched.

Other examples / descriptions:
<http://user.services.openoffice.org/en/forum/viewtopic.php?f=9&t=20725&start=0>;
<http://www.theregister.co.uk/2009/07/16/openoffice_autofilter_bug_feature/>.

Super annoying ...
Comment 1 Rainer Bielefeld Retired 2011-03-15 23:17:07 UTC
[Reproducible] with "LibreOffice 3.3.2RC1  – WIN7  Home Premium  (64bit) German UI [OOO330m19 (Build:201 / tag 3.3.2.1)]"

Steps to reproduce: 
1. open attached "sample10.ods"
2. Filter column d  "<>b" (you can use special filter "filterdforb")
   rows 5:7 will beocme hidden
3. Click on 'A4' with the red "X"
   Cell cursor with little fill handle at the right bottom corner appears
4. Move mouse pointer to fill handle so that mouse pointer view changes
5. click and drag/drop fill handle to'A10'
   red border around fill area 'A4:A10' appears
6. release mouse button:
   Range within round border will be filled with red "X"
7. Menu 'Data > Filter > Remove Filter' to make hidden rows visible
   expected: hidden cells will not have been changed
   actual: also contain "X"

That behavior differs from the one if you try 'Edit > Fill > down' starting with step 4, that function will not be available to protect the hidden cells.

OOo:
 Bug 104473 -  Cells hidden by using AutoFilter are overwritten by using copy with fill handle  
<http://openoffice.org/bugzilla/show_bug.cgi?id=104473>
what is a DUP of
 Bug 89232 -  Fill operations should not touch filtered rows
<http://openoffice.org/bugzilla/show_bug.cgi?id=89232>

<http://openoffice.org/bugzilla/show_bug.cgi?id=89232>
@stgries:
Your LibO version is?

@Katarina
Is this problem already on the schedule?
Comment 2 Rainer Bielefeld Retired 2011-03-15 23:18:14 UTC
Created attachment 44494 [details]
See Comment 1
Comment 3 Rainer Bielefeld Retired 2011-03-18 05:37:41 UTC
*** Bug 35403 has been marked as a duplicate of this bug. ***
Comment 4 Fran 2011-04-05 04:37:58 UTC
Solved in OpenOffice (see comment 27):
http://openoffice.org/bugzilla/show_bug.cgi?id=89232#c27

It's a really annoying problem. Would be great having it solved on 3.4.
Comment 5 Katarina Behrens 2011-04-13 00:07:31 UTC
Allright, I've extracted relevant parts of that CWS and put it into 3.4 branch. Let's call this fixed then
Comment 6 Alexei Neufeld 2011-05-08 22:37:37 UTC
LibreOffice 3.4.0 DEV300m103 (Build:4)

somthing going worse. now it delets hidden cells.
Comment 7 Alexei Neufeld 2011-05-18 22:27:12 UTC
Win XP and Win 7
LibreOffice 3.4.0 OOO340m1 (Build:11) RC1

deletes hidden cells after using filter and pull down selected data for auto fill.
Comment 8 Petr Mladek 2011-05-23 05:53:10 UTC
(In reply to comment #7)
> Win XP and Win 7
> LibreOffice 3.4.0 OOO340m1 (Build:11) RC1
> 
> deletes hidden cells after using filter and pull down selected data for auto
> fill.

I am unable to reproduce this with LibreOffice 3.4.0 OOO340m1 (Build:11) RC1 on Windows XP. I use the steps from the comment #1. The result is that the cells A5..A6 include the values 4, 5, 6. The cells A4, A8..A10 include the red X. => everything works as expected.

Alexei, do you use another steps?
Comment 9 Katarina Behrens 2011-05-23 06:40:02 UTC
I can reproduce in master build, unfortunately :(
And it got worse somehow, as the values get incremented on drag-fill i.e. the
cells are filled with XI, XII, I, ... (roman numerals) :( :(
Comment 10 Alexei Neufeld 2011-05-23 06:53:56 UTC
Created attachment 47045 [details]
steps to reproduce failure

here my steps with filter in calc
Comment 11 Petr Mladek 2011-05-23 07:14:33 UTC
Created attachment 47046 [details]
Test document for the removed hidden cells; scenario from the comment #10

I am able to reproduce the scenario from the comment #10 as well with LO-3.4.0-rc1.
Comment 12 Katarina Behrens 2011-05-25 05:08:15 UTC
Allright folks, this is fixed, but for 3.4.1 only, didn't make 3.4.0 deadline