Bug Hunting Session
Bug 89232 - Improvements to comments look and function
Summary: Improvements to comments look and function
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 108626 (view as bug list)
Depends on:
Blocks: Writer-Comments
  Show dependency treegraph
 
Reported: 2015-02-08 16:46 UTC by Joel
Modified: 2019-04-02 20:03 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
comparison of commenting layouts (650.55 KB, application/pdf)
2015-02-11 19:16 UTC, Joel
Details
comment reply (28.33 KB, image/png)
2015-03-02 01:22 UTC, Yousuf Philips (jay) (retired)
Details
sample (9.13 KB, application/vnd.oasis.opendocument.text)
2015-03-02 08:43 UTC, Yousuf Philips (jay) (retired)
Details
Minimalist comment box from Apple Pages 4.3 (21.31 KB, image/png)
2017-04-25 18:17 UTC, Orion
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joel 2015-02-08 16:46:08 UTC
Hi,
I think the comments in LibreOffice Writer don't look very good, to the point that it impairs functionality. The default font size is too big so if there are many comments, I either have to click the scroll bar on each individual one or resize the fonts for them individually. The commenting box is also taking up unnecessary space that is not filled with text. Things that will improve the commenting experience are: a smaller font, removing of clutter (appears on mouseover only) and elongating the comments horizontally so they don't take too much vertical space. It is also not possible to respond to a comment someone else has made, but one has to create a new comment next to it instead.

I believe there is much that can be learned by looking at how the commenting is done in Google Docs and also  Word2013. There it is easy to get an overview of what has been commented upon at a quick glance and get to the important comments right away.

cheers,
Comment 1 V Stuart Foote 2015-02-08 16:54:35 UTC
@Joel,

Thanks for posting...

Moving this over to ux-advise side. Please identify the build of LibreOffice you are working with as there are continual changes with the track changes and commenting.

Mock-ups and annotated screen captures are helpful to the design and implementation process--see if you can rough them out with pointers of what is wrong and which are priorities.
Comment 2 Heiko Tietze 2015-02-09 09:34:55 UTC
The UX team is currently working on a new implementation of the changes manager. Stay tuned for the upcoming blog post...
Comment 3 Joel 2015-02-11 19:16:50 UTC
Created attachment 113320 [details]
comparison of commenting layouts

Some specifics regarding what is good and bad regarding the layout of comments in MS Word, LO, and Google docs
Comment 4 Joel 2015-02-11 19:19:05 UTC Comment hidden (obsolete)
Comment 5 Yousuf Philips (jay) (retired) 2015-02-11 20:23:09 UTC
Totally agree that improvements are needed to commenting and i was intending to make many of the same suggestions as i've used Google Docs and liked their style of commenting, primarily the easy of nested comments.

As bug reports are supposed to focus on one particular bug/enhancement, i think this one should be retitled to focus on improving comments as Heiko and the design team are working on improvements to track changes.
Comment 6 Yousuf Philips (jay) (retired) 2015-02-22 19:21:20 UTC
Here are some of the suggestions i think should go into improving comments.

* Make comments a plain color rather than the gradient, as the page is plain and so is the comment column.
* Minimum height of a comment needs to me smaller
* Comments column needs to be wider by 10 to 15 percent.
* Padding should be around the comment text as well the author and time lines should be padded as well.
* Two additional buttons are needed along with the drop down button. One for delete and one for reply (both being available in the context menu).
* It would be nice to have a slightly darker background color for the information part of the comment, so that its easier to see what part isnt the comment text.
Comment 7 Yousuf Philips (jay) (retired) 2015-03-02 01:22:02 UTC
Created attachment 113806 [details]
comment reply

(In reply to Joel from comment #0)
> It is also not possible to
> respond to a comment someone else has made, but one has to create a new
> comment next to it instead.

Just to clarify this. I was also under the impression that it wasnt possible to do so, but it is. You click on the drop arrow of the comment you want to respond to and you will be given the option to reply to it if the comment originates from another user. It would be better for an icon to appear in the same area that a user could click to reply rather than having them open up the drop down to do it, as replying to a comment is a fundamental of commenting.
Comment 8 Heiko Tietze 2015-03-02 08:00:05 UTC
Try to save and reload the document. In my test with 4.5 the secondary comment wasn't stored as it. Despite from this bug a threaded review would need more than just one level (comment to comment). UX team dropped this therefore as a primary requirement.
Comment 9 Yousuf Philips (jay) (retired) 2015-03-02 08:43:31 UTC
Created attachment 113813 [details]
sample

I just tested saving reply comments in a document and it saved fine for me, so if thats not the case for you Heiko, i'd file a bug for that. I've attached one i just created.
Comment 10 Robinson Tryon (qubit) 2016-08-25 04:44:49 UTC Comment hidden (obsolete)
Comment 11 Orion 2017-04-25 18:16:35 UTC
(In reply to Yousuf Philips (jay) from comment #6)
> * Make comments a plain color rather than the gradient, as the page is plain
> and so is the comment column.
The gradient looks nice. If it ain't broke...

> * Minimum height of a comment needs to me smaller
Agreed! Easiest way to fit more on the page (see below). 

> * Comments column needs to be wider by 10 to 15 percent.
As long as this doesn't interfere with printing (which it shouldn't), agreed! 

> * Padding should be around the comment text as well the author and time
> lines should be padded as well.

Disagree, actually. The more padding you add, the less space you have for comments, which is why I suggest: 

* Make the time-stamp and the author optional. 

* Make the minimum size ~1~ line, not four 

(See attachment from Pages, above.)
Comment 12 Orion 2017-04-25 18:17:44 UTC
Created attachment 132838 [details]
Minimalist comment box from Apple Pages 4.3
Comment 13 Yousuf Philips (jay) (retired) 2017-04-25 18:35:27 UTC
(In reply to Orion from comment #11)
> > * Comments column needs to be wider by 10 to 15 percent.
> As long as this doesn't interfere with printing (which it shouldn't),
> agreed! 
> 
> > * Padding should be around the comment text as well the author and time
> > lines should be padded as well.
> 
> Disagree, actually. The more padding you add, the less space you have for
> comments, which is why I suggest: 

With the increase of the column width by 10 to 15 percent adding padding wouldnt to a negative. The need for padding is quite obvious, as you dont create documents without page margins and presently that is how comments appear touching the sides of the comments column.
Comment 14 Xisco Faulí 2017-06-19 11:11:53 UTC
*** Bug 108626 has been marked as a duplicate of this bug. ***
Comment 15 Nick Bugs 2018-02-12 09:41:16 UTC
Hi, for me the key would be for all of all the comments to be visible, where space makes that a possibility, and where it isn't, clicking into a comment should immediately show the whole of that comment (up to a very generous limit).
Cheers!
Comment 16 Daniel Mcr 2018-11-09 16:58:35 UTC
Hi,

In Libre Office Online currently you can put a comment on an item, we use Google Docs where you have threaded view that can be pulled up any time from within the document and the ability for 'resolved' comments to stay in place. That way you have a clear history of what has been discussed and can be referred back to.

I submitted this as per https://github.com/nextcloud/richdocuments/issues/274 and was advised similar to this issue.

Is this possible?

Many thanks

Daniel
Comment 17 Cor Nouws 2019-04-02 20:03:14 UTC
Dear people,

There are several useful remarks in this report. But of such a different nature, that it does short to most/all of them.
Pls be so kind to pick out your specific RFE and create a new report. Thanks!

In doing so, you may want to take a look at existing issues too:

https://bugs.documentfoundation.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&f1=short_desc&f2=short_desc&j_top=OR&list_id=934583&product=LibreOffice&query_format=advanced&short_desc=comments&short_desc_type=allwordssubstr