Bug Hunting Session
Bug 35405 - Using Thesaurus causes crash
Summary: Using Thesaurus causes crash
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 35464 (view as bug list)
Depends on:
Blocks: Thesaurus
  Show dependency treegraph
 
Reported: 2011-03-18 00:16 UTC by Francisco Belmonte
Modified: 2017-02-04 11:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
a spreadsheet used like scheduler (52.44 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-03-18 02:28 UTC, Francisco Belmonte
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco Belmonte 2011-03-18 00:16:31 UTC
when i try to use "synonimous", the program crash and closes.
Comment 1 David Tardon 2011-03-18 00:50:13 UTC
I have no idea what "synonimous" might be or how does one use it... Could you tell us what did you do, where you clicked etc., preferably in a few easy-to-follow steps?
Comment 2 Francisco Belmonte 2011-03-18 01:21:43 UTC
(In reply to comment #1)
> I have no idea what "synonimous" might be or how does one use it... Could you
> tell us what did you do, where you clicked etc., preferably in a few
> easy-to-follow steps?

Dear Sir,

I beg your pardon for my poor english, but here you are:

You open a document in writer.

type some words misspelled.

Select one of these words.

Go to Tools->Language->Synonimous (CTRL+F7)... and you have a beatiful crash..

Yours sincerely,

Francisco Belmonte
Comment 3 Rainer Bielefeld Retired 2011-03-18 01:51:49 UTC
NOT Reproducible with "LibreOffice 3.3.2RC1  – WIN7  Home Premium  (64bit) German UI [OOO330m19 (Build:201 / tag 3.3.2.1)]"

May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport>?
Then please:
- Attach a sample WRITER document so that we can try to reproduce your problem
- add information 
  -- concerning your PC 
  -- concerning your OS
  -- concerning your LibO localization (UI language) and installed dictionaries
  -- Whether that problem also occurs in CALC
  –- Libo settings that might be related to your problems 
  -- everything else crossing your mind after you read a.m. URL
Comment 4 David Tardon 2011-03-18 02:00:20 UTC
Ah, thesaurus... I'm pretty sure this is https://bugzilla.redhat.com/show_bug.cgi?id=675806, then. We have fixed it in master, but not in 3.3. Maybe we should, too?
Comment 5 Caolán McNamara 2011-03-18 02:19:47 UTC
yeah @yahoo.es -> likely this is Spanish, and the known mythes crasher was triggered by a Spanish thesaurus extension
Comment 6 Caolán McNamara 2011-03-18 02:23:30 UTC
cherrypicked b788f9fc846c0f47d02df02ac6733c0ac21a13c6 to 3-3, need more acks to push to 3-3-2

its a trivial fix: see http://cgit.freedesktop.org/libreoffice/libs-extern/commit/?h=libreoffice-3-3&id=896c49083aec918b0710f9c62f2f775a53f28057
Comment 7 Francisco Belmonte 2011-03-18 02:28:18 UTC
Created attachment 44570 [details]
a spreadsheet used like scheduler
Comment 8 Rainer Bielefeld Retired 2011-03-18 04:55:48 UTC
@Francisco Belmonte:
Thank you for your contribution, additional information only will be required if you find out that your problem unexpectedly is different to the one that will be fixed soon, as you can see.
Comment 10 Runspect 2011-03-21 15:01:05 UTC
*** Bug 35464 has been marked as a duplicate of this bug. ***