Bug Hunting Session
Bug 35681 - VIEWING: Gradient loss for bright transparent objects on dark background in presentation mode
Summary: VIEWING: Gradient loss for bright transparent objects on dark background in p...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Radek Doulik
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Impress-Gradient
  Show dependency treegraph
 
Reported: 2011-03-25 17:31 UTC by Fabian
Modified: 2014-07-14 19:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test case file matching the "steps to reproduce" (12.20 KB, application/vnd.oasis.opendocument.presentation)
2011-03-25 17:31 UTC, Fabian
Details
Screenshot of the presentation mode: Transparency incorrect. (19.34 KB, image/png)
2011-03-25 17:33 UTC, Fabian
Details
Screenshot of the edit mode: Transparency ok. (58.53 KB, image/png)
2011-03-25 17:33 UTC, Fabian
Details
Transparent gradients: Test file (16.17 KB, application/vnd.oasis.opendocument.presentation)
2011-03-28 14:34 UTC, Fabian
Details
Transparent gradients: Editing mode (rendered rather ok) (101.16 KB, image/png)
2011-03-28 14:35 UTC, Fabian
Details
Transparent gradients: Presentation mode (rendered wrongly) (40.12 KB, image/png)
2011-03-28 14:35 UTC, Fabian
Details
On the first slide, the transparent objects are too dark in presentation mode (816.24 KB, application/vnd.oasis.opendocument.presentation)
2011-05-01 13:21 UTC, markusN
Details
Test file for gradient problems (12.77 KB, application/vnd.oasis.opendocument.presentation)
2011-08-07 09:22 UTC, Raphaël
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian 2011-03-25 17:31:42 UTC
Created attachment 44867 [details]
Test case file matching the "steps to reproduce"

Description:
============
The transparency of brightly filled semi-transparent objects on dark backgrounds is rendered wrongly in presentation mode

Steps to reproduce:
===================
1) Change the page background color to black
2) Create a rectangle
3) Change filling to color white
4) Change transparency to 40%
5) Next to this rectangle, create a rectangle with 60% gray filling without transparency
6) The two should look the same (in editing mode)
7) switch to presentation mode (F5)
8) They transparent one looks darker.
Comment 1 Fabian 2011-03-25 17:33:07 UTC
Created attachment 44868 [details]
Screenshot of the presentation mode: Transparency incorrect.
Comment 2 Fabian 2011-03-25 17:33:40 UTC
Created attachment 44869 [details]
Screenshot of the edit mode: Transparency ok.
Comment 3 Rainer Bielefeld Retired 2011-03-26 01:29:28 UTC
Not Reproducible with reporter's sample document "LibreOffice 3.3.2  – WIN7  Home Premium  (64bit) German UI [OOO330m19 (Build:202 / tag 3.3.2.2)]"

Linux specific or related to particular video card or particular settings?

@Fabian:
Can you try to find out some more information concerning the reasons of your problem?
Comment 4 Fabian 2011-03-28 14:04:07 UTC
Well. I can certainly give some 
more information on my system:
******************************

Kubuntu Linux        10.10 amd64 
Kernel:              2.6.35-28-generic
Xorg Version:        1:7.5+6ubuntu3
Graphics Card:       Ati Radeon HD 4800
Graphics Driver:     Catalyst Version 10.12 (open ati drivers don't work for me)
Desktop Environment: KDE 4.6
Window Manager:      Compiz (but effect's the same with KWIN (with and without composit)

LibO was downloaded via the following repositories:
deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu maverick main

I'm not running the libreoffice-kde package.

Additional info:
****************
- Transparency for objects on white background are ok.
- I've never seen such behavior in the past, but maybe I just didn't have transparent objects on dark background.
- I've tested some other objects. See below.
Comment 5 Fabian 2011-03-28 14:32:22 UTC
Additional Tests:
*****************
- Transparent images -
no problems. are rendered ok in editing and presentation mode

- Gradients - 
Two problems here:
1) Neither in editing mode nor in presentation mode the transparent (white to black) gradient matches the non-transparent (grey to black) gradient.

2) The rendering is different in edit and presentation mode, latter is too bright.
I've added the source file and the 2 screen shots.
left:   transparent gradient (black to white, 40% tranparency)
right:  non-transparent (should-be-) equivalent (60% grey to white)
bottom: black-to-white gradient in 10%-steps of transparency. Only "0%" and "100%" are rendered right, but I suppose these cases are handled separately.
Comment 6 Fabian 2011-03-28 14:34:10 UTC
Created attachment 44974 [details]
Transparent gradients: Test file
Comment 7 Fabian 2011-03-28 14:35:07 UTC
Created attachment 44975 [details]
Transparent gradients: Editing mode (rendered rather ok)
Comment 8 Fabian 2011-03-28 14:35:57 UTC
Created attachment 44976 [details]
Transparent gradients: Presentation mode (rendered wrongly)
Comment 9 Fabian 2011-03-28 15:02:41 UTC
Some more info on the "border" colors of the gradients
******************************************************
For the given example 
- black background, 
- gradient with-to-black and 
- transparencies 0%..10%..20%....100%) 
the border colors (white and black) are mapped to the following intensity values in presentation mode (multiply by 255 to get the actual rgb values)

white: 100%, 90%, 80%, 70%, 60%, 50%, 40%, 30%, 20%, 10%, 0% (<- which is correct)
black:   0%,  9%, 16%, 21%, 24%, 25%, 24%, 21%, 16%,  9%, 0%

So black is brightened up to a maximum of 25%, following something like a parabolic function...
Comment 10 Rainer Bielefeld Retired 2011-04-05 22:55:03 UTC
[Reproducible] with rerporters "transparency_with_gradient.odp" and "LibreOffice 3.3.2  – WIN7  Home Premium  (64bit) German UI [OOO330m19 (Build:202 / tag 3.3.2.2)]", 64 bit AMD Phenom II X4 955 Processor 32.2 GHz, 4GB RAM, 
Graphic Card: NVIDIA GeForce GT 430. 

Left "Gradient white to black Transparency 40%" more or less looses gradient in presentation mode.

@Radek:
One for you?
Comment 11 markusN 2011-05-01 13:19:20 UTC
I have the same problem with

rpm -qa | grep libre | grep impress
libreoffice3-impress-3.3.2-202

Linux north 2.6.33.7-desktop-2mnb #1 SMP Mon Sep 20 18:19:20 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

I have attached an example.
Comment 12 markusN 2011-05-01 13:21:52 UTC
Created attachment 46229 [details]
On the first slide, the transparent objects are too dark in presentation mode
Comment 13 Rainer Bielefeld Retired 2011-05-02 04:12:48 UTC
OS "All" due to Comment 10

Related to "Bug 36547 - Impress: Rendering problems with some .odp files"?
Comment 14 markusN 2011-05-17 15:08:54 UTC
This is a real showstopper, forcing me to reinstall Openoffice just 
for this bug... I hope it can be fixed soon.
Comment 15 Radek Doulik 2011-07-12 04:41:40 UTC
I have fixed this problem in master branch and sent for review to include in 3-4 branch as well.
Comment 16 markusN 2011-07-27 15:22:13 UTC
Please backport it to the upcoming 3.4.2 release to enable us to professionally use LibrOffice. Thanks!
Comment 17 Raphaël 2011-08-05 10:27:28 UTC
I suggest to reopen this bug: see my attachment and comment in bug 36766 !
Comment 18 Fabian 2011-08-05 16:31:00 UTC
LibreOffice 3.4.2 
OOO340m1 (Build:203)

I agree with Raphaël:
Gradients are still rendered as wrongly as before.

tested with 4th attachment: 
https://bugs.freedesktop.org/attachment.cgi?id=44974
Comment 19 Fabian 2011-08-05 16:32:13 UTC
(In reply to comment #0)

This seems to be fixed in LibreOffice 3.4.2 OOO340m1 (Build:203)
Comment 20 Rainer Bielefeld Retired 2011-08-07 08:10:58 UTC
@Raphaël
I can't see a direct relation to your comments somewhere in other bugs. Do not touch Status pickers!
Leave a comment here why you want to see this bug reopened.

I will close this Bug again without further information.
Comment 21 Fabian 2011-08-07 08:51:42 UTC
@Rainer:
In my initial report, I seem to have mixed up two issues. 
Only one of the two is fixed!

1) wrong transparency for color filled objects 
to be tested with https://bugs.freedesktop.org/attachment.cgi?id=44867)
This is fixed in 3.4.2 OOO340m1 (Build:203)


2) wrong transparency for gradient filled objects 
(test with https://bugs.freedesktop.org/attachment.cgi?id=44974)
This is NOT fixed in 3.4.2 OOO340m1 (Build:203)

So maybe it's sensible to split the reports up...? I'm not sure about the best way to handle this.
Comment 22 Raphaël 2011-08-07 09:16:35 UTC
(In reply to comment #20)
> @Raphaël
> I can't see a direct relation to your comments somewhere in other bugs. Do not
> touch Status pickers!
> Leave a comment here why you want to see this bug reopened.
> 
> I will close this Bug again without further information.


I refered to comment 5 in bug 36766, with my test file in attachment: gradients are not correctly rendered in LibO 3.4.2 OOO340m1 (Build:203). The reporter of this bug 35682, Fabian, seems to agree with me (see comment 18 above).

In comment 15 above, Mr Radek Doulik said that he had sent the patch for 3.4 branch, and actually something changed in the new version: the specific issue described in comment 0 seems to be fixed in 3.4.2. But problems with gradients still remains, so it seems that the real cause of these issues was not correctly identified (probably something was touched in the rendering process during the migration from openoffice to libreoffice)...

As some of the files attached here by Fabian are still not correctly rendered (for instance the 4th), I think this bug can't be closed...
Comment 23 Raphaël 2011-08-07 09:22:58 UTC
Created attachment 50017 [details]
Test file for gradient problems

I copy here the attachment of the file I sent for bug 36766, which illustrate some issues with gradients.
Comment 24 Rainer Bielefeld Retired 2011-08-07 10:48:24 UTC
Currently I looks as if the document from original report looks fine with with "LibreOffice 3.4.2  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:203)]". The question is - why? Fixed or Linux specific? The original Subjed twas  "FORMATTING: Transparency rendered wrongly for bright objects on dark background in presentation mode", what now s´might have had completely different roots.

It's not remarkable that during the confirming and bugfixing process more details and may be completely different bugs with similar appearance show up.

The problem from "Transparent gradients: Test file" (2011-03-28) still is visible for me. 

If my suspect is true (2 different problems in 1 bug, problem from original report fixed) we should

a) reset Subject line to Transparency problem
b) Close this bug again
d) reopen a new bug for Gradient bug, if no other report concerning this bug exists.

@Radek:
For what Bug detail has your Fix been?
Comment 25 markusN 2011-11-02 15:09:55 UTC
Tested on Linux, 64bit, LibreOffice 3.4.3 OOO340m1 (Build:302): the
transparency problem is solved for me. Thanks!
Comment 26 markusN 2011-11-02 15:25:38 UTC
(In reply to comment #25)
> Tested on Linux, 64bit, LibreOffice 3.4.3 OOO340m1 (Build:302): the
> transparency problem is solved for me. Thanks!

Unfortunately I was too hasty... the PDF export is still broken for
transparent polygons, they are still too dark, hence unusable.
Comment 27 Rainer Bielefeld Retired 2011-11-02 22:32:36 UTC
(In reply to comment #26)
> Unfortunately I was too hasty... the PDF export is still broken for
> transparent polygons, they are still too dark, hence unusable.

I  expect a PDF problem to be something completely different from a presentation mode rendering problem. What indications do you see that your problem has the same roots like the reported one? You should submit a new bug for that problem. 

We need information how you tested (with what sample document) in that report.

I close this bug because the original problem has been fixed (due to my own test results and rodo's comment 2011-07-12. There is no indication that the original problem still does exist.

=============================================================================
 THIS REPORT IS ONLY FORT THE PROBLEM WITH THE FIRST ATTACHMENT, ALL OTHER
 PROBLEMS WITH OTHER DOCUMENTS ARE DIFFERENT BUGS TO BE SUBMITTED IN 
 DIFFERENT REPORTS. 
=============================================================================
Comment 28 Raphaël 2011-11-03 06:42:24 UTC
As described in the original report, this bug is actually fixed. But as there is still problems with transparency gradient with some files in attachment here, I opened a new bug with a specific description for remaining problems : see bug 42553.
Comment 29 markusN 2011-12-23 14:12:21 UTC
(In reply to comment #26)
> (In reply to comment #25)
> > Tested on Linux, 64bit, LibreOffice 3.4.3 OOO340m1 (Build:302): the
> > transparency problem is solved for me. Thanks!
> 
> Unfortunately I was too hasty... the PDF export is still broken for
> transparent polygons, they are still too dark, hence unusable.

For the record, submitted as Bug 40143.