Bug 36547 - Impress: Rendering problems with some .odp files
Summary: Impress: Rendering problems with some .odp files
Status: RESOLVED DUPLICATE of bug 33591
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.0 Beta2
Hardware: x86 (IA32) All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Impress-Gradient mab3.4
  Show dependency treegraph
 
Reported: 2011-04-24 12:13 UTC by Raphaël
Modified: 2013-11-24 19:35 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This file is not correctly rendered in impress. (623.55 KB, application/vnd.oasis.opendocument.presentation)
2011-04-24 12:17 UTC, Raphaël
Details
This file illustrate the problem with transparency gradient. (10.41 KB, application/vnd.oasis.opendocument.presentation)
2011-12-23 03:14 UTC, Raphaël
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Raphaël 2011-04-24 12:13:19 UTC
Hello,

I noticed a problem with the .odp file given in attachment: during the diaporama in Impress, the graphical items are not correctly rendered.

For comparison, you can see the difference in the two screen captures inserted in slides 2 and 3, the first beeing the diaporama rendering in Openoffice 2.3, the second in Libreoffice 3.4 beta2 (I didn't check if the problem occurs with other versions of openoffice).

The problem occured on Windows XP SP3, on a computer with an Intel GMA 950 chipset, 1024*600 screen.

As I think it's a big problem if some presentations made with openoffice aren't correctly rendered in Libreoffice, I suggest to evaluate this problem as 'critical': for many people, it will be difficult to switch to Libreoffice if the files made with Openoffice aren't 100% compatible...

Best regards,

Raphaël
Comment 1 Raphaël 2011-04-24 12:17:45 UTC
Created attachment 46028 [details]
This file is not correctly rendered in impress.
Comment 2 Rainer Bielefeld Retired 2011-05-02 04:13:31 UTC
Relate to
"Bug 35681 - VIEWING: Gradient loss for bright transparent objects on dark background in presentation"
and / or 
"Bug 36470 - Transparency rendering grey instead of white in presentation mode"?
Comment 3 Andrea Pescetti 2011-05-02 07:00:22 UTC
It doesn't seem to be LibreOffice specific. OpenOffice.org 3.3 (latest stable) renders it similarly to LibreOffice 3.4 beta: you might want to look for a regression/change in the OpenOffice.org code.
Comment 4 vitruss 2011-05-07 21:00:35 UTC
LO 3.3.2 Renders correct for me (except some characters in "Grandeurs physiques", which I attribute to different fonts). 
Arch Linux current.
Comment 5 Raphaël 2011-05-09 03:06:08 UTC
(In reply to comment #4)
> LO 3.3.2 Renders correct for me (except some characters in "Grandeurs
> physiques", which I attribute to different fonts). 
> Arch Linux current.

@ vitruss: It's the colors of objects that are not correctly rendered. Actually, it's probably a problem of transparency gradient (connected to bug 36766), but it's appears only when diaporama is running (presentation mode)... 

Probably a regression from openoffice 3.2 !
Comment 6 Yifan Jiang 2011-05-26 01:41:08 UTC
Reproduced on 3.4 rc1 / SLED 11 sp1 i586. Update the platform information.

As mentioned, it only happens in Slide Show mode.

Thanks Thorsten/Radek to have a review :)
Comment 7 Rainer Bielefeld Retired 2011-08-08 05:05:43 UTC
Currently I can't see any additional effect to "Bug 36470 - Transparency rendering grey instead of white in presentation mode", so this one might be a DUP?
Comment 8 Rainer Bielefeld Retired 2011-08-16 04:43:20 UTC
No new information, so DUP

*** This bug has been marked as a duplicate of bug 36470 ***
Comment 9 Björn Michaelsen 2011-12-22 05:53:55 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.
Comment 10 Raphaël 2011-12-23 03:12:35 UTC
This bug doesn't seem to be fixed, even in the latest releases of Libreoffice. 

The reason is the following:

This bug 36547 is similar, but not exactly the same, as bug 36470. So it was considered as a duplicate of 36470.

And in turn, Bug 36470 is similar, but not exactly the same, as bug 33591. And this one was considered as a bug of 33591.

Now, Bug 33591 is fixed.

BUT: 33591 is not at all a duplicate of this bug 36547 !!

So, this bug 36547 is not fixed, and there is now no open bug for this problem...

I opened some weeks before the new bug 42553, with a more precise description of the problem underlying this bug 36547, under the title 'problems with transparency gradient'. But Mr Rainer Bielfeld modified the title and truncated my originate file, saying that the problem was already fixed (probably through bug 33591) and he focused on a more specific problem (an additionnal geometrical problem in the gradient rendering).

So, I propose to reopen this one, adding a more precise description than in the original report (now I understand better the underlying problem):

This is a problem with the 'transparency gradient' (linear, axial, radial,
etc) in Impress, when turning to presentation mode. It is a regression from
openoffice, but present since the first version of LibreOffice.

The best way to see it is the following:

1) Make a new slide with black background;

2) Draw a shape and fill area with black (so you have a black shape on black
background);

3) Right click -> Area -> Transparency -> Gradient and choose for instance a
linear one;

4) Start the diaporama (F5) and wait for the rendering: your black form isn't
black anymore !

I added a new file in attachment to illustrate the problem.
Comment 11 Raphaël 2011-12-23 03:14:50 UTC
Created attachment 54742 [details]
This file illustrate the problem with transparency gradient.
Comment 12 Rainer Bielefeld Retired 2012-02-29 09:52:15 UTC
This one is a DUP of "Bug 33591 - Area transparency turns gray in presentation mode" ("Bug 36470 - Transparency rendering grey instead of white in presentation mode")

Closing again.

I reopened Bug 33591, for reasons please see my comment there.

@Raphaël:
Please never reopen bugs!
<https://wiki.documentfoundation.org/BugReport_Details#How_to_reopen_Bugs>

A simple short comment in the correct Bug like
'Still reproducible with sample xxx and "LibreOffice 3.5.1.1 German UI/Locale [Build-ID: 45a2874-aa8c38d-dff3b9c-def3dbd-62463c8] on German WIN7 Home Premium (64bit)' is the thing that helps  8You find the exact version ID in Menu 'Help -> About', everything else only will waste your and our time.

*** This bug has been marked as a duplicate of bug 33591 ***
Comment 13 Raphaël 2012-03-01 02:04:09 UTC
@Rainer Bielfeld: this bug 36547 contains something more than bug 33591. 

In the description of bug 33591, the area who turns gray in presentation mode is filled with 'simple' transparency. And this problem seems to be fixed. But in bug 36547, the problem comes from areas filled with a 'gradient' transparency.

In other terms, the problem is solved for 'simple' transparency (bug 33591), but not for 'gradient' transparency (bug 36547).

So, I don't agree that bug 36547 is a duplicate of bug 33591, even if these two bugs seems similar. I fear some people will close again bug 33591, who is, strictly speaking, fixed, whilst bug 36547 isn't...

I think it would be better to let 36547 open, or to replace it by a new one with a better description who emphasize the fact that the remaining problem concerns the 'gradient' transparency (I admit that my original report wasn't precise enough; I tried to improve it in comment 10 above). What do you think?
Comment 14 Rainer Bielefeld Retired 2012-03-01 03:26:19 UTC
@Raphaël
No! Samples here are referenced, the Fix for Bug 33591 has also to show Samples in Bug 36547 correctly. No further discussion here required!