Bug Hunting Session
Bug 36443 - Toolbars do not show in LibreOffice Base 3.3.2 (while making a form or a report)
Summary: Toolbars do not show in LibreOffice Base 3.3.2 (while making a form or a report)
Status: CLOSED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Björn Michaelsen
URL:
Whiteboard:
Keywords:
: 33032 (view as bug list)
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-04-20 16:43 UTC by Marqeaux
Modified: 2011-12-24 04:27 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Open form - no navigation-bar. Edit form - not possible. (10.30 KB, application/vnd.sun.xml.base)
2011-04-22 10:21 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marqeaux 2011-04-20 16:43:47 UTC
The summary says it all: The toolbars in LibreOffice Base 3.3.2 don't show up in the first place when you open a new form, or modify an existing form in design view in the Base component of LibreOffice. The same thing happens when you make or modify a report in Base.

When I try to add a toolbar, it immediately disappears when I change the size of the window, or when I try to add a second toolbar.

That's all I can say about this slight problem. I hope you can reproduce it. I am not very good at this, but I wanted to let you know about this minor bug.

Kind regards,
Marco.
Comment 1 Robert Großkopf 2011-04-22 10:21:55 UTC
Created attachment 45959 [details]
Open form - no navigation-bar. Edit form - not possible.

Same problem with LibreOffice in openSuSE: Editing of forms is not possible. Only the first time with the assistant base shows the toolbars.
Another problem - could be the same: Navigation-bar is not shown.

Robert
Comment 2 Robert Großkopf 2011-04-22 10:25:44 UTC
I have changed the platform to "All" and the importance to "high" and "major", because base isn't usable for editing new databases.

Robert
Comment 3 Robert Großkopf 2011-04-22 11:59:01 UTC
Excuse me. I have tested it with the version of OpenSuSE. The original version of LibreOffice works well. Forms could be edited, toolbars appear and didn't disappear.

I have changed all values back (sse comment 2)

Robert
Comment 4 Björn Michaelsen 2011-05-16 10:58:53 UTC
Adding lp#709778 with four dupes and lots of additional info. This is indeed a serious issue, however not reproducible on all machines/setups. It is _not_ an Ubuntu only bug, see:
 https://bugs.launchpad.net/df-libreoffice/+bug/709778/comments/27
 https://bugs.launchpad.net/df-libreoffice/+bug/709778/comments/32
Comment 5 Björn Michaelsen 2011-05-16 11:17:55 UTC
*** Bug 33032 has been marked as a duplicate of this bug. ***
Comment 7 SchneiderH 2011-05-17 06:42:19 UTC
The solution of this bug is very important for me because I want to switch over from Microsoft Windows to Ubuntu. I'm working with databases and LibreOffice frontends. At the moment I can't work with the Linux version of LibreOffice.

The windows version of LibreOffice doesn't have this problem.

Regards
Herbert
Comment 8 Björn Michaelsen 2011-05-17 08:34:06 UTC
Confirmed on current master without any vendor patching.
Comment 9 Björn Michaelsen 2011-05-17 11:22:11 UTC
Confirmed on current 3.4 release branch without any vendor patching. Given that this was reported _not_ to happen on the 3.3.2 release without vendor patching, this is a regression.
Comment 10 Björn Michaelsen 2011-05-17 11:34:53 UTC
@Noel: Assigning to you for further info.
As the bug was not observed in libreoffice 3.3.2 upstream builds, but was observed in OpenSUSE and Ubuntu vendor builds and is being observed in the current 3.4, this is most likely one of the integrated patches from libreoffice/build. Any hints on likely candidates for triage?
Comment 11 Stefan Gruber 2011-05-17 13:39:24 UTC
(In reply to comment #9)
> Confirmed on current 3.4 release branch without any vendor patching. Given that
> this was reported _not_ to happen on the 3.3.2 release without vendor patching,
> this is a regression.

It is very painful indeed...
I'm joining this bugzilla, because I reported this bug to Novells Bugzilla für LibreOffice (#686354), but nothing happened yet.

Maybe my observations (using opensuse 11.x) will help you to find the bug:

I first encountered this fault last autumn in the 3.3rc-Versions of OpenOffice; later in the 3.3rc of  LibreOffice and all final Versions since then.
Note that I always got Open/LibreOffice from the opensuse-buildservice.

All corresponding native packages of Open/LibreOffices didn't show this effect, as you mentioned.
So I assumed, it was a opensuse/Novell thing.

For some weeks I noticed  several  reports of this issue in usenet by users with brand-new e.g. ubuntu-linux, so this seems to be not opensuse-only.

It is slightly horrifying news, that this came into the pure LibreOffice code, because this will make work with databases completely impossible!

(Currently I'm using opensuse-builds, because they have a better KDE-Integration. For databases only I have native version installed additionally.)

Besides this, there is another problem with *existing* forms: control dialogs of form elements do not appear called by context menu. So after solving this bug, that would be the next problem.
Comment 12 Michael Meeks 2011-05-19 09:40:44 UTC
Bjoern would greatly appreciate some hints on which ooo-build patches might have caused this (Noel - any ideas ?).
Comment 13 Noel Power 2011-05-24 04:37:27 UTC
(In reply to comment #12)
> Bjoern would greatly appreciate some hints on which ooo-build patches might
> have caused this (Noel - any ideas ?).

as mentioned on irc...

https://bugzilla.novell.com/show_bug.cgi?id=689375 looks like a likely candidate, Still, I cannot understand how this would be reproducible on 3.4 ( without distro patches ) so... still not clear we are dealing with the same thing ( looks like it though )
Comment 14 Björn Michaelsen 2011-05-24 05:27:31 UTC
This is how I reproduced the the issue with the last time:

build smoketest
cd solver/340/unxlngx6.pro/installation/
./opt/program/soffice
- select database in startcenter
- create new database, click finish
- confirm filename
- Use Wizard to create table -> AssetID -> ">>" -> Finish
- Forms -> Create Form in Design View
-> no toolbars?

However I now have toolbars but on 2011-05-17 I had not. Instead I had:
 https://launchpadlibrarian.net/63089243/screenshot3.png
(not my screenie, but I saw the same)

So this is a Heisenbug or accidently fixed. On the launchpad bug you see people observing the bug on one machine, but not on a different one. I tested on the same machine. My money is on this being a Heisenbug.

I wish I was already logging repostates of my builds last week. I will keep an eye on this one from now on.
Comment 15 Noel Power 2011-05-24 08:35:08 UTC
(In reply to comment #14)
> However I now have toolbars but on 2011-05-17 I had not. Instead I had:
>  https://launchpadlibrarian.net/63089243/screenshot3.png
the screenshot is exactly what I saw with https://bugzilla.novell.com/show_bug.cgi?id=689375 
> (not my screenie, but I saw the same)
> 
> So this is a Heisenbug or accidently fixed. On the launchpad bug you see people
> observing the bug on one machine, but not on a different one. I tested on the
> same machine. My money is on this being a Heisenbug.
it seems to be too coincidental to see this same effect[*], are you positive that you saw this on 3.4 branch ? Anyway, keep an eye out

[*] ALL toolbars gone
Comment 16 Ferry Toth 2011-05-28 14:22:42 UTC
The above discussion sounds like the problem is difficult to reproduce.

In fact it is simple and quick and exactly as Björns comment 14.

On Ubuntu Natty (i32 and amd64)
LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2, Ubuntu package 1:3.3.2-1ubuntu5

the result is exactly the same:

When opening a form to enter data there are no navigation bars, no tool bars and no status bar. You can only add a record by clicking on the last field and pressing enter. You can manually add the navigation bar, but it will disappear after close/reopen the form. You can not add the status bar. And if you try to add the formating toolbar the navigation bar will disappear.

When editing a form there are no Form Design and Form Control toolbars. Also you cannot click a control to get to these tools, so you can not change your form at all, other then drag the control around a bit.

I think more needs to be done then 'keep an eye out'.

I just downloaded 3.3.2 Final (22-03-2011) (the deb version) from the LO web site, installed on a Maverick VM with OO wiped off.

LO is same build OOO330m19 (Build:202). Guess what, here Data entry and Forms Editing work fine.

This suggests a packaging problem in Ubuntu.

So then upgraded to LibreOffice 3.4 RC2 (2011-05-27)
LibreOffice 3.4.0 
OOO340m1 (Build:12)

Also NO problems here (with forms).

So it actually does seem to be a packaging problem. But then one then occurs on multiple distributions - not just Ubuntu.

Now what. None of the user with Natty installed is currently able to do any useful database work.

We need a fix in Natty and quick too.

Ferry
Comment 17 Björn Michaelsen 2011-05-28 18:01:58 UTC
@Ferry: No, this bug is _not_ easily reproducible. If you look at the launchpad bug some people have can produce the issue on one machine but cannot on another with the same version.

Also this is not a "packaging problem in Ubuntu" -- it was most likely introduced by the go-oo patches that were applied as a de-fact standard by almost all distributions including SUSE, Debian, Ubuntu for the 3.3 branch. Those are some 500 patches which is why I asked about some hints which ones could be the problematic ones.

On 3.4 these patches have been included in all versions including those directly available from the libreoffice website -- they are not patches anymore. As this could not be reproduced in the recent 3.4.0 rcs, we however still need to keep an eye out for it to pop up again as it might just be a Heisenbug that is hiding.

Also adding Debian bug 617319 for reference: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=617319
Comment 18 Björn Michaelsen 2011-05-29 03:20:11 UTC
Adding Novell bug url.

In the Novell bug, optional-outplace-ole.diff is assumed to be the root cause of the problem. However, I just did a Ubuntu/Debian build without that patch, and the problem persists.
Comment 19 Björn Michaelsen 2011-05-29 05:09:20 UTC
additionally removed the patchsets Layout, VBABits, VBAObjects, LayoutDialogs, VBAUntested, but the bug persists.
Comment 20 Björn Michaelsen 2011-05-29 08:01:17 UTC
ignore the last two comments: I had an old soffice.bin instance running. it is indeed optional-outplace-ole.diff causing the trouble.
Comment 21 Ferry Toth 2011-05-29 09:03:39 UTC
@Björn,

I didn't mean to say that the problem would be easy to debug. Or solely a Ubuntu problem, as I am well aware that it happens at least on Debian too.

I am glad you located the offending patch. Does it explain why "some people can produce the issue on one machine but cannot on another with the same version"?

If I could have found a machine that didn't have the problem I wouldn't have been that desperate. I tried new installs, older upgrades, i32 and amd64, VM. All the same.

I think some confuse the form showing 'read only' with 'cannot enter data in the form'.

Will the 'rebuild' show up in the PPA? I can't wait to try it.

Ferry
Comment 22 Björn Michaelsen 2011-05-29 12:28:42 UTC
closing as fixed as it is not reproducible in the current unpatched 3.3 and 3.4 branches.
Comment 23 Björn Michaelsen 2011-05-29 14:40:24 UTC
@Ferry: FYI, the fixed version is currently building in the ppa.
Comment 24 Stefan Gruber 2011-05-31 14:19:43 UTC
Many thanks for your succeeding efforts, Björn...

I really hope, that this bug will not rise again in the downstream versions by ubuntu or in my case opensuse.
Comment 25 Keith Clark 2011-07-07 15:28:46 UTC
How is this fixed?  I have Libre Office 3.3.2 installed on my Ubuntu 11.04 machine and this is still happening to me.
Comment 26 NoOp 2011-07-07 18:58:04 UTC
Works for me in (linux) 3.3.3 & 3.4.1. 

Still does not work in Ubuntu 3.3.2, so it appears to be a distro packaging/update/upgrade issue.
Comment 27 Björn Michaelsen 2011-07-11 05:32:51 UTC
Never been an issue with the plain native build. Fixed in 3.3.3 release which will be SRUed for Natty and all further releases on Ubuntu and Debian.

Again: Please dont reopen, not an upstream issue, as not in the master repo.
Comment 28 Björn Michaelsen 2011-12-24 04:27:29 UTC
closing