Bug Hunting Session
Bug 36492 - Configure which fonts are visible in font selection
Summary: Configure which fonts are visible in font selection
Status: RESOLVED DUPLICATE of bug 88416
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog Font-List
  Show dependency treegraph
 
Reported: 2011-04-22 08:19 UTC by Simon Oosthoek
Modified: 2017-11-04 10:32 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Oosthoek 2011-04-22 08:19:59 UTC
Whenever I create or work on a document I use only a very limited set of fonts. On my system (linux/kubuntu) I have any number of fonts installed for various purposes, 99% (or thereabouts) of which I don't use in my document.

It would greatly improve the usability (mine and probably most people's) if I could configure which font (families) I can select from the font dialogue.

I know about styles and their goodness, but very often choosing a font for a specific selection of text is more convenient than using styles.

Obviously, a relatively easy method should be available to show all fonts on the system, a gesture and a quick toggle in the list or menu ("font filter" on/off)
Comment 1 Björn Michaelsen 2011-12-23 12:05:01 UTC Comment hidden (obsolete)
Comment 2 Florian Reisinger 2012-08-14 14:03:09 UTC Comment hidden (obsolete)
Comment 3 Florian Reisinger 2012-08-14 14:04:04 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:08:37 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:10:39 UTC Comment hidden (obsolete)
Comment 6 Simon Oosthoek 2012-08-14 14:18:53 UTC
In my version of libreoffice 3.5.4 I still see no improvement (too many fonts)

I suppose you need to clean up old bugs, but closing this one 4 times is overdoing it a little... ;-)

Anyway, I still think this would be a great improvement for usability!

/Simon
Comment 7 Florian Reisinger 2012-08-15 07:19:36 UTC
Yep that would be a nice improvement (PS: I sent this message only once ;) )
Comment 8 Joel Madero 2013-12-22 15:56:08 UTC
*** Bug 60626 has been marked as a duplicate of this bug. ***
Comment 9 Thomas Lendo 2017-10-18 22:22:21 UTC
Adding needsUXEval and some CC users to ask the UX team for input if this is possible and desirable and how it could be realized.
Comment 10 Heiko Tietze 2017-10-19 07:33:20 UTC
Fully agree on this. Personally I remove as many fonts as possible from my system as 'solution' for this issue - and still have the annoying D050000L, Z003, C059 etc. We need some kind of 'hide this font' feature, where a tree allows to exclude all variants of a family. Could be merged into the Tools > Options > Fonts replacement table. Would do a mockup when a dev is interested.

(Dealing with missing fonts has been discussed here https://design.blog.documentfoundation.org/2016/10/21/dealing-with-missing-fonts/)
Comment 11 Yousuf Philips (jay) (retired) 2017-10-19 11:05:54 UTC
This is a duplicate of bug 88416 which has more info in it along with screenshots. A smaller default font list is mentioned in bug 91130.

*** This bug has been marked as a duplicate of bug 88416 ***