Bug Hunting Session
Bug 60626 - Allow custom font sorting
Summary: Allow custom font sorting
Status: RESOLVED DUPLICATE of bug 91130
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks: Font-List
  Show dependency treegraph
 
Reported: 2013-02-11 06:37 UTC by afterthebeep
Modified: 2018-09-03 06:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description afterthebeep 2013-02-11 06:37:04 UTC
The font drop down listing gets extremely pointless to navigate when it contains more than ~100 fonts.  Many users have 500+ fonts and don't recall what each nice serif one is named.

I propose a feature that would allow a user to alternately list the fonts if they would like.  This way one who wanted to could put all the serif fonts together, all the outline fonts together, all the monospace together, etc...

It would be wonderful if this was in a settings window that allowed dragging/dropping of the font list to setup the user's custom list.  Possible exporting of that list would also be extremely wonderful but slightly unnecessary.
Comment 1 Linus Drumbler 2013-02-16 05:14:42 UTC
There are other applications to perform this function.
Comment 2 Owen Genat (retired) 2013-09-13 23:15:28 UTC
This would appear to be a duplicate of bug #36492. If the original reporter can confirm this (or make the distinction more clear) that would be good. With regard to comment #1, this is true, but at present LO does not support all these methods on all platforms.
Comment 3 afterthebeep 2013-09-15 22:23:20 UTC
Technically, bug #36492 is requesting a different feature - a filter on the fonts list rather than a method for custom sorting.  But the spirit of that bug is in the same spirit as this one.  Same original annoyance, but different solution (I personally prefer the custom sorting solution, but good cases can be made for either solution).

In regards to comment #1 I would love to see any program that can do this.  Please elaborate and give specifics as to which program(s) is/are able to sort fonts within LibreOffice.
Comment 4 Owen Genat (retired) 2013-12-21 13:03:03 UTC
Thanks for clarifying. I can't confirm this report as it still seems very similar to the bug I indicated and not as effective. Filtering a list of 500 fonts (e.g., down to a dozen) would seem more useful to me than sorting the entire list. There is less scrolling involved. The User Experience (UX) would be similar to that for the current filtering of styles. I would also argue that filtering is the generally favoured UX approach over sorting in most instances.

Component set to UI. Version set to Inherited From OOo as this feature has never been available.
Comment 5 Joel Madero 2013-12-22 15:56:08 UTC
@Owen - enhancements are slightly different than regular bugs in terms of version #, we like to know when the request was requested instead of "when the bug appeared" -- since otherwise essentially every enhancement would be "inherited from OOo".

That being said - for now closing this as a dupe as I think the other request would give the same functionality (or very similar) in a much cleaner way. As Owen pointed out, sorting 500 fonts seems almost as pointless as having them unsorted, this compared to just selecting the fonts you want and hiding the other ones so your list is manageable to begin with.

Closing as DUPE, but if someone REALLY wants this to be an additional feature request, set it as NEW instead - please explain the usefulness of this in comparison to bug 36492, as both of them would require quite a bit of developer time and if the other enhancement gets the same functionality, no need to waste our devs time.


Thanks for the request!

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material

*** This bug has been marked as a duplicate of bug 36492 ***
Comment 6 afterthebeep 2013-12-22 20:20:13 UTC
I wanted to clarify a difference between this bug and bug 36492.  People who have 500+ fonts installed will often use well over 100 of them on a regular basis.  Filtering the fonts will hopefully not restrict the user to only using the selected filtered fonts.  Sorting them would obviously easily allow all fonts to be used at any given time.  I'd like to hear what benefit to the user experience a filtered list of fonts would achieve over a sorted list of fonts as I really do believe that the sorted option would be preferable.

Should this bug be re-opened?  or should this discussion continue on the thread of bug 36492?
Comment 7 Joel Madero 2013-12-22 21:23:13 UTC
Nope - if people are using 100+ fonts then, well I suppose this is a unique request :)
Comment 8 Joel Madero 2014-02-27 22:55:20 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 9 Robinson Tryon (qubit) 2015-12-13 11:20:59 UTC Comment hidden (obsolete)
Comment 10 Heiko Tietze 2018-09-03 06:59:05 UTC

*** This bug has been marked as a duplicate of bug 91130 ***