Bug 36587 - FILESAVE, FORMATTING. Conditional Formatting and Compatibility Excel.
Summary: FILESAVE, FORMATTING. Conditional Formatting and Compatibility Excel.
Status: RESOLVED DUPLICATE of bug 36379
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-25 11:11 UTC by xoy
Modified: 2012-11-24 15:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test file (18.50 KB, application/vnd.ms-excel)
2011-04-25 11:11 UTC, xoy
Details
test file - after seving (6.50 KB, application/vnd.ms-excel)
2011-04-25 11:15 UTC, xoy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xoy 2011-04-25 11:11:11 UTC
Created attachment 46061 [details]
test file

excel 2007 ru
liberoffice 3.3.0

When you save an XLS garbles "improves" cell address
in excel Initially, it was: И=AND
=И($E14="p2";F14<>"";$G14<>0)

opening in LibreOffice was: Лист=sheet
AND(Лист1.$E14="p2";Лист1.F14<>"";Лист1.$G14<>0)

and after a save in XLS obtain in Excel:
=И(Лист1!$E1="p2";Лист1!IV1<>"";Лист1!$G1<>0)

But in LiberOffice same file is opened:
AND($Лист1.$E14="p2";$Лист1.F14<>"";$Лист1.$G14<>0)


workaround
=И($E$14="p2";$F$14<>"";$G$14<>0)

after saving
formatting will work, but trying to adjust Excel would be a mistake for the presence of names of sheets in a formula ...


sorry my excuse english...
Comment 1 xoy 2011-04-25 11:15:30 UTC
Created attachment 46062 [details]
test file - after seving
Comment 2 Björn Michaelsen 2011-12-23 12:02:39 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 xoy 2012-03-20 21:46:17 UTC
The problem still exists.
Comment 4 Giuliano 2012-04-12 16:08:12 UTC
Hi xoy.
Should in Ms Excel xls conditional formatting, sheet reference NEVER be used ?
Should this be the error xls exporting ?

The xls generated seems not to comply with Ms format
Comment 5 Markus Mohrhard 2012-10-11 11:02:27 UTC
Ok. So I had a look at this one.

All tests done in master with my latest changes to the cond format handling.

Import of the file looks correct. The leading sheet name is not a problem because it is a relative sheet reference like in Excel.

The problem is that the export generates then absolute sheet references. I can't reproduce the other issue with master and Excel 2010.

I'll have a look at the cond format export and try to find the code that writes the absolute sheet refs instead of the relative ones.
Comment 6 Markus Mohrhard 2012-11-24 15:02:41 UTC

*** This bug has been marked as a duplicate of bug 36379 ***