Bug Hunting Session
Bug 36379 - EDITING , FORMATTING: Conditional Formatting formula changed by LibO & OOo
Summary: EDITING , FORMATTING: Conditional Formatting formula changed by LibO & OOo
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:4.0.0
Keywords:
: 36587 48785 57076 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-19 00:30 UTC by marc.claes.369
Modified: 2012-11-24 15:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
series of random numbers; cond. form. colors largest & 2nd largest (19.50 KB, application/vnd.ms-excel)
2011-04-19 00:30 UTC, marc.claes.369
Details
series of random numbers; cond. form. colors largest & 2nd largest - corrected (19.50 KB, application/vnd.ms-excel)
2011-04-20 00:31 UTC, marc.claes.369
Details
45845: series of random numbers; cond. form. colors largest & 2nd largest - 2xcorrected (19.00 KB, application/vnd.ms-excel)
2011-04-20 23:02 UTC, marc.claes.369
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marc.claes.369 2011-04-19 00:30:55 UTC
Created attachment 45798 [details]
series of random numbers; cond. form. colors largest & 2nd largest

When entering a conditional formatting formula in MS Excel, sheet references are not allowed. Opening a .xls file with cond. form. in OOo or LibO, (editing and) saving it as .xls, then opening the saved file again in Excel shows the "corruption" done by OOo and LO: cell references in cond. form. formulas get prepended by sheet references, which generates an error message in Excel.

See the file attached:
- open with Excel: no problem
- open with OOo or LibO: no problem
- save as .xls in OOo or LibO: no problem
- now open saved file again in Excel: cond. form. formulas give error message.
Comment 1 Kohei Yoshida 2011-04-19 06:58:13 UTC
Could you attach the original Excel file that Excel opens without problem?  The attached file is already damaged and even opening it in Excel shows #NAME! errors.
Comment 2 marc.claes.369 2011-04-20 00:31:49 UTC
Created attachment 45845 [details]
series of random numbers; cond. form. colors largest & 2nd largest - corrected

My mistake. Sorry.
Hope this does it...
Comment 3 Kohei Yoshida 2011-04-20 06:02:08 UTC
Hmm... Excel still shows a bunch of #NAME! errors even with the 2nd file...
Comment 4 marc.claes.369 2011-04-20 23:02:58 UTC
Created attachment 45904 [details]
45845: series of random numbers; cond. form. colors largest & 2nd largest - 2xcorrected

See mail for 2nd correction.
Sorry again...
Comment 5 Giuliano 2012-04-16 15:58:00 UTC
Similar to Bug 48785
Comment 6 Giuliano 2012-04-24 00:59:32 UTC
Bug may be related also to https://bugs.freedesktop.org/show_bug.cgi?id=36587

It seems indeed that when opening the file (in bug 36587 ), the formula is modified. 
So an IMPORT xls formula bug.

Maybe they can be merged together ?
Comment 7 Markus Mohrhard 2012-04-30 17:51:13 UTC
*** Bug 48785 has been marked as a duplicate of this bug. ***
Comment 8 Markus Mohrhard 2012-11-24 14:59:52 UTC
*** Bug 57076 has been marked as a duplicate of this bug. ***
Comment 9 Markus Mohrhard 2012-11-24 15:02:41 UTC
*** Bug 36587 has been marked as a duplicate of this bug. ***
Comment 10 Not Assigned 2012-11-24 15:04:11 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d1def6b029ad941d0b2cbecd8f682ae0d33ddd79

don't make 2D refs 3D refs in the cond format import, fdo#36379



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.