Bug 57076 - Import of XLS of conditional formatting in FILEOPEN prepends the sheet name to cell names
Summary: Import of XLS of conditional formatting in FILEOPEN prepends the sheet name t...
Status: RESOLVED DUPLICATE of bug 36379
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: All Windows (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-13 16:31 UTC by Paul Kinzelman
Modified: 2012-11-24 14:59 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Kinzelman 2012-11-13 16:31:56 UTC
If I have an XLS file created in Excel, and a cell has a Conditional Format formula like:
            =AND(D6<$B6,COUNT(D6))

and I import it into Calc, what I see instead is:
            AND('2012'.D6<'2012'.$B6,COUNT('2012'.D6))
where '2012' is the name of the sheet.

The formula is arithmetically correct, but it's got extra stuff in there which I don't want to see.

The import should import exactly what the formula is and should not add any embellishment.

This bug has been in a number of versions, and even in openoffice.
Comment 1 Markus Mohrhard 2012-11-14 05:48:08 UTC
This would be just a cosmetic fix.

The formulas are exactly the same.
Comment 2 Paul Kinzelman 2012-11-14 14:14:28 UTC
While I agree the two formulas would result in the same format, clearly they are *not* the same and so I would not call the fix "cosmetic". I'd really like the formula to stay as originally written so I don't have to be as concerned that everything gets changed correctly if I make a new copy of the page.

I suspect it's just an "if" statement that's not working, it should be a trivial fix which is why I'm asking that it be fixed.
(In reply to comment #1)
> This would be just a cosmetic fix.
> 
> The formulas are exactly the same.

While I agree the two formulas would result in the same format, clearly they are *not* the same and so I would not call the fix "cosmetic". I'd really like the formula to stay as originally written so I don't have to be as concerned that everything gets changed correctly if I make a new copy of the page.

I suspect it's just an "if" statement that's not working, it should be a trivial fix which is why I'm asking that it be fixed.
Comment 3 Markus Mohrhard 2012-11-24 14:45:15 UTC
Please attach a test document to the bug report.
Comment 4 Markus Mohrhard 2012-11-24 14:59:52 UTC

*** This bug has been marked as a duplicate of bug 36379 ***